Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0041546
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] A. Platformmajorhave not tried2019-08-01 13:182019-08-06 13:34
ReporterplujanView Statuspublic 
Assigned Tojarmendariz 
PrioritynormalResolutionfixedFixed in Version3.0PR19Q3
StatusclosedFix in branchFixed in SCM revision2d4114115307
ProjectionnoneETAnoneTarget Version3.0PR19Q3
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionmainSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date
Regression introduced in release3.0PR19Q1
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0041546: Errors in build from UI are not shown

DescriptionI am rebuilding the system after installing a module. It seems the module has some dependency issue, but the expected message of error is not shown. Instead, from the GUI seems the rebuild was successful, while the log is showing that it was not.
Steps To ReproduceIn order to reproduce the issue it is required to install via the MMC a module with an error like this one:
[java] org.apache.ddlutils.model.ModelException: The foreignkey EM_OBRESMS_ORDER_RESERVATION in table C_ORDER references the undefined table OBRE_RESERVATION

Launching the Rebuild process, it finishes (or seems to finish) successfully, since a green banner "Process Completed Successfully" is shown. But looking at the log shows a different story (the error message shown above is from the log)

For more information, check the attached screenshot. The full log is also available on demad.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0041524 closedjarmendariz Errors in build from UI are not shown 

-  Notes
(0113816)
hgbot (developer)
2019-08-05 13:54

Repository: erp/backports/3.0PR19Q3
Changeset: 2d4114115307f38b92c543348bf5311a638a9c96
Author: Javier Armendáriz <javier.armendariz <at> openbravo.com>
Date: Mon Aug 05 13:34:07 2019 +0200
URL: http://code.openbravo.com/erp/backports/3.0PR19Q3/rev/2d4114115307f38b92c543348bf5311a638a9c96 [^]

Fixed issue 41546: Errors in build from UI are not shown

Log4j configuration is missing in BuildTask ant task. This causes
that when this task fails, the error message is not passed to
OBRebuildAppender and thus the process finishes as successful from
the point of view of the UI.

---
M build.xml
M src-core/src/org/openbravo/utils/OBRebuildAppender.java
M src/org/openbravo/erpCommon/ad_process/ApplyModulesResponse.java
---
(0113844)
alostale (developer)
2019-08-06 13:34

reviewed + tested

- Issue History
Date Modified Username Field Change
2019-08-05 13:24 jarmendariz Type defect => backport
2019-08-05 13:24 jarmendariz Target Version => 3.0PR19Q3
2019-08-05 13:54 hgbot Checkin
2019-08-05 13:54 hgbot Note Added: 0113816
2019-08-05 13:54 hgbot Status scheduled => resolved
2019-08-05 13:54 hgbot Resolution open => fixed
2019-08-05 13:54 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR19Q3/rev/2d4114115307f38b92c543348bf5311a638a9c96 [^]
2019-08-05 13:56 jarmendariz Summary [19Q3] A failed rebuild shows a success message => Errors in build from UI are not shown
2019-08-06 13:34 alostale Review Assigned To => alostale
2019-08-06 13:34 alostale Note Added: 0113844
2019-08-06 13:34 alostale Status resolved => closed
2019-08-06 13:34 alostale Fixed in Version => 3.0PR19Q3


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker