Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0041524
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajorhave not tried2019-08-01 13:182019-08-22 14:45
ReporterplujanView Statuspublic 
Assigned Tojarmendariz 
PrioritynormalResolutionfixedFixed in Version3.0PR19Q4
StatusclosedFix in branchFixed in SCM revisionabfb012807e4
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionmainSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2018-11-19
Regression introduced in release3.0PR19Q1
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/4d00819f3952ff85dae35810a6a47c2f2bbfaed8 [^]
Triggers an Emergency PackNo
Summary

0041524: Errors in build from UI are not shown

DescriptionI am rebuilding the system after installing a module. It seems the module has some dependency issue, but the expected message of error is not shown. Instead, from the GUI seems the rebuild was successful, while the log is showing that it was not.
Steps To ReproduceIn order to reproduce the issue it is required to install via the MMC a module with an error like this one:
[java] org.apache.ddlutils.model.ModelException: The foreignkey EM_OBRESMS_ORDER_RESERVATION in table C_ORDER references the undefined table OBRE_RESERVATION

Launching the Rebuild process, it finishes (or seems to finish) successfully, since a green banner "Process Completed Successfully" is shown. But looking at the log shows a different story (the error message shown above is from the log)

For more information, check the attached screenshot. The full log is also available on demad.
TagsNo tags attached.
Attached Filespng file icon FailedRebuildSuccessful.png [^] (56,135 bytes) 2019-08-01 13:18

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00415463.0PR19Q3 closedjarmendariz Errors in build from UI are not shown 
depends on backport 00415473.0PR19Q2.2 closedjarmendariz Errors in build from UI are not shown 
depends on backport 00415483.0PR19Q1.3 closedjarmendariz Errors in build from UI are not shown 
caused by feature request 0039504 closedjarmendariz Upgrade Log4j to version 2 
caused by design defect 0039034 closedcaristu Illegal Access warning in xstream-1.3.1 library 
has duplicate defect 0040949 closedplatform The system build from the app fails but shows a success message 

-  Notes
(0113813)
hgbot (developer)
2019-08-05 13:53

Repository: erp/devel/pi
Changeset: abfb012807e402f384506ea4ff03dd258fafd818
Author: Javier Armendáriz <javier.armendariz <at> openbravo.com>
Date: Fri Aug 02 14:44:36 2019 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/abfb012807e402f384506ea4ff03dd258fafd818 [^]

Fixed issue 41524: Errors in build from UI are not shown

Log4j configuration is missing in BuildTask ant task. This causes
that when this task fails, the error message is not passed to
OBRebuildAppender and thus the process finishes as successful from
the point of view of the UI.

---
M build.xml
M src-core/src/org/openbravo/utils/OBRebuildAppender.java
M src/org/openbravo/erpCommon/ad_process/ApplyModulesResponse.java
---
(0113827)
jarmendariz (developer)
2019-08-06 10:58

Created a test scenario in TestLink:
https://testlink.openbravo.com/testlink/linkto.php?tprojectPrefix=Communit&item=testcase&id=Communit-11546 [^]
(0113843)
alostale (developer)
2019-08-06 13:33

reviewed + tested
(0114203)
hudsonbot (developer)
2019-08-22 14:45

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/ad3efd3bd07c [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2019-08-01 13:18 plujan New Issue
2019-08-01 13:18 plujan Assigned To => platform
2019-08-01 13:18 plujan File Added: FailedRebuildSuccessful.png
2019-08-01 13:18 plujan Modules => Core
2019-08-01 13:18 plujan Triggers an Emergency Pack => No
2019-08-05 12:49 jarmendariz Relationship added caused by 0039504
2019-08-05 12:49 jarmendariz Assigned To platform => jarmendariz
2019-08-05 13:02 jarmendariz Regression level => Production - Confirmed Stable
2019-08-05 13:02 jarmendariz Regression introduced in release => 3.0PR19Q1
2019-08-05 13:24 jarmendariz Status new => scheduled
2019-08-05 13:53 hgbot Checkin
2019-08-05 13:53 hgbot Note Added: 0113813
2019-08-05 13:53 hgbot Status scheduled => resolved
2019-08-05 13:53 hgbot Resolution open => fixed
2019-08-05 13:53 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/abfb012807e402f384506ea4ff03dd258fafd818 [^]
2019-08-05 13:55 jarmendariz Summary [19Q3] A failed rebuild shows a success message => Errors in build from UI are not shown
2019-08-06 10:53 alostale Relationship added has duplicate 0040949
2019-08-06 10:58 jarmendariz Note Added: 0113827
2019-08-06 11:03 jarmendariz Regression date => 2018-11-19
2019-08-06 11:03 jarmendariz Regression introduced by commit => 4d00819f3952ff85dae35810a6a47c2f2bbfaed8
2019-08-06 11:05 jarmendariz Regression introduced by commit 4d00819f3952ff85dae35810a6a47c2f2bbfaed8 => https://code.openbravo.com/erp/devel/pi/rev/4d00819f3952ff85dae35810a6a47c2f2bbfaed8 [^]
2019-08-06 13:33 alostale Relationship added caused by 0039034
2019-08-06 13:33 alostale Review Assigned To => alostale
2019-08-06 13:33 alostale Note Added: 0113843
2019-08-06 13:33 alostale Status resolved => closed
2019-08-06 13:33 alostale Fixed in Version => 3.0PR19Q4
2019-08-22 14:45 hudsonbot Checkin
2019-08-22 14:45 hudsonbot Note Added: 0114203


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker