Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0041474
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2019-07-29 14:462019-08-22 14:45
ReporteralostaleView Statuspublic 
Assigned Toalostale 
PriorityimmediateResolutionfixedFixed in Version3.0PR19Q4
StatusclosedFix in branchFixed in SCM revisionb7c07ac600a4
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tocaristu
Web browser
ModulesCore
Regression levelPre packaging ( pi )
Regression date2018-07-18
Regression introduced in releasepi
Regression introduced by commithttp://code.openbravo.com/erp/devel/pi/rev/f6a08a4efa0b7d9478d9db5c61e2b865a15f1a49 [^]
Triggers an Emergency PackNo
Summary

0041474: cannot register module with DBPrefix

DescriptionWhen trying to register a new module with a db prefix, the process fails with "Not a valid DB Prefix. DB Prefix must contain only upper alpha numeric characters and it must start with an alphabetic character."
Steps To Reproduce1. Login as System Admin
2. Create a new module and add a valid DB Prefix
3. Click on register module and enter your credentials
  -> ERROR: Not a valid DB Prefix. DB Prefix must contain only upper alpha numeric characters and it must start with an alphabetic character.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
caused by feature request 0041104 closedalostale refactor CR services not to depend on axis 

-  Notes
(0113691)
hgbot (developer)
2019-07-29 14:50

Repository: erp/devel/pi
Changeset: b7c07ac600a4fc79e94d2768c286fc50b57b37c8
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Mon Jul 29 14:50:32 2019 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/b7c07ac600a4fc79e94d2768c286fc50b57b37c8 [^]

fixed bug 41474: cannot register module with DBPrefix

   When registering modules with DBPrefix, full DAL object idetifier was sent
   instead of only the actual prefix.

---
M modules/org.openbravo.client.application/src/org/openbravo/client/application/businesslogic/RegisterModuleActionHandler.java
---
(0113769)
caristu (developer)
2019-08-02 07:59

Reviewed
(0114180)
hudsonbot (developer)
2019-08-22 14:45

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/ad3efd3bd07c [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2019-07-29 14:46 alostale New Issue
2019-07-29 14:46 alostale Assigned To => alostale
2019-07-29 14:46 alostale Modules => Core
2019-07-29 14:46 alostale Triggers an Emergency Pack => No
2019-07-29 14:48 alostale Regression level => Pre packaging ( pi )
2019-07-29 14:48 alostale Regression date => 2018-07-18
2019-07-29 14:48 alostale Regression introduced in release => pi
2019-07-29 14:48 alostale Regression introduced by commit => http://code.openbravo.com/erp/devel/pi/rev/f6a08a4efa0b7d9478d9db5c61e2b865a15f1a49 [^]
2019-07-29 14:48 alostale Relationship added caused by 0041104
2019-07-29 14:48 alostale Review Assigned To => caristu
2019-07-29 14:50 hgbot Checkin
2019-07-29 14:50 hgbot Note Added: 0113691
2019-07-29 14:50 hgbot Status new => resolved
2019-07-29 14:50 hgbot Resolution open => fixed
2019-07-29 14:50 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/b7c07ac600a4fc79e94d2768c286fc50b57b37c8 [^]
2019-08-02 07:59 caristu Note Added: 0113769
2019-08-02 07:59 caristu Status resolved => closed
2019-08-02 07:59 caristu Fixed in Version => 3.0PR19Q4
2019-08-22 14:45 hudsonbot Checkin
2019-08-22 14:45 hudsonbot Note Added: 0114180


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker