Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0041431
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Modules] Base Apache CXF Infrastructureminorhave not tried2019-07-23 12:582019-07-26 08:38
ReportercaristuView Statuspublic 
Assigned Tocaristu 
PriorityhighResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision77acbf3c1ff8
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Regression date
Regression introduced by commit
Regression level
Review Assigned Toalostale
Regression introduced in release
Summary

0041431: Add dependency with Javax XML SOAP API module

DescriptionAs part of the changes introduced to remove the support for axis in core[1], the Javax XML SOAP API library[2] is removed.

This library is required by the Base Apache CXF Infrastructure module as it implements the SAAJ API.

[1] https://issues.openbravo.com/view.php?id=40536 [^]
[2] https://mvnrepository.com/artifact/javax.xml.soap/javax.xml.soap-api/1.3.7 [^]
Steps To ReproduceIn description
Proposed SolutionAdd a dependency with Javax XML SOAP API module which is intended to provide this required library.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to design defect 0040536 closedalostale Openbravo ERP Remove support for axis 

-  Notes
(0113592)
hgbot (developer)
2019-07-23 13:20

Repository: erp/mods/org.openbravo.base.cxf
Changeset: 77acbf3c1ff8a206f39bd54433944ef34ba7b521
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Tue Jul 23 13:20:00 2019 +0200
URL: http://code.openbravo.com/erp/mods/org.openbravo.base.cxf/rev/77acbf3c1ff8a206f39bd54433944ef34ba7b521 [^]

fixes issue 41431: Add dependency with Javax XML SOAP API module

---
M src-db/database/sourcedata/AD_MODULE.xml
M src-db/database/sourcedata/AD_MODULE_DEPENDENCY.xml
---
(0113665)
alostale (developer)
2019-07-26 08:38

reviewed

- Issue History
Date Modified Username Field Change
2019-07-23 12:58 caristu New Issue
2019-07-23 12:58 caristu Assigned To => caristu
2019-07-23 12:59 caristu Relationship added related to 0040536
2019-07-23 12:59 caristu Description Updated View Revisions
2019-07-23 12:59 caristu Description Updated View Revisions
2019-07-23 13:20 hgbot Checkin
2019-07-23 13:20 hgbot Note Added: 0113592
2019-07-23 13:20 hgbot Status new => resolved
2019-07-23 13:20 hgbot Resolution open => fixed
2019-07-23 13:20 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/mods/org.openbravo.base.cxf/rev/77acbf3c1ff8a206f39bd54433944ef34ba7b521 [^]
2019-07-23 13:21 caristu Review Assigned To => alostale
2019-07-26 08:38 alostale Note Added: 0113665
2019-07-26 08:38 alostale Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker