Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0041383
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Discounts and Promotionsmajoralways2019-07-17 16:412019-08-22 14:44
Reporterinaki_garciaView Statuspublic 
Assigned Toguilleaer 
PriorityimmediateResolutionfixedFixed in VersionRR19Q4
StatusclosedFix in branchFixed in SCM revision81de09b49dad
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionmainSCM revision 
Review Assigned Tojorge-garcia
Regression levelQA functional test
Regression date2019-02-22
Regression introduced in releaseRR18Q3
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/73c8bbf59361 [^]
Triggers an Emergency PackNo
Summary

0041383: [19Q3] [D&P per hour] Discount or promotion can no longer be correctly created and used

DescriptionDue to the newly introduced "Discounts and Promotions per Hour" module extension, creating a discount or promotion in the usual workflow will lead to it not working. This is due to the newly added "Availability" section when creating a new discount or promotion, which has made it mandatory to have some of the the checkboxes checked in order to make the discount or promotion available for use when adding products to a ticket.

This issue is considered a regression, not because an error introduced in an existing project, but due to the disruption of the standard flow as a result of the introduction of this new functionality.
Steps To ReproducePRECONDITION: the "Discounts and Promotions per Hour" module must be installed alongside the standard "Discounts and Promotions" module

** Behaviour prior to the introduction of the module (19Q2 and earlier) **
-- Backend
0. Log in the ERP
1. Create a discount which isn't discretionary (p.e. "Price Adjustment" type) in the "Discounts and Promotions" window.
Fill all mandatory fields (highlighted in yellow), and add a Product by setting the "Included Products *" to "Only those defined"
and by creating a new record in the "Products" subtab

-- Frontend
0. Log in the Web POS as "vallblanca"
1. Add the product the discount has been created for
2. The discount is correctly added to the list item of the product



** Current behaviour **
- Execute steps 0 and 1 of Backend and Frontend
NOTICE that in step 2. of Frontend, the discount hasn't been correctly applied

-- Backend
2. Check the "All Week" checkbox in the availability section of the Discount, or check the current weekday and leave the Start/Ending Times blank

-- Frontend
- Execute steps 0 to 2 of Frontend
NOTICE that the discount is now correctly added

TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 0041398RR19Q3 closedguilleaer [19Q3] [D&P per hour] Discount or promotion can no longer be correctly created and used 

-  Notes
(0113529)
hgbot (developer)
2019-07-18 16:49

Repository: erp/devel/pi
Changeset: a6c7fb43ae23162df5e13dd65400238f5b16da13
Author: Guillermo Alvarez de Eulate <guillermo.alvarez <at> openbravo.com>
Date: Thu Jul 18 16:48:49 2019 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/a6c7fb43ae23162df5e13dd65400238f5b16da13 [^]

Fixed issue 41383: Discounts should be available all week by default

After add new feature to define discounts per hours, previous discounts present in the database must be marked as -allweek-. When the development was done developer tried to do it but forgot to define default in AD. Also is needed to set the column as required to update previous registers with Y

---
M src-db/database/model/tables/M_OFFER.xml
M src-db/database/sourcedata/AD_COLUMN.xml
---
(0113535)
jorge-garcia (developer)
2019-07-18 17:22

Code reviewed and tested
(0113541)
hgbot (developer)
2019-07-19 07:42

Repository: erp/devel/pi
Changeset: b5dfc1e0749d2d3ed03bb2f0a1d600e8f3c9fc78
Author: Guillermo Alvarez de Eulate <guillermo.alvarez <at> openbravo.com>
Date: Fri Jul 19 07:41:48 2019 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/b5dfc1e0749d2d3ed03bb2f0a1d600e8f3c9fc78 [^]

Related to issue 41383: Backed out changeset a6c7fb43ae23 because it is an API change.

The fix its correct but it is an API change. Will be pushed again after manage API change properly.

---
M src-db/database/model/tables/M_OFFER.xml
M src-db/database/sourcedata/AD_COLUMN.xml
---
(0113564)
hgbot (developer)
2019-07-22 13:52

Repository: erp/devel/api-checks
Changeset: 3e1a8884e6e61d24de1d2bbe3c04db2ca084eb52
Author: Guillermo Alvarez de Eulate <guillermo.alvarez <at> openbravo.com>
Date: Mon Jul 22 09:07:12 2019 +0200
URL: http://code.openbravo.com/erp/devel/api-checks/rev/3e1a8884e6e61d24de1d2bbe3c04db2ca084eb52 [^]

Related to issue 41383: Update API tool

---
M model/src-db/database/model/tables/M_OFFER.xml
M model/src-db/database/sourcedata/AD_COLUMN.xml
---
(0113565)
hgbot (developer)
2019-07-22 13:53

Repository: erp/devel/pi
Changeset: 81de09b49dadfc03f929336ff0bb061b150ab91b
Author: Guillermo Alvarez de Eulate <guillermo.alvarez <at> openbravo.com>
Date: Fri Jul 19 12:58:33 2019 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/81de09b49dadfc03f929336ff0bb061b150ab91b [^]

Fixed issue 41383: Discounts should be available all week by default

After add new feature to define discounts per hours, previous discounts present in the database must be marked as -allweek-. When the development was done developer tried to do it but forgot to define default in AD. Also is needed to set the column as required to update previous registers with Y

---
M src-db/database/model/tables/M_OFFER.xml
M src-db/database/sourcedata/AD_COLUMN.xml
---
(0113596)
guilleaer (developer)
2019-07-23 13:45

Regarding API change, To put more light here

Accept change to 'not null' for M_OFFER.ALLWEEKDAYS column as false positive.

That column was recently added (for 19Q3) release as nullable (wrongly).
Issue xx makes the column now mandatory and this change will be backported
to 19Q3 release directly.
That means ALLWEEKDAYS will have never been published as nullable so this
is not an api-change but managed as false positive.
(0113597)
jorge-garcia (developer)
2019-07-23 13:52

Code and API change reviewed and tested
(0114161)
hudsonbot (developer)
2019-08-22 14:44

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/ad3efd3bd07c [^]
Maturity status: Test
(0114164)
hudsonbot (developer)
2019-08-22 14:44

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/ad3efd3bd07c [^]
Maturity status: Test
(0114171)
hudsonbot (developer)
2019-08-22 14:44

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/ad3efd3bd07c [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2019-07-17 16:41 inaki_garcia New Issue
2019-07-17 16:41 inaki_garcia Assigned To => Retail
2019-07-17 16:41 inaki_garcia Triggers an Emergency Pack => No
2019-07-17 17:08 inaki_garcia Steps to Reproduce Updated View Revisions
2019-07-18 16:41 guilleaer Status new => scheduled
2019-07-18 16:41 guilleaer Assigned To Retail => guilleaer
2019-07-18 16:49 hgbot Checkin
2019-07-18 16:49 hgbot Note Added: 0113529
2019-07-18 16:49 hgbot Status scheduled => resolved
2019-07-18 16:49 hgbot Resolution open => fixed
2019-07-18 16:49 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/a6c7fb43ae23162df5e13dd65400238f5b16da13 [^]
2019-07-18 17:22 jorge-garcia Review Assigned To => jorge-garcia
2019-07-18 17:22 jorge-garcia Note Added: 0113535
2019-07-18 17:22 jorge-garcia Status resolved => closed
2019-07-18 17:22 jorge-garcia Fixed in Version => RR19Q4
2019-07-18 17:30 guilleaer Regression level => QA functional test
2019-07-18 17:30 guilleaer Regression date => 2019-02-22
2019-07-18 17:30 guilleaer Regression introduced in release => RR18Q3
2019-07-18 17:30 guilleaer Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/73c8bbf59361 [^]
2019-07-19 07:42 hgbot Checkin
2019-07-19 07:42 hgbot Note Added: 0113541
2019-07-19 07:55 guilleaer Status closed => new
2019-07-19 07:55 guilleaer Resolution fixed => open
2019-07-19 07:55 guilleaer Fixed in Version RR19Q4 =>
2019-07-19 07:55 guilleaer Status new => scheduled
2019-07-22 13:52 hgbot Checkin
2019-07-22 13:52 hgbot Note Added: 0113564
2019-07-22 13:53 hgbot Checkin
2019-07-22 13:53 hgbot Note Added: 0113565
2019-07-22 13:53 hgbot Status scheduled => resolved
2019-07-22 13:53 hgbot Resolution open => fixed
2019-07-22 13:53 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/a6c7fb43ae23162df5e13dd65400238f5b16da13 [^] => http://code.openbravo.com/erp/devel/pi/rev/81de09b49dadfc03f929336ff0bb061b150ab91b [^]
2019-07-23 13:45 guilleaer Note Added: 0113596
2019-07-23 13:52 jorge-garcia Note Added: 0113597
2019-07-23 13:52 jorge-garcia Status resolved => closed
2019-07-23 13:52 jorge-garcia Fixed in Version => RR19Q4
2019-08-22 14:44 hudsonbot Checkin
2019-08-22 14:44 hudsonbot Note Added: 0114161
2019-08-22 14:44 hudsonbot Checkin
2019-08-22 14:44 hudsonbot Note Added: 0114164
2019-08-22 14:44 hudsonbot Checkin
2019-08-22 14:44 hudsonbot Note Added: 0114171


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker