Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0041376
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] A. Platformcriticalalways2019-07-17 12:262019-07-18 16:08
Reportergorka_gilView Statuspublic 
Assigned Toalostale 
PriorityimmediateResolutionfixedFixed in Version3.0PR19Q2.1
StatusclosedFix in branchFixed in SCM revisionf058c7d7182e
ProjectionnoneETAnoneTarget Version3.0PR19Q2.1
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression levelCoding ( Testing )
Regression date
Regression introduced in release
Regression introduced by commithttps://code.openbravo.com/erp/backports/3.0PR19Q2.1/rev/cacf8e9d06b5 [^]
Triggers an Emergency PackNo
Summary

0041376: After backport new js formater all windows in form mode fail to open

DescriptionOpening a sales order in form mode gives appear a popup with error:

Error occured: No bean found for type class org.openbravo.client.application.window.FormInitializationComponent

It happens also in all windows.
Steps To ReproduceIn a 19q2.1 branch of erp with the changes of formater.
Open a window of sales order, do double click in a sales order
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
caused by backport 00413503.0PR19Q2.1 closedjarmendariz Upgrade javascript formatter 
related to backport 00413773.0PR19Q1.3 closedalostale After backport new js formater all windows in form mode fail to open 

-  Notes
(0113478)
hgbot (developer)
2019-07-17 12:34

Repository: erp/backports/3.0PR19Q2.1
Changeset: f058c7d7182e4633931e3c71ca2579b2924d86e4
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Wed Jul 17 12:34:03 2019 +0200
URL: http://code.openbravo.com/erp/backports/3.0PR19Q2.1/rev/f058c7d7182e4633931e3c71ca2579b2924d86e4 [^]

fixed bug 41376: cannot open/create any record

  Backport for new js formatting included removal of jslint4java-1.4.7.jar which
  includes mozilla rhino that is used by FIC to compute callouts response. This
  casued FIC to fail on initialization.

  Reverted jslint4java removal.

---
M legal/Licensing.txt
A modules/org.openbravo.client.kernel/lib/runtime/jslint4java-1.4.7.jar
R legal/Licensing.txt.orig
---
(0113500)
guilleaer (developer)
2019-07-18 10:51

Wrongly closed by retail. Marking again as resolved
(0113513)
AugustoMauch (developer)
2019-07-18 13:04

Code reviewed and verified

- Issue History
Date Modified Username Field Change
2019-07-17 12:26 gorka_gil New Issue
2019-07-17 12:26 gorka_gil Assigned To => platform
2019-07-17 12:26 gorka_gil Modules => Core
2019-07-17 12:26 gorka_gil Regression level => Coding ( Testing )
2019-07-17 12:26 gorka_gil Regression introduced by commit => https://code.openbravo.com/erp/backports/3.0PR19Q2.1/rev/cacf8e9d06b5 [^]
2019-07-17 12:26 gorka_gil Triggers an Emergency Pack => No
2019-07-17 12:29 gorka_gil Issue cloned 0041377
2019-07-17 12:29 gorka_gil Relationship added related to 0041377
2019-07-17 12:30 gorka_gil Relationship added caused by 0041350
2019-07-17 12:34 hgbot Checkin
2019-07-17 12:34 hgbot Note Added: 0113478
2019-07-17 12:34 hgbot Status new => resolved
2019-07-17 12:34 hgbot Resolution open => fixed
2019-07-17 12:34 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR19Q2.1/rev/f058c7d7182e4633931e3c71ca2579b2924d86e4 [^]
2019-07-18 10:49 guilleaer Review Assigned To => guilleaer
2019-07-18 10:49 guilleaer Status resolved => closed
2019-07-18 10:49 guilleaer Fixed in Version => 3.0PR19Q2.1
2019-07-18 10:51 guilleaer Note Added: 0113500
2019-07-18 10:51 guilleaer Status closed => new
2019-07-18 10:51 guilleaer Resolution fixed => open
2019-07-18 10:51 guilleaer Fixed in Version 3.0PR19Q2.1 =>
2019-07-18 10:51 guilleaer Status new => scheduled
2019-07-18 10:52 guilleaer Status scheduled => resolved
2019-07-18 10:52 guilleaer Resolution open => fixed
2019-07-18 11:54 alostale Review Assigned To guilleaer => AugustoMauch
2019-07-18 12:40 gorka_gil Type defect => backport
2019-07-18 13:04 AugustoMauch Note Added: 0113513
2019-07-18 13:04 AugustoMauch Status resolved => closed
2019-07-18 13:04 AugustoMauch Fixed in Version => 3.0PR19Q2.1
2019-07-18 16:08 alostale Assigned To platform => alostale


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker