Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0041358
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] A. Platformmajorrandom2019-07-11 12:142019-07-16 11:33
ReporterLeyreView Statuspublic 
Assigned Toalostale 
PriorityimmediateResolutionfixedFixed in Version3.0PR19Q3
StatusclosedFix in branchFixed in SCM revisionf44622c52c24
ProjectionnoneETAnoneTarget Version3.0PR19Q3
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2018-11-22
Regression introduced in release3.0PR19Q1
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/4d71d9e4d6d5c9be49d1a301da6dbeefeb5d9048 [^]
Triggers an Emergency PackNo
Summary

0041358: error when opening some backoffice windows

DescriptionWhen actions in backoffice windows that have tabs for the same table (ie. Sales Invoice Header and Purchase Invoice Header, both of them based in the same C_Order table) are performed in certain order, it is not possible to open one of those windows, until Tomcat is restarted or ADCS cache is reset.

This is caused because some of this actions can trigger ADCS to be partially initialized for some of these tabs.

Steps To ReproduceIn browser A:
- Open Sales Invoice (tab is properly stored in cache due to view generation)
- Open Purchase Invoice (tab is properly stored in cache due to view generation)
- Reset the ApplicationDictionaryCachedStructure either restarting Tomcat or following the steps described in the Proposed Solution section.
- Open Sales Invoice (tab is partially stored in cache dure to WindowSettingsActionHanlder request)
- Open Purchase Invoice (tab is partially stored in cache dure to WindowSettingsActionHanlder request)

In browser B:
- Open Purchase Invoice. The following error will be shown:

Error occured: freemarker.template.TemplateModelException: get(tabView) failed on instance of org.openbravo.client.application.window.StandardWindowComponent
Proposed SolutionWorkaround while the problem is not solved:
1) Download jmxterm-1.0.1-uber.jar
2) java -jar jmxterm-1.0.1-uber.jar
3) open <PID>
4) bean
Openbravo:context=<contexto>,name=ApplicationDictionaryCachedStructures
5) run resetCache

** to the step 3) open <PID>: execute the "jps" command. It returns an id, to use.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0041338 closedalostale error when opening some backoffice windows 

-  Notes
(0113389)
hgbot (developer)
2019-07-16 07:55

Repository: erp/backports/3.0PR19Q3
Changeset: f44622c52c2434aa94c99379cebda137e66b20cf
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Tue Jul 16 07:55:10 2019 +0200
URL: http://code.openbravo.com/erp/backports/3.0PR19Q3/rev/f44622c52c2434aa94c99379cebda137e66b20cf [^]

fixed bug 41358: error when opening some backoffice windows

  Tabs that share the same table (ie. Purchase Invoice Header and Sales Invoice
  Header) could set ADCS to an incorrect state where one of those tabs is partially
  initialized. This cause the view for that tab not to be possible to get generated.

  Fixed by forcing complete tab initialization even the table for it was already
  initialized as it could have been done by another tab with the same table.

---
M modules/org.openbravo.client.application/src-test/org/openbravo/client/application/test/ADCSTest.java
M modules/org.openbravo.client.application/src/org/openbravo/client/application/window/ApplicationDictionaryCachedStructures.java
M src-test/src/org/openbravo/test/base/TestConstants.java
---
(0113399)
AugustoMauch (developer)
2019-07-16 11:33

Code reviewed and verified

- Issue History
Date Modified Username Field Change
2019-07-15 14:10 alostale Type defect => backport
2019-07-15 14:10 alostale Target Version => 3.0PR19Q3
2019-07-16 07:55 hgbot Checkin
2019-07-16 07:55 hgbot Note Added: 0113389
2019-07-16 07:55 hgbot Status scheduled => resolved
2019-07-16 07:55 hgbot Resolution open => fixed
2019-07-16 07:55 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR19Q3/rev/f44622c52c2434aa94c99379cebda137e66b20cf [^]
2019-07-16 11:33 AugustoMauch Note Added: 0113399
2019-07-16 11:33 AugustoMauch Status resolved => closed
2019-07-16 11:33 AugustoMauch Fixed in Version => 3.0PR19Q3


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker