Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0041352
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2019-07-15 11:272019-08-22 14:45
ReporterdmiguelezView Statuspublic 
Assigned ToAugustoMauch 
PrioritynormalResolutionfixedFixed in Version3.0PR19Q4
StatusclosedFix in branchFixed in SCM revisionf82044001bce
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0041352: Wrong validation error when internet connection is slow

DescriptionWhen the internet connection is slow, a wrong validation is fired and the cell is marked as red when the values are correct
Steps To Reproduce1.- Create a New Purchase Order
2.- Click the button "Create Lines"
3.- Add the columns "Aum" and "Aum Quantity"
4.- Open the Chrome dev tools and set the Internet connection to "3G fast"
5.- Enter a value in the "Aum Quantity" and later click in another row

Error: the cell is in red but the value is correct.
TagsNo tags attached.
Attached Files? file icon 41087.mp4 [^] (3,027,874 bytes) 2019-07-15 11:27

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0041087 closedcollazoandy4 when the internet connection is slow the GetConvertedQtyActionHandler don't set the value in the correct cell 

-  Notes
(0113485)
hgbot (developer)
2019-07-17 18:19

Repository: erp/devel/pi
Changeset: 7d4eb3d7c838679542b1ef1729a369ba36620662
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Wed Jul 17 18:18:51 2019 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/7d4eb3d7c838679542b1ef1729a369ba36620662 [^]

Fixes issue 41352: Runs validation after modifying value in non-editing row

In pick and execute grids, when a row other than the one that has the editGrid is programatically edited
( for instance using the setEditValue function), the validation should be run again. Otherwise the row would
not be revalidated, since validation is done when leaving the row that has the editGrid.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/process/ob-pick-and-execute-grid.js
---
(0113498)
hgbot (developer)
2019-07-18 09:35

Repository: erp/devel/pi
Changeset: d48c24a6a5cf35c03b838827ef3117b6169a9ae7
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Thu Jul 18 09:35:04 2019 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/d48c24a6a5cf35c03b838827ef3117b6169a9ae7 [^]

Related with issue Fixes issue 41352: Backed out changeset 7d4eb3d7c838

The changeset [1] has been backed out because it is causing an error in CI [2]

[1] https://code.openbravo.com/erp/devel/pi/rev/7d4eb3d7c838679542b1ef1729a369ba36620662 [^]
[2] http://ci.openbravo.com/view/int/job/int-addpayment2-pgsql/531/ [^]

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/process/ob-pick-and-execute-grid.js
---
(0113576)
hgbot (developer)
2019-07-22 17:33

Repository: erp/devel/pi
Changeset: f82044001bce30a8e7c08b36deecfb1dfbad8253
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Mon Jul 22 17:33:24 2019 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/f82044001bce30a8e7c08b36deecfb1dfbad8253 [^]

Fixes issue 41352: Validates row when it is modified programatically

The problem was that when a row was programatically modified using the setEditValue method, the
change was not validated unless it was done in the row that was currently being edited in the UI.

Now the change will be validated, but only if the row is selected.

A changes has also been done on ob-aprm-addPayment.js to deselected a row before updating it,
because otherwise it caused a validation error.

---
M modules/org.openbravo.advpaymentmngt/web/org.openbravo.advpaymentmngt/js/ob-aprm-addPayment.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/process/ob-pick-and-execute-grid.js
---
(0113663)
alostale (developer)
2019-07-26 08:38

reviewed + tested
(0114156)
hudsonbot (developer)
2019-08-22 14:44

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/ad3efd3bd07c [^]
Maturity status: Test
(0114157)
hudsonbot (developer)
2019-08-22 14:44

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/ad3efd3bd07c [^]
Maturity status: Test
(0114172)
hudsonbot (developer)
2019-08-22 14:45

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/ad3efd3bd07c [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2019-07-15 11:27 dmiguelez New Issue
2019-07-15 11:27 dmiguelez Assigned To => platform
2019-07-15 11:27 dmiguelez File Added: 41087.mp4
2019-07-15 11:27 dmiguelez Modules => Core
2019-07-15 11:27 dmiguelez Triggers an Emergency Pack => No
2019-07-15 11:27 dmiguelez Relationship added related to 0041087
2019-07-15 17:42 AugustoMauch Assigned To platform => AugustoMauch
2019-07-17 18:19 hgbot Checkin
2019-07-17 18:19 hgbot Note Added: 0113485
2019-07-17 18:19 hgbot Status new => resolved
2019-07-17 18:19 hgbot Resolution open => fixed
2019-07-17 18:19 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/7d4eb3d7c838679542b1ef1729a369ba36620662 [^]
2019-07-17 18:20 AugustoMauch Review Assigned To => alostale
2019-07-18 09:35 hgbot Checkin
2019-07-18 09:35 hgbot Note Added: 0113498
2019-07-18 09:35 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/7d4eb3d7c838679542b1ef1729a369ba36620662 [^] => http://code.openbravo.com/erp/devel/pi/rev/d48c24a6a5cf35c03b838827ef3117b6169a9ae7 [^]
2019-07-19 10:41 AugustoMauch Status resolved => new
2019-07-19 10:41 AugustoMauch Resolution fixed => open
2019-07-19 10:43 alostale Severity major => minor
2019-07-22 17:33 hgbot Checkin
2019-07-22 17:33 hgbot Note Added: 0113576
2019-07-22 17:33 hgbot Status new => resolved
2019-07-22 17:33 hgbot Resolution open => fixed
2019-07-22 17:33 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/d48c24a6a5cf35c03b838827ef3117b6169a9ae7 [^] => http://code.openbravo.com/erp/devel/pi/rev/f82044001bce30a8e7c08b36deecfb1dfbad8253 [^]
2019-07-26 08:38 alostale Note Added: 0113663
2019-07-26 08:38 alostale Status resolved => closed
2019-07-26 08:38 alostale Fixed in Version => 3.0PR19Q4
2019-08-22 14:44 hudsonbot Checkin
2019-08-22 14:44 hudsonbot Note Added: 0114156
2019-08-22 14:44 hudsonbot Checkin
2019-08-22 14:44 hudsonbot Note Added: 0114157
2019-08-22 14:45 hudsonbot Checkin
2019-08-22 14:45 hudsonbot Note Added: 0114172


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker