Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0041338
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajorrandom2019-07-11 12:142019-08-22 14:44
ReporterLeyreView Statuspublic 
Assigned Toalostale 
PriorityimmediateResolutionfixedFixed in Version3.0PR19Q4
StatusclosedFix in branchFixed in SCM revision15579b4991b6
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2018-11-22
Regression introduced in release3.0PR19Q1
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/4d71d9e4d6d5c9be49d1a301da6dbeefeb5d9048 [^]
Triggers an Emergency PackNo
Summary

0041338: error when opening some backoffice windows

DescriptionWhen actions in backoffice windows that have tabs for the same table (ie. Sales Invoice Header and Purchase Invoice Header, both of them based in the same C_Order table) are performed in certain order, it is not possible to open one of those windows, until Tomcat is restarted or ADCS cache is reset.

This is caused because some of this actions can trigger ADCS to be partially initialized for some of these tabs.

Steps To ReproduceIn browser A:
- Open Sales Invoice (tab is properly stored in cache due to view generation)
- Open Purchase Invoice (tab is properly stored in cache due to view generation)
- Reset the ApplicationDictionaryCachedStructure either restarting Tomcat or following the steps described in the Proposed Solution section.
- Open Sales Invoice (tab is partially stored in cache dure to WindowSettingsActionHanlder request)
- Open Purchase Invoice (tab is partially stored in cache dure to WindowSettingsActionHanlder request)

In browser B:
- Open Purchase Invoice. The following error will be shown:

Error occured: freemarker.template.TemplateModelException: get(tabView) failed on instance of org.openbravo.client.application.window.StandardWindowComponent
Proposed SolutionWorkaround while the problem is not solved:
1) Download jmxterm-1.0.1-uber.jar
2) java -jar jmxterm-1.0.1-uber.jar
3) open <PID>
4) bean
Openbravo:context=<contexto>,name=ApplicationDictionaryCachedStructures
5) run resetCache

** to the step 3) open <PID>: execute the "jps" command. It returns an id, to use.
TagsNo tags attached.
Attached Files file icon 10796_log [^] (136,706 bytes) 2019-07-11 12:14 [Show Content]
 file icon 10881_log [^] (2,059 bytes) 2019-07-11 12:14 [Show Content]
log file icon andino_test_openbravo.log [^] (136,677 bytes) 2019-07-12 08:24

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0040633 closedalostale Generation of Discounts and Promotions windows fails under some circumstances 
depends on backport 00413583.0PR19Q3 closedalostale error when opening some backoffice windows 
depends on backport 00413593.0PR19Q2.1 closedalostale error when opening some backoffice windows 
depends on backport 00413603.0PR19Q1.3 closedalostale error when opening some backoffice windows 
caused by design defect 0039670 closedalostale view generation scalability issues 
related to defect 0041892 closedalostale Masked String reference can leave ADCS in an inconsitent state 

-  Notes
(0113385)
hgbot (developer)
2019-07-16 07:22

Repository: erp/devel/pi
Changeset: b6525addd506e89d84c5f238ac1907eae5a99df3
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Mon Jul 15 12:18:33 2019 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/b6525addd506e89d84c5f238ac1907eae5a99df3 [^]

related to bug 41338: added test case

---
M modules/org.openbravo.client.application/src-test/org/openbravo/client/application/test/ADCSTest.java
M src-test/src/org/openbravo/test/base/TestConstants.java
---
(0113386)
hgbot (developer)
2019-07-16 07:23

Repository: erp/devel/pi
Changeset: 15579b4991b60c9ab57f4e6b36d8d49fdbcfdbc5
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Mon Jul 15 12:50:46 2019 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/15579b4991b60c9ab57f4e6b36d8d49fdbcfdbc5 [^]

fixed bug 41338: error when opening some backoffice windows

  Tabs that share the same table (ie. Purchase Invoice Header and Sales Invoice
  Header) could set ADCS to an incorrect state where one of those tabs is partially
  initialized. This cause the view for that tab not to be possible to get generated.

  Fixed by forcing complete tab initialization even the table for it was already
  initialized as it could have been done by another tab with the same table.

---
M modules/org.openbravo.client.application/src/org/openbravo/client/application/window/ApplicationDictionaryCachedStructures.java
---
(0113387)
hgbot (developer)
2019-07-16 07:23

Repository: erp/devel/pi
Changeset: 95e4ea70afe5ec3c9cffab0c5246c8e5924b3242
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Mon Jul 15 14:00:44 2019 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/95e4ea70afe5ec3c9cffab0c5246c8e5924b3242 [^]

related to issue 41338: added test case

  Adds a test case which is more similar to reported steps to reproduce.

---
M modules/org.openbravo.client.application/src-test/org/openbravo/client/application/test/ADCSTest.java
M src-test/src/org/openbravo/test/base/TestConstants.java
---
(0113388)
hgbot (developer)
2019-07-16 07:43

Repository: erp/devel/pi
Changeset: 112f56ad6db511ca86ed6b47e247a103d1ef5fc5
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Tue Jul 16 07:43:23 2019 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/112f56ad6db511ca86ed6b47e247a103d1ef5fc5 [^]

related to issue 41338: reverted unintended change

---
M modules/org.openbravo.client.application/src-test/org/openbravo/client/application/test/ADCSTest.java
---
(0113400)
AugustoMauch (developer)
2019-07-16 12:26

Code reviewed and verified
(0114146)
hudsonbot (developer)
2019-08-22 14:44

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/ad3efd3bd07c [^]
Maturity status: Test
(0114147)
hudsonbot (developer)
2019-08-22 14:44

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/ad3efd3bd07c [^]
Maturity status: Test
(0114148)
hudsonbot (developer)
2019-08-22 14:44

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/ad3efd3bd07c [^]
Maturity status: Test
(0114149)
hudsonbot (developer)
2019-08-22 14:44

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/ad3efd3bd07c [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2019-07-11 12:14 Leyre New Issue
2019-07-11 12:14 Leyre Assigned To => platform
2019-07-11 12:14 Leyre File Added: 10796_log
2019-07-11 12:14 Leyre Modules => Core
2019-07-11 12:14 Leyre Triggers an Emergency Pack => No
2019-07-11 12:14 Leyre File Added: 10881_log
2019-07-11 12:15 Leyre Summary Error when open a window in Backend => Error opening a window in Backend
2019-07-11 12:15 Leyre Description Updated View Revisions
2019-07-11 12:33 Practics Issue Monitored: Practics
2019-07-12 08:24 Leyre File Added: andino_test_openbravo.log
2019-07-12 14:08 alostale Relationship added depends on 0039670
2019-07-12 14:08 alostale Relationship replaced related to 0039670
2019-07-12 14:08 alostale Relationship added related to 0040633
2019-07-12 15:54 ahernandezgil Issue Monitored: ahernandezgil
2019-07-15 12:22 alostale Summary Error opening a window in Backend => error when opening some backoffice windows
2019-07-15 12:57 AugustoMauch Description Updated View Revisions
2019-07-15 12:57 AugustoMauch Steps to Reproduce Updated View Revisions
2019-07-15 13:03 AugustoMauch Steps to Reproduce Updated View Revisions
2019-07-15 14:05 alostale Description Updated View Revisions
2019-07-15 14:05 alostale Proposed Solution updated
2019-07-15 14:06 alostale Assigned To platform => alostale
2019-07-15 14:06 alostale Priority high => immediate
2019-07-15 14:06 alostale Reproducibility always => random
2019-07-15 14:08 alostale Steps to Reproduce Updated View Revisions
2019-07-15 14:08 alostale Review Assigned To => AugustoMauch
2019-07-15 14:09 alostale Regression level => Production - Confirmed Stable
2019-07-15 14:09 alostale Regression date => 2018-11-22
2019-07-15 14:09 alostale Regression introduced in release => 3.0PR19Q1
2019-07-15 14:09 alostale Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/4d71d9e4d6d5c9be49d1a301da6dbeefeb5d9048 [^]
2019-07-15 14:10 alostale Status new => scheduled
2019-07-15 15:07 martinsdan Issue Monitored: martinsdan
2019-07-15 15:14 egoitz Issue Monitored: egoitz
2019-07-15 16:13 txasu Issue Monitored: txasu
2019-07-15 16:35 matias-bernal Issue Monitored: matias-bernal
2019-07-16 07:22 hgbot Checkin
2019-07-16 07:22 hgbot Note Added: 0113385
2019-07-16 07:23 hgbot Checkin
2019-07-16 07:23 hgbot Note Added: 0113386
2019-07-16 07:23 hgbot Status scheduled => resolved
2019-07-16 07:23 hgbot Resolution open => fixed
2019-07-16 07:23 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/15579b4991b60c9ab57f4e6b36d8d49fdbcfdbc5 [^]
2019-07-16 07:23 hgbot Checkin
2019-07-16 07:23 hgbot Note Added: 0113387
2019-07-16 07:43 hgbot Checkin
2019-07-16 07:43 hgbot Note Added: 0113388
2019-07-16 08:40 alostale Relationship replaced caused by 0039670
2019-07-16 12:20 jfrances Issue Monitored: jfrances
2019-07-16 12:26 AugustoMauch Note Added: 0113400
2019-07-16 12:26 AugustoMauch Status resolved => closed
2019-07-16 12:26 AugustoMauch Fixed in Version => 3.0PR19Q4
2019-08-22 14:44 hudsonbot Checkin
2019-08-22 14:44 hudsonbot Note Added: 0114146
2019-08-22 14:44 hudsonbot Checkin
2019-08-22 14:44 hudsonbot Note Added: 0114147
2019-08-22 14:44 hudsonbot Checkin
2019-08-22 14:44 hudsonbot Note Added: 0114148
2019-08-22 14:44 hudsonbot Checkin
2019-08-22 14:44 hudsonbot Note Added: 0114149
2019-09-26 17:09 alostale Relationship added related to 0041892


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker