Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0041124
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2019-06-19 11:272019-06-21 14:40
ReportercaristuView Statuspublic 
Assigned Tocaristu 
PriorityimmediateResolutionfixedFixed in Version3.0PR19Q3
StatusclosedFix in branchFixed in SCM revisionafe240a1304e
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression levelPre packaging ( pi )
Regression date2019-04-18
Regression introduced in releasepi
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/08db5ae97ad2b0fb0c4499b630018a9bc0c0166f [^]
Triggers an Emergency PackNo
Summary

0041124: Not possible to install modules with MMC having XSL processor in classpath which does not support all the standard attributes

DescriptionIf there is an XSL processor library in the classpath that provides a TrasnformerFactory implementation which is not able to handle the standard attributes configured in XMLUtil class, then this class is not able to provide a TransformerFactory instance.

Under this scenario, those parts of the application (like the MMC) that use XMLUtil to retrieve a TransformerFactory will not work properly.
Steps To Reproduce0) Copy the following libraries[1],[2] into lib/runtime folder and run ant compile.complete
1) Login
2) Go to the MMC window and try to install any module. The attached error will be shown.


[1] https://mvnrepository.com/artifact/xalan/xalan/2.7.1 [^]
[2] https://mvnrepository.com/artifact/xalan/serializer/2.7.1 [^]
Proposed SolutionCatch the IllegalArgumentException thrown when the attribute is not recognized. See: https://docs.oracle.com/javase/tutorial/jaxp/properties/usingProps.html [^]
TagsNo tags attached.
Attached Filespng file icon moduleDetailError.png [^] (36,853 bytes) 2019-06-19 11:27

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00411253.0PR19Q2.1 closedcaristu Not possible to install modules with MMC having XSL processor in classpath which does not support all the standard attributes 
depends on backport 00411263.0PR19Q1.2 closedcaristu Not possible to install modules with MMC having XSL processor in classpath which does not support all the standard attributes 
caused by defect 0040642 closedalostale centralize in XMLUtils creation of objects to deal with XML documents 

-  Notes
(0112883)
hgbot (developer)
2019-06-19 11:37

Repository: erp/devel/pi
Changeset: afe240a1304e930f55fb8a54055096b1d7ce79fb
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Wed Jun 19 11:33:03 2019 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/afe240a1304e930f55fb8a54055096b1d7ce79fb [^]

fixes bug 41124: Don't fail if can't set a TransformerFactory attribute

  In case the TransformerFactory underlying implementation does not recognize an attribute, do not fail and handle the error showing a warning message.

---
M src/org/openbravo/dal/xml/XMLUtil.java
---
(0112897)
hudsonbot (developer)
2019-06-19 16:02

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/5a31264dd0f8 [^]
Maturity status: Test
(0112944)
AugustoMauch (developer)
2019-06-21 14:40

Code reviewed and verified

- Issue History
Date Modified Username Field Change
2019-06-19 11:27 caristu New Issue
2019-06-19 11:27 caristu Assigned To => platform
2019-06-19 11:27 caristu File Added: moduleDetailError.png
2019-06-19 11:27 caristu Modules => Core
2019-06-19 11:27 caristu Triggers an Emergency Pack => No
2019-06-19 11:28 caristu Assigned To platform => caristu
2019-06-19 11:29 caristu Regression level => Pre packaging ( pi )
2019-06-19 11:29 caristu Regression date => 2019-04-18
2019-06-19 11:29 caristu Regression introduced in release => pi
2019-06-19 11:29 caristu Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/08db5ae97ad2b0fb0c4499b630018a9bc0c0166f [^]
2019-06-19 11:29 caristu Relationship added caused by 0040642
2019-06-19 11:30 caristu Status new => scheduled
2019-06-19 11:37 hgbot Checkin
2019-06-19 11:37 hgbot Note Added: 0112883
2019-06-19 11:37 hgbot Status scheduled => resolved
2019-06-19 11:37 hgbot Resolution open => fixed
2019-06-19 11:37 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/afe240a1304e930f55fb8a54055096b1d7ce79fb [^]
2019-06-19 11:38 caristu Review Assigned To => AugustoMauch
2019-06-19 11:46 ngarcia Issue Monitored: ngarcia
2019-06-19 13:05 caristu Proposed Solution updated
2019-06-19 16:02 hudsonbot Checkin
2019-06-19 16:02 hudsonbot Note Added: 0112897
2019-06-21 14:40 AugustoMauch Note Added: 0112944
2019-06-21 14:40 AugustoMauch Status resolved => closed
2019-06-21 14:40 AugustoMauch Fixed in Version => 3.0PR19Q3


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker