Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0041122
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajoralways2019-06-19 11:062019-06-27 17:18
Reportersalvador_campanellaView Statuspublic 
Assigned Tomigueldejuana 
PrioritynormalResolutionfixedFixed in VersionRR19Q3
StatusclosedFix in branchFixed in SCM revision1e151311e561
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toguilleaer
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0041122: the login in offline mode fails when the tomcat is retarted and the postgres is down

Descriptionthe login in offline mode fails when the tomcat is retarted and the postgres is down
Steps To Reproduce- Start Postgres
- Start Tomcat
- Login on Web POS
- Make a Sales Order

- Stop Tomcat
- Stop Postgres
- Start Tomcat
- Make a Sales Order in web pos
- The WebPOS go Offline
- End the sesion

exist two ways to see the error:
----------------------------------
A - In the login page, refresh the window [F5]
or
B - In the login page, insert a bad password and try to login

The offline mode shows a error HTTP 404
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 0041144RR19Q2.1 closedmigueldejuana the login in offline mode fails when the tomcat is retarted and the postgres is down 
depends on backport 0041145RR19Q1.2 closedmigueldejuana the login in offline mode fails when the tomcat is retarted and the postgres is down 
related to defect 0040710 closedjavierRodriguez [19Q2] Offline log out shows an error and does not return to login page 

-  Notes
(0112954)
hgbot (developer)
2019-06-24 07:56

Repository: erp/pmods/org.openbravo.mobile.core
Changeset: a38605f1c48fe1ecabe3efd40d79ab2c3409f411
Author: Miguel de Juana <miguel.dejuana <at> openbravo.com>
Date: Mon Jun 24 07:56:42 2019 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/a38605f1c48fe1ecabe3efd40d79ab2c3409f411 [^]

Fixed issue 0041122: the login in offline mode fails when the tomcat is retarted and the postgres is down

- If database is down and tomcat started, we get 404 response and we are not stopping properly the flow, we do a reject, but this is not stopping the flow

---
M web/org.openbravo.mobile.core/source/offline/ob-fetch-manifest.js
---
(0112956)
migueldejuana (developer)
2019-06-24 08:02

It is happening since 18Q3 where Service Workers was introduced.
(0112962)
hgbot (developer)
2019-06-24 08:58

Repository: erp/pmods/org.openbravo.mobile.core
Changeset: 1e151311e561cb8ce9421a95c185768a9792686b
Author: Miguel de Juana <miguel.dejuana <at> openbravo.com>
Date: Mon Jun 24 08:58:05 2019 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/1e151311e561cb8ce9421a95c185768a9792686b [^]

Fixed issue 0041122: the login in offline mode fails when the tomcat is retarted and the postgres is down

- JSLint

---
M web/org.openbravo.mobile.core/source/offline/ob-fetch-manifest.js
---

- Issue History
Date Modified Username Field Change
2019-06-19 11:06 salvador_campanella New Issue
2019-06-19 11:06 salvador_campanella Assigned To => Retail
2019-06-19 11:06 salvador_campanella Triggers an Emergency Pack => No
2019-06-21 09:04 migueldejuana Assigned To Retail => migueldejuana
2019-06-21 09:08 migueldejuana Status new => scheduled
2019-06-24 07:56 hgbot Checkin
2019-06-24 07:56 hgbot Note Added: 0112954
2019-06-24 07:56 hgbot Status scheduled => resolved
2019-06-24 07:56 hgbot Resolution open => fixed
2019-06-24 07:56 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/a38605f1c48fe1ecabe3efd40d79ab2c3409f411 [^]
2019-06-24 08:02 migueldejuana Note Added: 0112956
2019-06-24 08:58 hgbot Checkin
2019-06-24 08:58 hgbot Note Added: 0112962
2019-06-24 08:58 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/a38605f1c48fe1ecabe3efd40d79ab2c3409f411 [^] => http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/1e151311e561cb8ce9421a95c185768a9792686b [^]
2019-06-27 17:18 guilleaer Review Assigned To => guilleaer
2019-06-27 17:18 guilleaer Status resolved => closed
2019-06-27 17:18 guilleaer Fixed in Version => RR19Q3
2019-07-16 16:28 ngarcia Relationship added related to 0040710


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker