Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0040905
TypeCategorySeverityReproducibilityDate SubmittedLast Update
design defect[Openbravo ERP] A. Platformminorhave not tried2019-05-20 08:332019-08-22 14:45
ReporterSandrahuguetView Statuspublic 
Assigned ToAugustoMauch 
PrioritynormalResolutionopenFixed in Version
StatusnewFix in branchFixed in SCM revision6457d6616229
ProjectionnoneETAnoneTarget Version
OSLinux 64 bitDatabasePostgreSQLJava version7.x
OS VersionOpenbravo Appliance 14.04Database version9.3.xAnt version1.9.x
Product VersionSCM revision 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0040905: It would be fine to automatically truncate the value if the reference is date

DescriptionIt would be fine to automatically truncate the value if the reference is date (not date/time).
Steps To ReproduceN/A
TagsNo tags attached.
Attached Filesdiff file icon transformDate.diff [^] (4,721 bytes) 2019-07-19 14:35 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0041476 closedalostale API Change: Columns that use the Date reference will only store date part (and not time part) in the database 
blocks defect 0040722 closedcollazoandy4 MovementDate is filled with time and should contain only with the date 

-  Notes
(0113693)
hgbot (developer)
2019-07-29 16:41

Repository: erp/devel/pi
Changeset: 6457d6616229b7c8cbabc82c4befc4891c98c6d1
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Mon Jul 29 16:40:42 2019 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/6457d6616229b7c8cbabc82c4befc4891c98c6d1 [^]

Fixes issue 40905: Values of Date properties are automatically truncated

Now before storing a date property in the database, the data is automatically truncated, its time
part is stripped.

This can be done because if a column uses the Date reference, its time part is not taken into account.
Stripping the time part allows to filter the date columns properly, otherwise the time part was
wrongfully taken into account.

There was not mechanism to transform a value at reference level, so a new hook has been added to
the DomainType class, with an empty default behaviour.

---
M src/org/openbravo/base/model/Property.java
M src/org/openbravo/base/model/domaintype/DateDomainType.java
M src/org/openbravo/base/model/domaintype/DomainType.java
M src/org/openbravo/base/structure/BaseOBObject.java
---
(0113694)
AugustoMauch (developer)
2019-07-29 16:56

Note that the current fix will not modify existing data.
(0113695)
hgbot (developer)
2019-07-29 17:13

Repository: erp/devel/pi
Changeset: 635b9156c59df2502ae7d03e6d5b50ccec0ea25f
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Mon Jul 29 17:13:08 2019 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/635b9156c59df2502ae7d03e6d5b50ccec0ea25f [^]

Related with issue 40905: Prevents NullPointerException when DomainType is null

---
M src/org/openbravo/base/model/Property.java
---
(0113697)
hgbot (developer)
2019-07-29 17:55

Repository: erp/devel/pi
Changeset: 85d17ee11787bfe60642075536729dea2ed2cd27
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Mon Jul 29 17:55:40 2019 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/85d17ee11787bfe60642075536729dea2ed2cd27 [^]

Related with issue 40905: Rollback changes, they break CI

---
M src/org/openbravo/base/model/Property.java
M src/org/openbravo/base/model/domaintype/DateDomainType.java
M src/org/openbravo/base/model/domaintype/DomainType.java
M src/org/openbravo/base/structure/BaseOBObject.java
---
(0114062)
AugustoMauch (developer)
2019-08-19 09:44

Moved to design defect, as we have found no way to do it cleanly.

At first we tried truncating the date on the BaseOBObject.set method, but that was not a good point because that method is also invoked when Hibernate loads the data from database, and it is performining unintended changes
(0114181)
hudsonbot (developer)
2019-08-22 14:45

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/ad3efd3bd07c [^]
Maturity status: Test
(0114182)
hudsonbot (developer)
2019-08-22 14:45

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/ad3efd3bd07c [^]
Maturity status: Test
(0114183)
hudsonbot (developer)
2019-08-22 14:45

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/ad3efd3bd07c [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2019-05-20 08:33 Sandrahuguet New Issue
2019-05-20 08:33 Sandrahuguet Assigned To => platform
2019-05-20 08:33 Sandrahuguet Modules => Core
2019-05-20 08:33 Sandrahuguet Triggers an Emergency Pack => No
2019-05-20 08:34 Sandrahuguet Relationship added blocks 0040722
2019-05-20 08:37 Sandrahuguet Description Updated View Revisions
2019-05-20 08:38 Sandrahuguet Summary it would be fine to automatically truncate the value if the reference is date => It would be fine to automatically truncate the value if the reference is date
2019-05-20 08:38 Sandrahuguet Description Updated View Revisions
2019-07-19 14:35 AugustoMauch File Added: transformDate.diff
2019-07-29 16:36 AugustoMauch Assigned To platform => AugustoMauch
2019-07-29 16:36 AugustoMauch Status new => scheduled
2019-07-29 16:41 hgbot Checkin
2019-07-29 16:41 hgbot Note Added: 0113693
2019-07-29 16:41 hgbot Status scheduled => resolved
2019-07-29 16:41 hgbot Resolution open => fixed
2019-07-29 16:41 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/6457d6616229b7c8cbabc82c4befc4891c98c6d1 [^]
2019-07-29 16:56 AugustoMauch Note Added: 0113694
2019-07-29 17:03 AugustoMauch Relationship added related to 0041476
2019-07-29 17:13 hgbot Checkin
2019-07-29 17:13 hgbot Note Added: 0113695
2019-07-29 17:55 hgbot Checkin
2019-07-29 17:55 hgbot Note Added: 0113697
2019-07-29 18:01 AugustoMauch Status resolved => new
2019-07-29 18:01 AugustoMauch Resolution fixed => open
2019-08-19 09:44 AugustoMauch Note Added: 0114062
2019-08-19 09:44 AugustoMauch Type feature request => design defect
2019-08-22 14:45 hudsonbot Checkin
2019-08-22 14:45 hudsonbot Note Added: 0114181
2019-08-22 14:45 hudsonbot Checkin
2019-08-22 14:45 hudsonbot Note Added: 0114182
2019-08-22 14:45 hudsonbot Checkin
2019-08-22 14:45 hudsonbot Note Added: 0114183


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker