Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0040885
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajoralways2019-05-15 15:252019-06-27 13:40
ReporterlmonrealView Statuspublic 
Assigned Toranjith_qualiantech_com 
PrioritynormalResolutionfixedFixed in VersionRR19Q3
StatusclosedFix in branchFixed in SCM revision1af4792ddd93
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tojorge-garcia
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0040885: WEBPOS buttons freeze if Cancel is clicked when approval is displayed to approve cash difference when opening a Till.

DescriptionWEBPOS buttons freeze if Cancel is clicked when approval is displayed to approve cash difference when opening a Till.



It is similar to:
https://issues.openbravo.com/view.php?id=39655 [^]
Steps To Reproduce1.Configuration Preferences
Web POS Add Cash Differences approval
Value: Y
User Openbravo

Web POS Add Cash Differences approval
Value: N
User: Demouser

Steps:

1. Login in WEBPOS with Demouser to open a terminal
2. Open till screen is displayed, add a different cash amount
3. Click on Approve difference button
4. Approval is displayed, click Cancel
7. Buttons in WEBPOS freezes, so user is unable to click Cancel if he does not want to continue

Proposed SolutionWhen clicking cancel in approval buttons should be enabled
TagsNo tags attached.
Attached Filespng file icon FBTs.png [^] (119,175 bytes) 2019-05-15 15:25

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0039655 closedranjith_qualiantech_com WEBPOS freeze if Cancel is clicked when approval is displayed to do cash up after openning a WEBPOS closed from back office 

-  Notes
(0112880)
hgbot (developer)
2019-06-19 09:26

Repository: erp/pmods/org.openbravo.retail.sessions
Changeset: 559b38dbb9fd468de18b138b90043ebee752f27d
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Wed Jun 19 12:56:00 2019 +0530
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.sessions/rev/559b38dbb9fd468de18b138b90043ebee752f27d [^]

Related to issue 40885 : Till Toolbar Button status should be reset when approval is cancelled

---
M web/org.openbravo.retail.sessions/js/countcash/countcash.js
---
(0112887)
hgbot (developer)
2019-06-19 12:35

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 1af4792ddd938c02c55bb85c7912706d6c422533
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Wed Jun 19 16:01:25 2019 +0530
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/1af4792ddd938c02c55bb85c7912706d6c422533 [^]

Fixed issue 40885 : Approval Reason callback should be called with approval status

---
M web/org.openbravo.retail.posterminal/js/closecash/components/approvalreason-modal.js
M web/org.openbravo.retail.posterminal/js/closecash/view/tabcountcash.js
---
(0113054)
jorge-garcia (developer)
2019-06-27 13:24

The preference to reproduce the issue is "Web POS Add Cash Differences approval" instead of "Web POS Cash Up Differences Approval"
(0113055)
jorge-garcia (developer)
2019-06-27 13:40

Code reviewed and tested

- Issue History
Date Modified Username Field Change
2019-05-15 15:25 lmonreal New Issue
2019-05-15 15:25 lmonreal Assigned To => Retail
2019-05-15 15:25 lmonreal File Added: FBTs.png
2019-05-15 15:25 lmonreal Triggers an Emergency Pack => No
2019-05-15 15:28 lmonreal Steps to Reproduce Updated View Revisions
2019-05-15 15:28 lmonreal Proposed Solution updated
2019-05-15 15:29 lmonreal Issue Monitored: martinsdan
2019-06-12 07:47 guillermogil Relationship added related to 0039655
2019-06-12 14:24 ranjith_qualiantech_com Assigned To Retail => ranjith_qualiantech_com
2019-06-12 14:24 ranjith_qualiantech_com Status new => scheduled
2019-06-19 09:26 hgbot Checkin
2019-06-19 09:26 hgbot Note Added: 0112880
2019-06-19 12:35 hgbot Checkin
2019-06-19 12:35 hgbot Note Added: 0112887
2019-06-19 12:35 hgbot Status scheduled => resolved
2019-06-19 12:35 hgbot Resolution open => fixed
2019-06-19 12:35 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/1af4792ddd938c02c55bb85c7912706d6c422533 [^]
2019-06-27 09:43 jorge-garcia Review Assigned To => jorge-garcia
2019-06-27 13:24 jorge-garcia Steps to Reproduce Updated View Revisions
2019-06-27 13:24 jorge-garcia Note Added: 0113054
2019-06-27 13:40 jorge-garcia Note Added: 0113055
2019-06-27 13:40 jorge-garcia Status resolved => closed
2019-06-27 13:40 jorge-garcia Fixed in Version => RR19Q3


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker