Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0040787
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajoralways2019-05-06 11:152019-05-21 15:17
ReporterjavietxeView Statuspublic 
Assigned Toalostale 
PriorityimmediateResolutionfixedFixed in VersionRR19Q3
StatusclosedFix in branchFixed in SCM revisionb638e581f3c3
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tojorge-garcia
Regression levelProduction - QA Approved
Regression date2018-12-14
Regression introduced in releaseRR19Q1
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/925d93d4e8971f34caf04cd2cad44223fa74bf3c [^]
Triggers an Emergency PackNo
Summary

0040787: User roles requires backend access to login in WebPOS

DescriptionIf the Role is marked with the configuration "Restrict backend access", when trying to login to the POS, the login is refused.

The error shown is:

Access Restricted This user doesn't have access to the backend. To be able to access Openbravo, a user needs a role with access to the backend.

See attached picture.
Steps To Reproduce- Configure the user role to do login as "Restrict backend access"
- Try to login in the POS with a user of the previously configured role.
TagsNo tags attached.
Attached Filespng file icon Screenshot from 2019-05-06 11-12-54.png [^] (151,289 bytes) 2019-05-06 11:15

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 0040790RR19Q2 closedjorge-garcia Retail Modules User roles requires backend access to login in WebPOS 
depends on backport 0040791RR19Q1.1 closedjorge-garcia Retail Modules User roles requires backend access to login in WebPOS 
caused by defect 0039776 closedjarmendariz Openbravo ERP OBSecurityException appears after login with user with no roles 

-  Notes
(0111504)
hgbot (developer)
2019-05-06 15:51

Repository: erp/devel/pi
Changeset: b638e581f3c387f2faca0bcf025579d960cdcebd
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Mon May 06 15:49:37 2019 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/b638e581f3c387f2faca0bcf025579d960cdcebd [^]

fixed issue 40787: roles require back-office access to log in to mobile apps

  MobileLoginHandler does a back-office login to later select mobile default role,
  it expects back-office to fail and keep session in case of restricted role login
  attempt.

  Back-office login handler was changed to fail and remove session in case there is
  no back-office role in current user's list. This made not possible to log in to
  mobile apps.

  Now if logging in to a mobile application session is kept after failure as it was
  before.

---
M src/org/openbravo/base/secureApp/LoginHandler.java
---
(0111505)
hgbot (developer)
2019-05-06 15:51

Repository: erp/pmods/org.openbravo.mobile.core
Changeset: 5c9e2544976c7726e70f19eaef6c65bd49536ec2
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Mon May 06 15:50:19 2019 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/5c9e2544976c7726e70f19eaef6c65bd49536ec2 [^]

related to issue 40787: define mobile applications in login handler

---
M src/org/openbravo/mobile/core/login/MobileCoreLoginHandler.java
---
(0111508)
jorge-garcia (developer)
2019-05-06 16:40

Code reviewed and tested
(0112010)
hudsonbot (developer)
2019-05-21 15:17

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/9b8f37d9d85e [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2019-05-06 11:15 javietxe New Issue
2019-05-06 11:15 javietxe Assigned To => Retail
2019-05-06 11:15 javietxe File Added: Screenshot from 2019-05-06 11-12-54.png
2019-05-06 11:15 javietxe Regression introduced in release => RR19Q1
2019-05-06 11:15 javietxe Triggers an Emergency Pack => No
2019-05-06 15:40 alostale Relationship added caused by 0039776
2019-05-06 15:43 alostale Regression level => Production - QA Approved
2019-05-06 15:43 alostale Regression date => 2018-12-14
2019-05-06 15:43 alostale Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/925d93d4e8971f34caf04cd2cad44223fa74bf3c [^]
2019-05-06 15:43 alostale Assigned To Retail => alostale
2019-05-06 15:43 alostale Priority urgent => immediate
2019-05-06 15:44 alostale Status new => scheduled
2019-05-06 15:51 hgbot Checkin
2019-05-06 15:51 hgbot Note Added: 0111504
2019-05-06 15:51 hgbot Status scheduled => resolved
2019-05-06 15:51 hgbot Resolution open => fixed
2019-05-06 15:51 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/b638e581f3c387f2faca0bcf025579d960cdcebd [^]
2019-05-06 15:51 hgbot Checkin
2019-05-06 15:51 hgbot Note Added: 0111505
2019-05-06 15:52 alostale Review Assigned To => jorge-garcia
2019-05-06 16:40 jorge-garcia Note Added: 0111508
2019-05-06 16:40 jorge-garcia Status resolved => closed
2019-05-06 16:40 jorge-garcia Fixed in Version => RR19Q3
2019-05-21 15:17 hudsonbot Checkin
2019-05-21 15:17 hudsonbot Note Added: 0112010


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker