Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0040782
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] Z. Othersmajoralways2019-05-03 11:362019-05-07 12:26
ReporteranderarangurenView Statuspublic 
Assigned Toplatform 
PriorityurgentResolutionfixedFixed in Version3.0PR19Q1.1
StatusclosedFix in branchFixed in SCM revisionaa8cc9d96cad
ProjectionnoneETAnoneTarget Version3.0PR19Q1.1
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release3.0PR18Q2
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0040782: In Payment Out window, Add Details process, the Business Partner is not showing the records that it should

DescriptionIn Payment Out window, Add Details process, the Business Partner is not showing the records that it should
Steps To Reproduce18Q1
1. Go to Payment Out window
2. Create a record with Paying to Mountains & Snow S.L
3. Press Add Details
4. In G/L items section add a new record
5. See the Business Partners available
 
PI
1. Go to Payment Out window
2. Create a record with Paying to Mountains & Snow S.L
3. Press Add Details
4. In G/L items section add a new record
5. See the Business Partners available are not the same

Note that if selecting it from the magnifying glass button it can be seen everyone after cleaning the filter.
 
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0040763 closedAugustoMauch In Payment Out window, Add Details process, the Business Partner is showing customers when it should show vendors 

-  Notes
(0111533)
hgbot (developer)
2019-05-07 11:55

Repository: erp/backports/3.0PR19Q1.1
Changeset: aa8cc9d96cadf888203a6802077c4d5c8b389876
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Mon May 06 16:47:56 2019 +0200
URL: http://code.openbravo.com/erp/backports/3.0PR19Q1.1/rev/aa8cc9d96cadf888203a6802077c4d5c8b389876 [^]

Fixes issue 40782: Standard properties are taken from underlying window in P&E

When a P&E window contains a grid and a request to the datasource of the P&E window is done, it is
not clear whether the P&E grid or the underlying grid standard properties (tabId, tableId, windowId, etc)
should be included in the contextInfo.

Before this changeset [1] was pushed, the standard properties were taken from the underlying grid. The
changeset modified the behaviour, so that the P&E grid standard properties were included instead.
This was necessary because the SelectorConstants.includeOrgFilter method needed the table ID of the
P&E grid.

But the change caused another problem: Some OBBindings were relying on the underlying grid standard
properties being included in the contextInfo.

To fix both problems, now a new property called inpPickAndExecuteTableId is included when doing a
request from a P&E grid, and that property is referenced by SelectorConstants.includeOrgFilter.

The contextInfo now will include the standard properties of the underlying grid, as it was done
before [1].

[1] https://code.openbravo.com/erp/devel/pi/rev/1ed089db27e7036cf53026ca873dbcf104d79bb9 [^]

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/process/ob-pick-and-execute-grid.js
M modules/org.openbravo.userinterface.selector/src/org/openbravo/userinterface/selector/SelectorConstants.java
---
(0111537)
alostale (developer)
2019-05-07 12:25

reviewed + tested

- Issue History
Date Modified Username Field Change
2019-05-06 04:56 nonofrancisco Type defect => backport
2019-05-06 04:56 nonofrancisco Target Version => 3.0PR19Q1.1
2019-05-06 10:03 Sandrahuguet Assigned To nonofrancisco => platform
2019-05-07 11:55 hgbot Checkin
2019-05-07 11:55 hgbot Note Added: 0111533
2019-05-07 11:55 hgbot Status scheduled => resolved
2019-05-07 11:55 hgbot Resolution open => fixed
2019-05-07 11:55 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR19Q1.1/rev/aa8cc9d96cadf888203a6802077c4d5c8b389876 [^]
2019-05-07 12:25 alostale Review Assigned To => alostale
2019-05-07 12:25 alostale Note Added: 0111537
2019-05-07 12:26 alostale Status resolved => closed
2019-05-07 12:26 alostale Fixed in Version => 3.0PR19Q1.1


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker