Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0040763
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] Z. Othersmajoralways2019-05-03 11:362019-05-21 15:17
ReporteranderarangurenView Statuspublic 
Assigned ToAugustoMauch 
PriorityurgentResolutionfixedFixed in Version3.0PR19Q3
StatusclosedFix in branchFixed in SCM revisione0759ec376b4
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2018-03-06
Regression introduced in release3.0PR18Q2
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/1ed089db27e7036cf53026ca873dbcf104d79bb9 [^]
Triggers an Emergency PackNo
Summary

0040763: In Payment Out window, Add Details process, the Business Partner is showing customers when it should show vendors

DescriptionIn Payment Out window, Add Details process, the Business Partner is showing customers when it should show vendors
Steps To Reproduce18Q1
1. Go to Payment Out window
2. Create a record with Paying to Mountains & Snow S.L
3. Press Add Details
4. In G/L items section add a new record
5. See the Business Partners available
 
PI
1. Go to Payment Out window
2. Create a record with Paying to Mountains & Snow S.L
3. Press Add Details
4. In G/L items section add a new record
5. See the Business Partners available are not the same

Note that if selecting it from the magnifying glass button it can be seen everyone after cleaning the filter.
 
TagsNo tags attached.
Attached Filespng file icon PaymentOut18Q1.png [^] (142,807 bytes) 2019-05-03 11:36


png file icon PaymentOutPi.png [^] (147,779 bytes) 2019-05-03 11:37

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00407813.0PR19Q2 closedplatform In Payment Out window, Add Details process, the Business Partner is not showing the records that it should 
depends on backport 00407823.0PR19Q1.1 closedplatform In Payment Out window, Add Details process, the Business Partner is not showing the records that it should 
depends on backport 00407833.0PR18Q4.4 closednonofrancisco In Payment Out window, Add Details process, the Business Partner is not showing the records that it should 
caused by defect 00380393.0PR18Q2 closedjarmendariz Organization filtering issues in Process Definition selectors 

-  Notes
(0111524)
hgbot (developer)
2019-05-07 09:48

Repository: erp/devel/pi
Changeset: e0759ec376b48d7c7d789b9c978a7b308b394d74
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Mon May 06 16:47:56 2019 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/e0759ec376b48d7c7d789b9c978a7b308b394d74 [^]

Fixes issue 40763: Standard properties are taken from underlying window in P&E

When a P&E window contains a grid and a request to the datasource of the P&E window is done, it is
not clear whether the P&E grid or the underlying grid standard properties (tabId, tableId, windowId, etc)
should be included in the contextInfo.

Before this changeset [1] was pushed, the standard properties were taken from the underlying grid. The
changeset modified the behaviour, so that the P&E grid standard properties were included instead.
This was necessary because the SelectorConstants.includeOrgFilter method needed the table ID of the
P&E grid.

But the change caused another problem: Some OBBindings were relying on the underlying grid standard
properties being included in the contextInfo.

To fix both problems, now a new property called inpPickAndExecuteTableId is included when doing a
request from a P&E grid, and that property is referenced by SelectorConstants.includeOrgFilter.

The contextInfo now will include the standard properties of the underlying grid, as it was done
before [1].

[1] https://code.openbravo.com/erp/devel/pi/rev/1ed089db27e7036cf53026ca873dbcf104d79bb9 [^]

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/process/ob-pick-and-execute-grid.js
M modules/org.openbravo.userinterface.selector/src/org/openbravo/userinterface/selector/SelectorConstants.java
---
(0111532)
alostale (developer)
2019-05-07 11:27

reviewed + tested
(0112012)
hudsonbot (developer)
2019-05-21 15:17

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/9b8f37d9d85e [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2019-05-03 11:36 anderaranguren New Issue
2019-05-03 11:36 anderaranguren Assigned To => Triage Finance
2019-05-03 11:36 anderaranguren File Added: PaymentOut18Q1.png
2019-05-03 11:36 anderaranguren Modules => Core
2019-05-03 11:36 anderaranguren Regression introduced in release => 3.0PR18Q2
2019-05-03 11:36 anderaranguren Triggers an Emergency Pack => No
2019-05-03 11:37 anderaranguren File Added: PaymentOutPi.png
2019-05-03 11:43 Sandrahuguet Assigned To Triage Finance => nonofrancisco
2019-05-06 04:56 nonofrancisco Status new => scheduled
2019-05-06 09:54 Sandrahuguet Assigned To nonofrancisco => platform
2019-05-06 16:09 AugustoMauch Regression level => Production - Confirmed Stable
2019-05-06 16:09 AugustoMauch Regression date => 2018-03-06
2019-05-06 16:09 AugustoMauch Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/1ed089db27e7036cf53026ca873dbcf104d79bb9 [^]
2019-05-06 16:09 AugustoMauch Assigned To platform => AugustoMauch
2019-05-06 16:09 AugustoMauch Relationship added caused by 0038039
2019-05-06 17:48 anderaranguren Summary In Payment Out window, Add Details process, the Business Partner is not showing the records that it should => In Payment Out window, Add Details process, the Business Partner is showing customers when it should show vendors
2019-05-06 17:48 anderaranguren Description Updated View Revisions
2019-05-07 09:48 hgbot Checkin
2019-05-07 09:48 hgbot Note Added: 0111524
2019-05-07 09:48 hgbot Status scheduled => resolved
2019-05-07 09:48 hgbot Resolution open => fixed
2019-05-07 09:48 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/e0759ec376b48d7c7d789b9c978a7b308b394d74 [^]
2019-05-07 11:27 alostale Review Assigned To => alostale
2019-05-07 11:27 alostale Note Added: 0111532
2019-05-07 11:27 alostale Status resolved => closed
2019-05-07 11:27 alostale Fixed in Version => 3.0PR19Q3
2019-05-21 15:17 hudsonbot Checkin
2019-05-21 15:17 hudsonbot Note Added: 0112012


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker