Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0040631
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Modules] Analyticsminorhave not tried2019-04-17 09:572019-04-19 08:10
ReportercaristuView Statuspublic 
Assigned Tocaristu 
PriorityurgentResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revisione7825a37d2cb
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Regression date
Regression introduced by commit
Regression level
Review Assigned Toalostale
Regression introduced in release
Summary

0040631: Analytics module fails to compile after Hibernate upgrade to version 5.4

DescriptionAs part of the Hibernate upgrade to version 5.4, the dom4j library was also upgraded to version 2.1.1.jar.

Analytics fails to compile having that dom4j library version:

  [javac] /srv/ci/workspace/mod-simple-ci23.18103/modules/org.openbravo.client.analytics/src/org/openbravo/client/analytics/report/AnalyticsProcessReportHandlerReplaceBP.java:64: error: incompatible types: List<Node> cannot be converted to ArrayList<Element>
    [javac] .selectNodes("Axis");
    [javac] ^
    [javac] /srv/ci/workspace/mod-simple-ci23.18103/modules/org.openbravo.client.analytics/src/org/openbravo/client/analytics/report/AnalyticsProcessReportHandlerReplaceBP.java:70: error: incompatible types: List<Node> cannot be converted to Collection<Element>
    [javac] .selectNodes("Dimension");
    [javac]
Steps To Reproduce1) Update pi to a revision equal or higher than https://code.openbravo.com/erp/devel/pi/rev/bdd63e1a834142c97bca4bee8ad1f5afbfadaafd [^]

2) Install analytics module. The compilation fails.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
caused by feature request 0040552 closedcaristu Openbravo ERP upgrade hibernate to version 5.4 

-  Notes
(0111180)
hgbot (developer)
2019-04-17 11:53

Repository: erp/pmods/org.openbravo.client.analytics
Changeset: e7825a37d2cbf9b5717a136d04dc527e47049673
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Wed Apr 17 11:48:48 2019 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.client.analytics/rev/e7825a37d2cbf9b5717a136d04dc527e47049673 [^]

fixes issue 40631: compilation error with dom4j-2.1.1

  With he dom4j-2.1.1.jar library (upgraded with [1]), the selectNodes method of Node class now returns the parameterized type List<Node>. Before it was returning the raw List,i.e., without defining the type parameter.

  Add the changes to adapt to this API change.

---
M src/org/openbravo/client/analytics/report/AnalyticsProcessReportHandlerReplaceBP.java
---
(0111197)
hgbot (developer)
2019-04-17 14:20

Repository: erp/pmods/org.openbravo.client.analytics
Changeset: 0eb79199135f4d053d71ea36f76d4562e67dbeea
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Wed Apr 17 14:20:00 2019 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.client.analytics/rev/0eb79199135f4d053d71ea36f76d4562e67dbeea [^]

related to issue 40631: remove warning no longer needed

---
M src/org/openbravo/client/analytics/mondrian/Mondrian4SchemaGenerator.java
---
(0111212)
alostale (developer)
2019-04-19 08:10

reviewed

- Issue History
Date Modified Username Field Change
2019-04-17 09:57 caristu New Issue
2019-04-17 09:57 caristu Assigned To => platform
2019-04-17 09:57 caristu Assigned To platform => caristu
2019-04-17 09:58 caristu Relationship added caused by 0040552
2019-04-17 09:58 caristu Summary Analytics module fails to compile after => Analytics module fails to compile after Hibernate upgrade to version 5.4
2019-04-17 11:53 hgbot Checkin
2019-04-17 11:53 hgbot Note Added: 0111180
2019-04-17 11:53 hgbot Status new => resolved
2019-04-17 11:53 hgbot Resolution open => fixed
2019-04-17 11:53 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.client.analytics/rev/e7825a37d2cbf9b5717a136d04dc527e47049673 [^]
2019-04-17 11:54 caristu Review Assigned To => alostale
2019-04-17 12:34 caristu Steps to Reproduce Updated View Revisions
2019-04-17 14:20 hgbot Checkin
2019-04-17 14:20 hgbot Note Added: 0111197
2019-04-19 08:10 alostale Note Added: 0111212
2019-04-19 08:10 alostale Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker