Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0040603
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminorhave not tried2019-04-12 09:202019-05-21 15:16
ReporteralostaleView Statuspublic 
Assigned Tojarmendariz 
PriorityimmediateResolutionfixedFixed in Version3.0PR19Q3
StatusclosedFix in branchFixed in SCM revision2ccef54104f1
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2018-07-11
Regression introduced in release3.0PR18Q4
Regression introduced by commithttp://code.openbravo.com/erp/devel/pi/rev/cf4416b527d97adba57b97484b66a33284101738 [^]
Triggers an Emergency PackNo
Summary

0040603: NPE sending email if timeout not set

DescriptionIf email configuration does not define a timeout, a NPE is thrown when trying to send email.
Steps To Reproduce1. Create an Email Configuration for current Client
   -> do not set Smtp Connection Timeout field
2. Open any Sales Invoice
3. Click on the email toolbar button and click on Send after populating mandatory fields
   -> ERROR:
      * In UI "Problems while sending the email" appears
      * In openbravo.log:
2019-04-12 09:10:26,328 [http-nio-8080-exec-9] ERROR org.openbravo.erpCommon.utility.reporting.printing.PrintInvoices - error sending mail
java.lang.NullPointerException: null
    at org.openbravo.erpCommon.utility.poc.EmailManager.sendEmail(EmailManager.java:67) ~[classes/:?]
    at org.openbravo.erpCommon.utility.reporting.printing.PrintController.sendDocumentEmail(PrintController.java:821) [classes/:?]
    at org.openbravo.erpCommon.utility.reporting.printing.PrintController.post(PrintController.java:416) [classes/:?]
    at org.openbravo.erpCommon.utility.reporting.printing.PrintInvoices.doPost(PrintInvoices.java:57) [classes/:?]
        ...
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00406043.0PR19Q2 closedjarmendariz NPE sending email if timeout not set 
depends on backport 00406053.0PR19Q1.1 closedjarmendariz NPE sending email if timeout not set 
depends on backport 00406063.0PR18Q4.3 closedjarmendariz NPE sending email if timeout not set 
caused by design defect 0038524 closedjarmendariz can't configure timeout for sending emails 

-  Notes
(0111121)
hgbot (developer)
2019-04-15 09:58

Repository: erp/devel/pi
Changeset: 2ccef54104f1f263a8d5e4847935b6a3339d3cb1
Author: Javier Armendáriz <javier.armendariz <at> openbravo.com>
Date: Fri Apr 12 14:54:40 2019 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/2ccef54104f1f263a8d5e4847935b6a3339d3cb1 [^]

Fixed issue 40603: NPE if email timeout is not set

Adding another null check to verify not only in the case that the email config
does not exist, but also that the timeout value is empty. In both cases the
default timeout should be used.

---
M src/org/openbravo/erpCommon/utility/poc/EmailManager.java
---
(0111160)
alostale (developer)
2019-04-16 08:38

reviewed + tested
(0111976)
hudsonbot (developer)
2019-05-21 15:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/9b8f37d9d85e [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2019-04-12 09:20 alostale New Issue
2019-04-12 09:20 alostale Assigned To => jarmendariz
2019-04-12 09:20 alostale Modules => Core
2019-04-12 09:20 alostale Regression level => Production - Confirmed Stable
2019-04-12 09:20 alostale Regression date => 2018-07-11
2019-04-12 09:20 alostale Regression introduced in release => 3.0PR18Q4
2019-04-12 09:20 alostale Triggers an Emergency Pack => No
2019-04-12 09:20 alostale Regression introduced by commit => http://code.openbravo.com/erp/devel/pi/rev/cf4416b527d97adba57b97484b66a33284101738 [^]
2019-04-12 09:20 alostale Relationship added caused by 0038524
2019-04-12 09:21 alostale Status new => scheduled
2019-04-15 09:58 hgbot Checkin
2019-04-15 09:58 hgbot Note Added: 0111121
2019-04-15 09:58 hgbot Status scheduled => resolved
2019-04-15 09:58 hgbot Resolution open => fixed
2019-04-15 09:58 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/2ccef54104f1f263a8d5e4847935b6a3339d3cb1 [^]
2019-04-15 12:09 jarmendariz Review Assigned To => alostale
2019-04-16 08:38 alostale Note Added: 0111160
2019-04-16 08:38 alostale Status resolved => closed
2019-04-16 08:38 alostale Fixed in Version => 3.0PR19Q3
2019-05-21 15:16 hudsonbot Checkin
2019-05-21 15:16 hudsonbot Note Added: 0111976


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker