Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0040520
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Modules] Advance Warehouse Operationsmajoralways2019-04-04 11:422019-05-03 09:47
Reporterjoniturralde93View Statuspublic 
Assigned ToAugustoMauch 
PriorityhighResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Regression date
Regression introduced by commit
Regression level
Review Assigned To
Regression introduced in release
Summary

0040520: Dependency problem when installing AWO External Data Load module

DescriptionDependency problem when installing AWO External Data Load module in version 18Q4. It shows a dependency error message and it installs version 1.0.0
Steps To ReproduceIn version PR18Q4, as System Administrator:
 - Open 'Module Management' window -> Settings, and select search modules in QA
 - install AWO
 - then install 'Advanced Warehouse Operations External Data Load' module. It will show a message to install 1.0.0, see the attached screenshot.
 - Compile the application, an error will be shown on the console:

     [java] 52147 ERROR - Error while inserting into the database: ERROR: duplicate key value violates unique constraint "obedl_out_type_key"
     [java] Detail: Key (obedl_output_type_id)=(0A5E3FF505B9442D8A67C093D90E9A6D) already exists.
     [java] org.postgresql.util.PSQLException: ERROR: duplicate key value violates unique constraint "obedl_out_type_key"
     [java] Detail: Key (obedl_output_type_id)=(0A5E3FF505B9442D8A67C093D90E9A6D) already exists.
     [java] at org.postgresql.core.v3.QueryExecutorImpl.receiveErrorResponse(QueryExecutorImpl.java:2433)
     [java] at org.postgresql.core.v3.QueryExecutorImpl.processResults(QueryExecutorImpl.java:2178)
     [java] at org.postgresql.core.v3.QueryExecutorImpl.execute(QueryExecutorImpl.java:306)
     [java] at org.postgresql.jdbc.PgStatement.executeInternal(PgStatement.java:441)
     [java] at org.postgresql.jdbc.PgStatement.execute(PgStatement.java:365)
     [java] at org.postgresql.jdbc.PgPreparedStatement.executeWithFlags(PgPreparedStatement.java:155)
     [java] at org.postgresql.jdbc.PgPreparedStatement.executeUpdate(PgPreparedStatement.java:132)
     [java] at org.apache.commons.dbcp.DelegatingPreparedStatement.executeUpdate(DelegatingPreparedStatement.java:105)
     [java] at org.apache.commons.dbcp.DelegatingPreparedStatement.executeUpdate(DelegatingPreparedStatement.java:105)
     [java] at org.apache.ddlutils.platform.PlatformImplBase.insert(PlatformImplBase.java:1640)
     [java] at org.apache.ddlutils.platform.PlatformImplBase.alterData(PlatformImplBase.java:866)
     [java] at org.openbravo.ddlutils.process.DBUpdater.update(DBUpdater.java:119)
     [java] at org.openbravo.ddlutils.task.AlterDatabaseDataAll.doExecute(AlterDatabaseDataAll.java:69)
     [java] at org.openbravo.ddlutils.task.BaseDatabaseTask.execute(BaseDatabaseTask.java:88)
     [java] at org.openbravo.ddlutils.task.AlterDatabaseJava.main(AlterDatabaseJava.java:81)
     [java] org.apache.ddlutils.DatabaseOperationException: Error while inserting into the database: ERROR: duplicate key value violates unique constraint "obedl_out_type_key"
     [java] Detail: Key (obedl_output_type_id)=(0A5E3FF505B9442D8A67C093D90E9A6D) already exists.
     [java] at org.apache.ddlutils.platform.PlatformImplBase.insert(PlatformImplBase.java:1648)
     [java] at org.apache.ddlutils.platform.PlatformImplBase.alterData(PlatformImplBase.java:866)
     [java] at org.openbravo.ddlutils.process.DBUpdater.update(DBUpdater.java:119)
     [java] at org.openbravo.ddlutils.task.AlterDatabaseDataAll.doExecute(AlterDatabaseDataAll.java:69)
     [java] at org.openbravo.ddlutils.task.BaseDatabaseTask.execute(BaseDatabaseTask.java:88)
     [java] at org.openbravo.ddlutils.task.AlterDatabaseJava.main(AlterDatabaseJava.java:81)
     [java] Caused by: org.postgresql.util.PSQLException: ERROR: duplicate key value violates unique constraint "obedl_out_type_key"
     [java] Detail: Key (obedl_output_type_id)=(0A5E3FF505B9442D8A67C093D90E9A6D) already exists.
     [java] at org.postgresql.core.v3.QueryExecutorImpl.receiveErrorResponse(QueryExecutorImpl.java:2433)
     [java] at org.postgresql.core.v3.QueryExecutorImpl.processResults(QueryExecutorImpl.java:2178)
     [java] at org.postgresql.core.v3.QueryExecutorImpl.execute(QueryExecutorImpl.java:306)
     [java] at org.postgresql.jdbc.PgStatement.executeInternal(PgStatement.java:441)
     [java] at org.postgresql.jdbc.PgStatement.execute(PgStatement.java:365)
     [java] at org.postgresql.jdbc.PgPreparedStatement.executeWithFlags(PgPreparedStatement.java:155)
     [java] at org.postgresql.jdbc.PgPreparedStatement.executeUpdate(PgPreparedStatement.java:132)
     [java] at org.apache.commons.dbcp.DelegatingPreparedStatement.executeUpdate(DelegatingPreparedStatement.java:105)
     [java] at org.apache.commons.dbcp.DelegatingPreparedStatement.executeUpdate(DelegatingPreparedStatement.java:105)
     [java] at org.apache.ddlutils.platform.PlatformImplBase.insert(PlatformImplBase.java:1640)
     [java] ... 5 more
     [java] Exception in thread "main" org.apache.ddlutils.DatabaseOperationException: Error while inserting into the database: ERROR: duplicate key value violates unique constraint "obedl_out_type_key"
     [java] Detail: Key (obedl_output_type_id)=(0A5E3FF505B9442D8A67C093D90E9A6D) already exists.
     [java] at org.openbravo.ddlutils.process.DBUpdater.update(DBUpdater.java:145)
     [java] at org.openbravo.ddlutils.task.AlterDatabaseDataAll.doExecute(AlterDatabaseDataAll.java:69)
     [java] at org.openbravo.ddlutils.task.BaseDatabaseTask.execute(BaseDatabaseTask.java:88)
     [java] at org.openbravo.ddlutils.task.AlterDatabaseJava.main(AlterDatabaseJava.java:81)
     [java] Caused by: org.apache.ddlutils.DatabaseOperationException: Error while inserting into the database: ERROR: duplicate key value violates unique constraint "obedl_out_type_key"
     [java] Detail: Key (obedl_output_type_id)=(0A5E3FF505B9442D8A67C093D90E9A6D) already exists.
     [java] at org.apache.ddlutils.platform.PlatformImplBase.insert(PlatformImplBase.java:1648)
     [java] at org.apache.ddlutils.platform.PlatformImplBase.alterData(PlatformImplBase.java:866)
     [java] at org.openbravo.ddlutils.process.DBUpdater.update(DBUpdater.java:119)
     [java] ... 3 more
     [java] Caused by: org.postgresql.util.PSQLException: ERROR: duplicate key value violates unique constraint "obedl_out_type_key"
     [java] Detail: Key (obedl_output_type_id)=(0A5E3FF505B9442D8A67C093D90E9A6D) already exists.
     [java] at org.postgresql.core.v3.QueryExecutorImpl.receiveErrorResponse(QueryExecutorImpl.java:2433)
     [java] at org.postgresql.core.v3.QueryExecutorImpl.processResults(QueryExecutorImpl.java:2178)
     [java] at org.postgresql.core.v3.QueryExecutorImpl.execute(QueryExecutorImpl.java:306)
     [java] at org.postgresql.jdbc.PgStatement.executeInternal(PgStatement.java:441)
     [java] at org.postgresql.jdbc.PgStatement.execute(PgStatement.java:365)
     [java] at org.postgresql.jdbc.PgPreparedStatement.executeWithFlags(PgPreparedStatement.java:155)
     [java] at org.postgresql.jdbc.PgPreparedStatement.executeUpdate(PgPreparedStatement.java:132)
     [java] at org.apache.commons.dbcp.DelegatingPreparedStatement.executeUpdate(DelegatingPreparedStatement.java:105)
     [java] at org.apache.commons.dbcp.DelegatingPreparedStatement.executeUpdate(DelegatingPreparedStatement.java:105)
     [java] at org.apache.ddlutils.platform.PlatformImplBase.insert(PlatformImplBase.java:1640)
     [java] ... 5 more

BUILD FAILED
/home/openbravo/Workspace/repos/18Q4/main/build.xml:404: The following error occurred while executing this line:
/home/openbravo/Workspace/repos/18Q4/main/build.xml:437: The following error occurred while executing this line:
/home/openbravo/Workspace/repos/18Q4/main/build.xml:696: The following error occurred while executing this line:
/home/openbravo/Workspace/repos/18Q4/main/src-db/database/build.xml:80: Java returned: 1
TagsNo tags attached.
Attached Filespng file icon Screenshot from 2019-04-04 11-26-36.png [^] (134,734 bytes) 2019-04-04 11:42

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0110980)
JONHM (developer)
2019-04-04 11:43

This issue is related to the module 'Advanced Warehouse Operations External Data Load'
(0111140)
AugustoMauch (developer)
2019-04-15 15:31

The dependency of version 1.0.2 of [1] to the EDL module was not proper, it has been fixed now

[1] http://centralrepository.openbravo.com/openbravo/org.openbravo.forge.ui/sso/ForgeModuleDetail/External-Integration-Infrastructure [^]
(0111459)
joniturralde93 (developer)
2019-05-03 09:47

Confirmed by customer

- Issue History
Date Modified Username Field Change
2019-04-04 11:42 JONHM New Issue
2019-04-04 11:42 JONHM Assigned To => Triage Finance
2019-04-04 11:42 JONHM File Added: Screenshot from 2019-04-04 11-26-36.png
2019-04-04 11:43 JONHM Note Added: 0110980
2019-04-04 12:15 Sandrahuguet Assigned To Triage Finance => nonofrancisco
2019-04-15 12:32 Sandrahuguet Assigned To nonofrancisco => AugustoMauch
2019-04-15 15:31 AugustoMauch Note Added: 0111140
2019-04-15 15:31 AugustoMauch Status new => feedback
2019-04-16 09:44 egoitz Reporter JONHM => joniturralde93
2019-05-03 09:47 joniturralde93 Status feedback => scheduled
2019-05-03 09:47 joniturralde93 Note Added: 0111459
2019-05-03 09:47 joniturralde93 Status scheduled => resolved
2019-05-03 09:47 joniturralde93 Resolution open => fixed
2019-05-03 09:47 joniturralde93 Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker