Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0040512
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminorhave not tried2019-04-03 13:362019-05-21 15:16
ReportercaristuView Statuspublic 
Assigned Tocaristu 
PriorityhighResolutionfixedFixed in Version3.0PR19Q3
StatusclosedFix in branchFixed in SCM revision5a18bcb0e394
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0040512: slf4j extensions library can be removed

DescriptionThe slf4j-ext-1.7.25.jar can be safely removed. It is an extension[1] of slf4j which is a dependency of weld 1.1.24. After the weld upgrade (0040193) it is no longer needed.

[1] https://www.slf4j.org/extensions.html [^]
Steps To ReproduceIn description
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to feature request 0040193 closedcaristu upgrade Weld to version 3.1.0.Final 
related to feature request 0040540 newplatform Replace usage of SLF4J library with Log4j version 2 

-  Notes
(0110976)
hgbot (developer)
2019-04-03 13:50

Repository: erp/devel/pi
Changeset: 5a18bcb0e39403289b83a1fd4bfc831f6d124904
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Wed Apr 03 13:46:54 2019 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/5a18bcb0e39403289b83a1fd4bfc831f6d124904 [^]

fixes issue 40512: remove slf4j extensions library

  The slf4j extensions library was a dependency of weld 1.1.24. It is not needed by weld 3.1.0 because it no longer uses slf4j for logging. Instead, it uses jboss-logging as a logging facade.

---
M legal/Licensing.txt
R lib/runtime/slf4j-ext-1.7.25.jar
---
(0110989)
alostale (developer)
2019-04-05 09:10

reviewed
(0111959)
hudsonbot (developer)
2019-05-21 15:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/9b8f37d9d85e [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2019-04-03 13:36 caristu New Issue
2019-04-03 13:36 caristu Assigned To => platform
2019-04-03 13:36 caristu Modules => Core
2019-04-03 13:36 caristu Triggers an Emergency Pack => No
2019-04-03 13:36 caristu Relationship added related to 0040193
2019-04-03 13:37 caristu Assigned To platform => caristu
2019-04-03 13:38 caristu Review Assigned To => alostale
2019-04-03 13:50 hgbot Checkin
2019-04-03 13:50 hgbot Note Added: 0110976
2019-04-03 13:50 hgbot Status new => resolved
2019-04-03 13:50 hgbot Resolution open => fixed
2019-04-03 13:50 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/5a18bcb0e39403289b83a1fd4bfc831f6d124904 [^]
2019-04-05 09:10 alostale Note Added: 0110989
2019-04-05 09:10 alostale Status resolved => closed
2019-04-05 09:10 alostale Fixed in Version => 3.0PR19Q3
2019-04-05 14:13 caristu Relationship added related to 0040540
2019-05-21 15:16 hudsonbot Checkin
2019-05-21 15:16 hudsonbot Note Added: 0111959


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker