Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0040476
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 07. Sales managementminoralways2019-03-28 13:062019-05-21 15:16
ReportervmromanosView Statuspublic 
Assigned Tononofrancisco 
PrioritynormalResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision92f93ee936b9
ProjectionnoneETAnoneTarget Version3.0PR19Q2
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tovmromanos
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0040476: Discounts and Promotions | Business Partner Set, Business Partner Set link doesn't work

DescriptionInside Discounts and Promotions | Business Partner Set, the Business Partner Set field link doesn't work.
Steps To ReproduceAs Openbravo Admin.
Go to Discounts and Promotions. Create any record and save it.
Go to Business Partner Set tab. Create a new record.
Try to browse to the Business Partner Set window using the link. It doesn't work.
Proposed SolutionDefine the right window in the correspondent AD_Table
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0110925)
nonofrancisco (developer)
2019-03-29 13:05

Test Plan.

As Openbravo Admin.
Go to Discounts and Promotions. Create any record and save it.
Go to Business Partner Set tab. Create a new record.
Using the link navigate to Business Partner Set window.
The Business Partner Set window is shown.
(0110931)
hgbot (developer)
2019-03-29 13:59

Repository: erp/devel/pi
Changeset: 92f93ee936b92d77d5a46dff84bc1a585ac943fe
Author: Nono Carballo <nonofce <at> gmail.com>
Date: Thu Mar 28 22:29:08 2019 -0400
URL: http://code.openbravo.com/erp/devel/pi/rev/92f93ee936b92d77d5a46dff84bc1a585ac943fe [^]

Fixes issue 40476: Missing window definition in C_BP_SET table

In Business Partner Set tab of Discount and Promotions window,
navigation to Business Parter Set window was not possible, due to missing
window definition in C_BP_SET table.
The Business Partner Set window was defined for this table.

---
M src-db/database/sourcedata/AD_TABLE.xml
---
(0110932)
vmromanos (developer)
2019-03-29 13:59

Code review + testing OK
(0111955)
hudsonbot (developer)
2019-05-21 15:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/9b8f37d9d85e [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2019-03-28 13:06 vmromanos New Issue
2019-03-28 13:06 vmromanos Assigned To => Triage Finance
2019-03-28 13:06 vmromanos Modules => Core
2019-03-28 13:06 vmromanos Triggers an Emergency Pack => No
2019-03-28 13:07 vmromanos Severity major => minor
2019-03-29 03:58 nonofrancisco Assigned To Triage Finance => nonofrancisco
2019-03-29 03:59 nonofrancisco Status new => scheduled
2019-03-29 13:05 nonofrancisco Note Added: 0110925
2019-03-29 13:59 hgbot Checkin
2019-03-29 13:59 hgbot Note Added: 0110931
2019-03-29 13:59 hgbot Status scheduled => resolved
2019-03-29 13:59 hgbot Resolution open => fixed
2019-03-29 13:59 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/92f93ee936b92d77d5a46dff84bc1a585ac943fe [^]
2019-03-29 13:59 vmromanos Review Assigned To => vmromanos
2019-03-29 13:59 vmromanos Note Added: 0110932
2019-03-29 13:59 vmromanos Status resolved => closed
2019-05-21 15:16 hudsonbot Checkin
2019-05-21 15:16 hudsonbot Note Added: 0111955


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker