Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0040438
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] B. User interfacetrivialhave not tried2019-03-22 11:042019-03-28 14:56
ReportercaristuView Statuspublic 
Assigned Tocaristu 
PrioritynormalResolutionfixedFixed in Version3.0PR19Q2
StatusclosedFix in branchFixed in SCM revision13a86070965b
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0040438: The field name to define the value of context parameters in AD is wrong

DescriptionThe field name to define the value of context parameters in AD is wrong: it is "Searck Key" but it should be "Value" instead. This is a bit confusing.

Together with this, the fields in that tab are not displayed following the standard order
Steps To Reproduce1) Log in as System Administrator
2) Go to the [AD Implementation Mapping] window
3) Select the "Openbravo Core Context Parameters" record in the header
4) Switch to the [Parameters Tab]. Note:
    a) The name of the "Search Key" field is confusing
    b) The order of the fields in the tab is not correct: mandatory fields should precede the rest of fields
TagsNo tags attached.
Attached Filespng file icon wrongFieldName.png [^] (106,443 bytes) 2019-03-22 11:07

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0110589)
hgbot (developer)
2019-03-22 12:35

Repository: erp/devel/pi
Changeset: 13a86070965b0f01cc2ae3e5d026d82a3ff53ff7
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Fri Mar 22 12:33:48 2019 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/13a86070965b0f01cc2ae3e5d026d82a3ff53ff7 [^]

fixes bug 40438: AD Implementation Mapping - Parameter tab UI improvements

    - Rename field "Search Key" as "Value"
    - Place mandatory fields at the beginning, both in grid and form views
    - Move "Value" AD_Element to core module because it is generic enough
    - By default do not sort by "Value" field

---
M modules/org.openbravo.client.application/src-db/database/sourcedata/AD_ELEMENT.xml
M src-db/database/sourcedata/AD_COLUMN.xml
M src-db/database/sourcedata/AD_ELEMENT.xml
M src-db/database/sourcedata/AD_FIELD.xml
---
(0110590)
hgbot (developer)
2019-03-22 12:53

Repository: erp/devel/pi
Changeset: d63dbf55ca53ab48046a65c1afdbf8882ee8d675
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Fri Mar 22 12:52:07 2019 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/d63dbf55ca53ab48046a65c1afdbf8882ee8d675 [^]

related to issue 40438: AD Implementation Mapping - Mapping tab UI improvements

  - Place mandatory field at the beginning, both in grid and form views

---
M src-db/database/sourcedata/AD_FIELD.xml
---
(0110644)
alostale (developer)
2019-03-26 09:00

reviewed
(0110885)
hudsonbot (developer)
2019-03-28 14:56

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b2fbc1588df4 [^]
Maturity status: Test
(0110886)
hudsonbot (developer)
2019-03-28 14:56

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b2fbc1588df4 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2019-03-22 11:04 caristu New Issue
2019-03-22 11:04 caristu Assigned To => platform
2019-03-22 11:04 caristu Modules => Core
2019-03-22 11:04 caristu Triggers an Emergency Pack => No
2019-03-22 11:04 caristu Steps to Reproduce Updated View Revisions
2019-03-22 11:07 caristu File Added: wrongFieldName.png
2019-03-22 12:35 hgbot Checkin
2019-03-22 12:35 hgbot Note Added: 0110589
2019-03-22 12:35 hgbot Status new => resolved
2019-03-22 12:35 hgbot Resolution open => fixed
2019-03-22 12:35 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/13a86070965b0f01cc2ae3e5d026d82a3ff53ff7 [^]
2019-03-22 12:36 caristu Assigned To platform => caristu
2019-03-22 12:36 caristu Review Assigned To => alostale
2019-03-22 12:53 hgbot Checkin
2019-03-22 12:53 hgbot Note Added: 0110590
2019-03-26 09:00 alostale Note Added: 0110644
2019-03-26 09:00 alostale Status resolved => closed
2019-03-26 09:00 alostale Fixed in Version => 3.0PR19Q2
2019-03-28 14:56 hudsonbot Checkin
2019-03-28 14:56 hudsonbot Note Added: 0110885
2019-03-28 14:56 hudsonbot Checkin
2019-03-28 14:56 hudsonbot Note Added: 0110886


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker