Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0040426
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] A. Platformmajorhave not tried2019-03-21 09:032019-03-21 11:43
ReporteralostaleView Statuspublic 
Assigned Tojarmendariz 
PrioritynormalResolutionfixedFixed in Version3.0PR19Q1
StatusclosedFix in branchFixed in SCM revision3eb04fed1351
ProjectionnoneETAnoneTarget Version3.0PR19Q1
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/6faaad2667fe [^]
Triggers an Emergency PackNo
Summary

0040426: no default log when updating to 19Q1 from 18Q4.1+

DescriptionWhen updating to 19Q1+ from 18Q4.1+ log is not automatically configured.

There is a build validation that should configure the log automatically on update if it is not previously manually done, although it works properly when updating from 18Q4, it is skipped when coming from something higher.
Steps To Reproduce1. Install a fresh 18Q4.1
2. Update to 19Q1
3. Rebuild
   -> Check log is not configured
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0040425 closedjarmendariz no default log when updating to 19Q1 from 18Q4.1+ 

-  Notes
(0110537)
hgbot (developer)
2019-03-21 11:33

Repository: erp/backports/3.0PR19Q1
Changeset: 3eb04fed13516d35dc654d69a279cd3cc13bca8c
Author: Javier Armendáriz <javier.armendariz <at> openbravo.com>
Date: Thu Mar 21 09:52:12 2019 +0100
URL: http://code.openbravo.com/erp/backports/3.0PR19Q1/rev/3eb04fed13516d35dc654d69a279cd3cc13bca8c [^]

Fixed issue 40426: log config file not created when updating from 18Q4.1+

Removed execution limit, so this build validation is executed when log4j2*.xml
is not found.

---
M src-util/buildvalidation/build/classes/org/openbravo/buildvalidation/CopyLog4jConfigurationFromTemplates.class
M src-util/buildvalidation/src/org/openbravo/buildvalidation/CopyLog4jConfigurationFromTemplates.java
---
(0110539)
alostale (developer)
2019-03-21 11:43

reviewed

tested: now default config is always applied if it was not present regardless versions

- Issue History
Date Modified Username Field Change
2019-03-21 09:03 alostale Type defect => backport
2019-03-21 09:03 alostale Target Version => 3.0PR19Q1.1
2019-03-21 09:04 alostale Target Version 3.0PR19Q1.1 => 3.0PR19Q1
2019-03-21 09:05 alostale Relationship added caused by 0039504
2019-03-21 09:27 alostale Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/6faaad2667fe [^]
2019-03-21 09:30 alostale Relationship deleted caused by 0039504
2019-03-21 11:33 hgbot Checkin
2019-03-21 11:33 hgbot Note Added: 0110537
2019-03-21 11:33 hgbot Status scheduled => resolved
2019-03-21 11:33 hgbot Resolution open => fixed
2019-03-21 11:33 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR19Q1/rev/3eb04fed13516d35dc654d69a279cd3cc13bca8c [^]
2019-03-21 11:35 jarmendariz Review Assigned To => alostale
2019-03-21 11:43 alostale Note Added: 0110539
2019-03-21 11:43 alostale Status resolved => closed
2019-03-21 11:43 alostale Fixed in Version => 3.0PR19Q1


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker