Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0040425
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajorhave not tried2019-03-21 09:032019-03-28 14:56
ReporteralostaleView Statuspublic 
Assigned Tojarmendariz 
PriorityimmediateResolutionfixedFixed in Version3.0PR19Q2
StatusclosedFix in branchFixed in SCM revision58db95f4c316
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelPackaging and release
Regression date2018-11-21
Regression introduced in release3.0PR19Q1
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/6faaad2667fe [^]
Triggers an Emergency PackNo
Summary

0040425: no default log when updating to 19Q1 from 18Q4.1+

DescriptionWhen updating to 19Q1+ from 18Q4.1+ log is not automatically configured.

There is a build validation that should configure the log automatically on update if it is not previously manually done, although it works properly when updating from 18Q4, it is skipped when coming from something higher.
Steps To Reproduce1. Install a fresh 18Q4.1
2. Update to 19Q1
3. Rebuild
   -> Check log is not configured
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00404263.0PR19Q1 closedjarmendariz no default log when updating to 19Q1 from 18Q4.1+ 
caused by feature request 0039504 closedjarmendariz Upgrade Log4j to version 2 

-  Notes
(0110535)
hgbot (developer)
2019-03-21 10:31

Repository: erp/devel/pi
Changeset: 58db95f4c31613090f259dfd4292f941a3681cf7
Author: Javier Armendáriz <javier.armendariz <at> openbravo.com>
Date: Thu Mar 21 09:52:12 2019 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/58db95f4c31613090f259dfd4292f941a3681cf7 [^]

Fixed issue 40425: log config file not created when updating from 18Q4.1+

Removed execution limit, so this build validation is executed when log4j2*.xml
is not found.

---
M src-util/buildvalidation/build/classes/org/openbravo/buildvalidation/CopyLog4jConfigurationFromTemplates.class
M src-util/buildvalidation/src/org/openbravo/buildvalidation/CopyLog4jConfigurationFromTemplates.java
---
(0110538)
alostale (developer)
2019-03-21 11:43

reviewed

tested: now default config is always applied if it was not present regardless versions
(0110878)
hudsonbot (developer)
2019-03-28 14:56

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b2fbc1588df4 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2019-03-21 09:03 alostale New Issue
2019-03-21 09:03 alostale Assigned To => jarmendariz
2019-03-21 09:03 alostale Modules => Core
2019-03-21 09:03 alostale Triggers an Emergency Pack => No
2019-03-21 09:03 alostale Status new => scheduled
2019-03-21 09:30 alostale Relationship added caused by 0039504
2019-03-21 09:31 alostale Regression level => Packaging and release
2019-03-21 09:31 alostale Regression date => 2018-11-21
2019-03-21 09:31 alostale Regression introduced in release => 3.0PR19Q1
2019-03-21 09:31 alostale Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/6faaad2667fe [^]
2019-03-21 09:32 alostale Priority normal => immediate
2019-03-21 10:31 hgbot Checkin
2019-03-21 10:31 hgbot Note Added: 0110535
2019-03-21 10:32 hgbot Status scheduled => resolved
2019-03-21 10:32 hgbot Resolution open => fixed
2019-03-21 10:32 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/58db95f4c31613090f259dfd4292f941a3681cf7 [^]
2019-03-21 10:33 jarmendariz Review Assigned To => alostale
2019-03-21 11:43 alostale Note Added: 0110538
2019-03-21 11:43 alostale Status resolved => closed
2019-03-21 11:43 alostale Fixed in Version => 3.0PR19Q2
2019-03-28 14:56 hudsonbot Checkin
2019-03-28 14:56 hudsonbot Note Added: 0110878


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker