Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0040333
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 09. Financial managementmajoralways2019-03-06 17:522019-03-28 14:56
ReporterfranciscoView Statuspublic 
Assigned Tomarkmm82 
PriorityhighResolutionfixedFixed in Version3.0PR19Q2
StatusclosedFix in branchFixed in SCM revision8fef3f886c45
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToSandrahuguet
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0040333: Advance Filters in Trial Balance is not working

Descriptionwhen you are trying to filter in Filter advanced section: "From account" "To Account" the filter is not working
Steps To ReproduceIn Pi environment:
* Go to Trial Balance
* In Primary Filters:
    * From 01-01-2017
    * To 31-12-2019
    * Organization F&B International Group
* In Advanced Filters
    * Account level breakdown
Click on search and the result you see will be the same than if you apply one more filter.
Again in:
* In Advanced Filters
    * From Account select one account
    * To Account select one account
Click on search you will have the same result than before
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0110638)
markmm82 (developer)
2019-03-26 02:21

Test Plan:
As F&B Group Admin
* Go to Trial Balance
* In Primary Filters:
    * From 01-01-2017
    * To 31-12-2019
    * Organization F&B International Group
* In Advanced Filters
    * Account level Subaccount
    Notice that Account From and Account To fields are shown
Click on search and take note of the result you see.

* In Advanced Filters select accounts in a middle of previously results
    * From Account select one account (for example 40000)
    * To Account select one account (for example 60000)
Click on search and notice you just have those accounts in that range.

* In Advanced Filters select an account level different than Subaccount
    Notice that Account From and Account To fields are hidden.
Click on search and notice you have other results different than previously when the subaccount level was defined.
(0110662)
hgbot (developer)
2019-03-26 15:39

Repository: erp/devel/pi
Changeset: 8fef3f886c4539f047d5c2c1171b04f42c095736
Author: Mark Molina <mark.molina <at> doceleguas.com>
Date: Mon Mar 25 22:17:37 2019 -0300
URL: http://code.openbravo.com/erp/devel/pi/rev/8fef3f886c4539f047d5c2c1171b04f42c095736 [^]

Fixes issue 40333: Advance Filters in Trial Balance is not working

The account from/to filters should be shown just if the Account Level filter is
"Subaccount" in any other case it should be hidden as they are used in the report
just for this particular case.

The display logic of this section/fields was incorrect defined because after a previous
search it was setting as TRUE to display the fields if the Advanced Filters section is
expanded, but it might take into account also the display logic explained before
asking if the selected account level is "Subaccount".

When the Advanced filters section is expanded then these fields will be hidden if the
selected Account level is different than "Subaccount"

---
M src/org/openbravo/erpCommon/ad_reports/ReportTrialBalance.html
---
(0110663)
Sandrahuguet (developer)
2019-03-26 15:48

Code review + testing OK
(0110893)
hudsonbot (developer)
2019-03-28 14:56

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b2fbc1588df4 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2019-03-06 17:52 francisco New Issue
2019-03-06 17:52 francisco Assigned To => Triage Finance
2019-03-06 17:52 francisco Modules => Core
2019-03-06 17:52 francisco Triggers an Emergency Pack => No
2019-03-06 18:13 Practics Issue Monitored: Practics
2019-03-25 08:50 Sandrahuguet Assigned To Triage Finance => markmm82
2019-03-25 14:02 markmm82 Status new => acknowledged
2019-03-25 21:30 markmm82 Status acknowledged => scheduled
2019-03-26 02:21 markmm82 Note Added: 0110638
2019-03-26 15:39 hgbot Checkin
2019-03-26 15:39 hgbot Note Added: 0110662
2019-03-26 15:39 hgbot Status scheduled => resolved
2019-03-26 15:39 hgbot Resolution open => fixed
2019-03-26 15:39 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/8fef3f886c4539f047d5c2c1171b04f42c095736 [^]
2019-03-26 15:48 Sandrahuguet Review Assigned To => Sandrahuguet
2019-03-26 15:48 Sandrahuguet Note Added: 0110663
2019-03-26 15:48 Sandrahuguet Status resolved => closed
2019-03-26 15:48 Sandrahuguet Fixed in Version => 3.0PR19Q2
2019-03-28 14:56 hudsonbot Checkin
2019-03-28 14:56 hudsonbot Note Added: 0110893


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker