Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0040308
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminorhave not tried2019-03-04 12:282019-04-05 09:53
ReportercaristuView Statuspublic 
Assigned Tocaristu 
PrioritynormalResolutionfixedFixed in Version3.0PR19Q2
StatusclosedFix in branchFixed in SCM revisionc5133206f8ce
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0040308: Improvements for the Openbravo Eclipse project

DescriptionThe Openbravo Eclipse project requires some improvements:

- Instead of importing the servlet api using the Tomcat 7 server, the servlet-api library can be directly included in the classpath. This applies both for the openbravo and OpenbravoTest projects. (See attached tomcat-servlet-api.png).

- The "Deployment Assembly" (See attached deployment-assembly.png) of the openbravo project contains a wrong reference to OpenbravoCore. It also references the classes of the OpenbravoTest project that causes the src-test folder to be unnecessarily deployed as a "classes folder" in the "Web App Libraries" section. (See attached src-test-web-app-lib.png).

- openbravo project depends on OpenbravoTrl and OpenbravoWad. It should depend just in OpenbravoCore project. (See attached required-projects.png)

Steps To ReproduceIn description
TagsNo tags attached.
Attached Filespng file icon src-test-web-app-lib.png [^] (179,001 bytes) 2019-03-04 12:31


png file icon required-projects.png [^] (80,695 bytes) 2019-03-04 12:34


png file icon tomcat-servlet-api.png [^] (146,593 bytes) 2019-03-04 12:36


png file icon deployment-assembly.png [^] (102,954 bytes) 2019-03-04 12:44

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0040531 closedalostale remove js.jar from eclipse project classpath 
blocks design defect 0032688 acknowledgedplatform remove unused resources 

-  Notes
(0110204)
hgbot (developer)
2019-03-04 16:58

Repository: erp/devel/pi
Changeset: c5133206f8cebd856954f9b36f0079c0e4739743
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Mon Mar 04 16:41:53 2019 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/c5133206f8cebd856954f9b36f0079c0e4739743 [^]

fixes issue 40308: Improvements for the Openbravo Eclipse project

  - Include servlet-api in the classpath of the main and src-test projects instead of adding it through Tomcat 7 libraries
  - Set OpenbravoCore as required project
  - Remove OpenbravoTrl and OpenbravoWad as required projects
  - Remove src-test and broken OpenbravoCore entry from the Web Deployment Assembly

---
M .classpath.template
M .settings/org.eclipse.wst.common.component.template
M src-test/.classpath.template
---
(0110305)
hgbot (developer)
2019-03-08 10:09

Repository: erp/devel/pi
Changeset: e77b49e6d86d258be33ca91180ade95af4d58535
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Fri Mar 08 10:08:46 2019 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/e77b49e6d86d258be33ca91180ade95af4d58535 [^]

related to issue 40308: rearranged openbravo core position

  Having OpenbravoCore project on top of WebContent libraries, which includes
  openbravo-core.jar, allows to debug it and changed code to prevail over the
  one already compiled in the jar.

---
M .classpath.template
---
(0110306)
alostale (developer)
2019-03-08 10:15

reviewed + tested
(0110444)
hgbot (developer)
2019-03-14 16:19

Repository: erp/devel/pi
Changeset: 9a9b31642c6fbac8ac8c77de2801efcb40afb854
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Thu Mar 14 16:18:07 2019 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/9a9b31642c6fbac8ac8c77de2801efcb40afb854 [^]

related to issue 40308: OpenbravoWAD is not required by OpenbravoTest project

---
M src-test/.classpath.template
---
(0110450)
hgbot (developer)
2019-03-15 08:32

Repository: erp/devel/pi
Changeset: 04228a5d2a51b7b8e0ad3da5526cb8dbb5f75c8f
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Fri Mar 15 08:32:02 2019 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/04228a5d2a51b7b8e0ad3da5526cb8dbb5f75c8f [^]

related to issue 40308: removed Openbravo project web app libs from test

  As they don't need to be directly defined because they are indirectly through
  openbravo project dependency.

---
M src-test/.classpath.template
---
(0110844)
hudsonbot (developer)
2019-03-28 14:56

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b2fbc1588df4 [^]
Maturity status: Test
(0110855)
hudsonbot (developer)
2019-03-28 14:56

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b2fbc1588df4 [^]
Maturity status: Test
(0110869)
hudsonbot (developer)
2019-03-28 14:56

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b2fbc1588df4 [^]
Maturity status: Test
(0110870)
hudsonbot (developer)
2019-03-28 14:56

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b2fbc1588df4 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2019-03-04 12:28 caristu New Issue
2019-03-04 12:28 caristu Assigned To => caristu
2019-03-04 12:28 caristu Modules => Core
2019-03-04 12:28 caristu Triggers an Emergency Pack => No
2019-03-04 12:28 caristu Summary Improvements for Openbravo Eclipse project => Improvements for the Openbravo Eclipse project
2019-03-04 12:31 caristu File Added: src-test-web-app-lib.png
2019-03-04 12:32 caristu Description Updated View Revisions
2019-03-04 12:34 caristu File Added: required-projects.png
2019-03-04 12:34 caristu Description Updated View Revisions
2019-03-04 12:36 caristu File Added: tomcat-servlet-api.png
2019-03-04 12:36 caristu Description Updated View Revisions
2019-03-04 12:44 caristu Description Updated View Revisions
2019-03-04 12:44 caristu File Added: deployment-assembly.png
2019-03-04 16:18 caristu Description Updated View Revisions
2019-03-04 16:58 hgbot Checkin
2019-03-04 16:58 hgbot Note Added: 0110204
2019-03-04 16:58 hgbot Status new => resolved
2019-03-04 16:58 hgbot Resolution open => fixed
2019-03-04 16:58 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/c5133206f8cebd856954f9b36f0079c0e4739743 [^]
2019-03-04 17:08 caristu Review Assigned To => alostale
2019-03-08 10:09 hgbot Checkin
2019-03-08 10:09 hgbot Note Added: 0110305
2019-03-08 10:15 alostale Note Added: 0110306
2019-03-08 10:15 alostale Status resolved => closed
2019-03-08 10:15 alostale Fixed in Version => 3.0PR19Q2
2019-03-14 16:19 hgbot Checkin
2019-03-14 16:19 hgbot Note Added: 0110444
2019-03-15 08:32 hgbot Checkin
2019-03-15 08:32 hgbot Note Added: 0110450
2019-03-28 14:56 hudsonbot Checkin
2019-03-28 14:56 hudsonbot Note Added: 0110844
2019-03-28 14:56 hudsonbot Checkin
2019-03-28 14:56 hudsonbot Note Added: 0110855
2019-03-28 14:56 hudsonbot Checkin
2019-03-28 14:56 hudsonbot Note Added: 0110869
2019-03-28 14:56 hudsonbot Checkin
2019-03-28 14:56 hudsonbot Note Added: 0110870
2019-04-05 09:24 alostale Relationship added related to 0040531
2019-04-05 09:53 alostale Relationship added blocks 0032688


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker