Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0040194
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2019-02-14 11:062019-02-22 13:05
ReporterJONHMView Statuspublic 
Assigned Toalostale 
PriorityhighResolutionfixedFixed in Version3.0PR19Q2
StatusclosedFix in branchFixed in SCM revision965c58c02c48
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tocaristu
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0040194: HQL based windows are not supporting BLOB images

DescriptionHQL based windows are not supporting BLOB images. When an image is added to the query, an error is raised when opening the window:
Error occured: freemarker.template.TemplateModelException: get(tabView) failed on instance of org.openbravo.client.application.window.StandardWindowComponent
Steps To Reproduce- Install attached module
- Open 'Image Window' window, you will get an error
 * If the p.image is deleted from the HQL query (and also the related column and field), the window is correctly opened

  -> ERROR:
...
Caused by: java.lang.ClassCastException: org.openbravo.base.model.domaintype.SearchDomainType cannot be cast to org.openbravo.base.model.domaintype.PrimitiveDomainType
    at org.openbravo.service.datasource.HQLDataSourceService.getDataSourceProperties(HQLDataSourceService.java:127) ~[classes/:?]
    at org.openbravo.service.datasource.DataSourceComponent.getDataSourceProperties(DataSourceComponent.java:80) ~[classes/:?]
...
TagsNo tags attached.
Attached Files? file icon com.openbravo.addimage-1.0.0.obx [^] (10,004 bytes) 2019-02-14 11:06

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0110023)
hgbot (developer)
2019-02-22 10:34

Repository: erp/devel/pi
Changeset: 965c58c02c48aa8ccd07512d850d88d508aa9127
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Fri Feb 22 10:24:47 2019 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/965c58c02c48aa8ccd07512d850d88d508aa9127 [^]

fixed issue 40194: HQL based windows don't support Image reference

  When a image reference column was included in a HQL window, ClassCastException
  was thrown trying to cast SearchDomainType to PrimitiveDomainType. This was
  caused by an incorrect assumption that all non primitive properties must extend
  ForeignKeyUIDefinition.

  Now if a propoerty is primitive is checked by looking its domain type.

---
M modules/org.openbravo.service.datasource/src/org/openbravo/service/datasource/HQLDataSourceService.java
---
(0110033)
caristu (developer)
2019-02-22 13:05

Reviewed + tested

- Issue History
Date Modified Username Field Change
2019-02-14 11:06 JONHM New Issue
2019-02-14 11:06 JONHM Assigned To => platform
2019-02-14 11:06 JONHM File Added: com.openbravo.addimage-1.0.0.obx
2019-02-14 11:06 JONHM Modules => Core
2019-02-14 11:06 JONHM Triggers an Emergency Pack => No
2019-02-14 11:14 JONHM Description Updated View Revisions
2019-02-22 10:14 alostale Assigned To platform => alostale
2019-02-22 10:14 alostale Review Assigned To => caristu
2019-02-22 10:26 alostale Steps to Reproduce Updated View Revisions
2019-02-22 10:34 hgbot Checkin
2019-02-22 10:34 hgbot Note Added: 0110023
2019-02-22 10:34 hgbot Status new => resolved
2019-02-22 10:34 hgbot Resolution open => fixed
2019-02-22 10:34 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/965c58c02c48aa8ccd07512d850d88d508aa9127 [^]
2019-02-22 13:05 caristu Note Added: 0110033
2019-02-22 13:05 caristu Status resolved => closed
2019-02-22 13:05 caristu Fixed in Version => 3.0PR19Q2


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker