Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0040185
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajoralways2019-02-12 16:022019-03-18 13:17
ReporteranderarangurenView Statuspublic 
Assigned Torqueralta 
PriorityurgentResolutionfixedFixed in VersionRR19Q2
StatusclosedFix in branchFixed in SCM revisiona680374f2bcf
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Tomarvintm
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0040185: Wrong Verified Return on an order that has a line split into different Storage Bins

DescriptionIf an order is done taking different quantities from 2 different Storage Bin, for example: 0.5 qty from VBS/001 0-0-0 Storage bin and 0.5 from VBS/002.
After doing a verified Return instead of showing two lines both with -0.5qty it is showing one with -1 and the other with -0.5
Steps To ReproduceGo to Physical Inventory window from Backoffice and set avalanche transceiver 0.5qty for VBS/001 0-0-0 Storage Bin and 0.5qty for VBS/002 Storage Bin.
Go to web POS and do an order of 1 avalanche transceiver
Go to the Backoffice to Goods Shipment and see that there are two lines, one for each storage bin
Go to the web POS and select Verified Returns from the menu and select the order.
See that instead of -0.5 and -0.5, it is showing -1 and -0.5
TagsNo tags attached.
Attached Filespng file icon woutDisc.png [^] (151,133 bytes) 2019-02-12 16:03


png file icon wDiscBO.png [^] (132,837 bytes) 2019-02-12 16:03

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0109881)
hgbot (developer)
2019-02-16 04:07

Repository: erp/pmods/org.openbravo.retail.returns
Changeset: a680374f2bcfa70b79b02b2b6463e80fc692030e
Author: Rafael Queralta <rafaelcuba81 <at> gmail.com>
Date: Wed Feb 13 18:31:30 2019 -0500
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.returns/rev/a680374f2bcfa70b79b02b2b6463e80fc692030e [^]

Fixed issue 40185: Wrong Verified Return on an order that has a line split into
different Storage Bins

- Fixed the selectedQuantity property if after execute parseIn function the
selectedQuantity value is 0

---
M web/org.openbravo.retail.returns/js/modalReturnLines.js
---
(0110412)
hgbot (developer)
2019-03-13 15:27

Repository: erp/pmods/org.openbravo.retail.sampledata
Changeset: 16f28c4092a54ee16c3a898c629f1f28a65cf6f4
Author: Alejandro <alekosmp86 <at> gmail.com>
Date: Fri Feb 15 10:12:15 2019 -0500
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.sampledata/rev/16f28c4092a54ee16c3a898c629f1f28a65cf6f4 [^]

Related to issue 40185: Added new product for testing purposes

---
M referencedata/sampledata/The_White_Valley_Group/M_PRODUCT.xml
M referencedata/sampledata/The_White_Valley_Group/M_PRODUCTPRICE.xml
M referencedata/sampledata/The_White_Valley_Group/M_PRODUCT_ACCT.xml
M referencedata/sampledata/The_White_Valley_Group/M_STORAGE_DETAIL.xml
M referencedata/sampledata/The_White_Valley_Group/OBRETCO_PROL_PRODUCT.xml
---
(0110413)
hgbot (developer)
2019-03-13 15:27

Repository: tools/automation/pi-mobile
Changeset: 6cd9284ec037993c33eec308637cd07f52da1bd0
Author: Alejandro <alekosmp86 <at> gmail.com>
Date: Wed Mar 06 13:10:14 2019 -0500
URL: http://code.openbravo.com/tools/automation/pi-mobile/rev/6cd9284ec037993c33eec308637cd07f52da1bd0 [^]

Related to issue 40185: added automated test

---
M src-test/org/openbravo/test/mobile/core/utils/AllowedErrorsHelper.java
A src-test/org/openbravo/test/mobile/retail/pack/selenium/tests/returns/I40185_VerifyReturnWithLinesSplitInTwoDifferentSB.java
---
(0110448)
hgbot (developer)
2019-03-14 19:32

Repository: erp/pmods/org.openbravo.retail.sampledata
Changeset: fa076e4df2159139486d88916c9d3b91422b5f92
Author: Alejandro <alekosmp86 <at> gmail.com>
Date: Thu Mar 14 14:12:15 2019 -0400
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.sampledata/rev/fa076e4df2159139486d88916c9d3b91422b5f92 [^]

Related to issue 40185: product used in test has been disabled in Assortment so
it doesn't affect other tests. The test for this issue should activate/deactivate
it accordingly.

---
M referencedata/sampledata/The_White_Valley_Group/OBRETCO_PROL_PRODUCT.xml
---
(0110460)
hgbot (developer)
2019-03-15 14:53

Repository: erp/pmods/org.openbravo.retail.sampledata
Changeset: 59e6f1d0d72a8f1f814076b707054f11b0adc518
Author: Alejandro <alekosmp86 <at> gmail.com>
Date: Fri Mar 15 09:49:54 2019 -0400
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.sampledata/rev/59e6f1d0d72a8f1f814076b707054f11b0adc518 [^]

Related to issue 40185: removed sampledata for test due to conflicts with other
tests

---
M referencedata/sampledata/The_White_Valley_Group/OBRETCO_PROL_PRODUCT.xml
---
(0110461)
hgbot (developer)
2019-03-15 14:53

Repository: erp/pmods/org.openbravo.retail.sampledata
Changeset: 51f2de63637271eb364ff35a86d384a8be430be5
Author: Alejandro <alekosmp86 <at> gmail.com>
Date: Fri Mar 15 09:50:35 2019 -0400
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.sampledata/rev/51f2de63637271eb364ff35a86d384a8be430be5 [^]

Related to issue 40185: removed sampledata due to conflicts with other tests

---
M referencedata/sampledata/The_White_Valley_Group/M_PRODUCT.xml
M referencedata/sampledata/The_White_Valley_Group/M_PRODUCTPRICE.xml
M referencedata/sampledata/The_White_Valley_Group/M_PRODUCT_ACCT.xml
M referencedata/sampledata/The_White_Valley_Group/M_STORAGE_DETAIL.xml
M referencedata/sampledata/The_White_Valley_Group/OBRETCO_PROL_PRODUCT.xml
---
(0110462)
hgbot (developer)
2019-03-15 14:55

Repository: tools/automation/pi-mobile
Changeset: 58b381eb9e2264d96e026a4a2857acd03bdafb5b
Author: Alejandro <alekosmp86 <at> gmail.com>
Date: Fri Mar 15 09:54:50 2019 -0400
URL: http://code.openbravo.com/tools/automation/pi-mobile/rev/58b381eb9e2264d96e026a4a2857acd03bdafb5b [^]

Related to issue 40185: test has been disabled until sampledata is fixed

---
M src-test/org/openbravo/test/mobile/retail/pack/selenium/tests/returns/I40185_VerifyReturnWithLinesSplitInTwoDifferentSB.java
---
(0110476)
hgbot (developer)
2019-03-18 13:17

Repository: tools/automation/pi-mobile
Changeset: a58aeffc7685a3a56653809ea0375bc840b8be95
Author: Gorka Gil <gorka.gil <at> openbravo.com>
Date: Mon Mar 18 13:16:38 2019 +0100
URL: http://code.openbravo.com/tools/automation/pi-mobile/rev/a58aeffc7685a3a56653809ea0375bc840b8be95 [^]

Related to issue 40185: make that the test don't fail in ci with 'No runnable methods'

---
M src-test/org/openbravo/test/mobile/retail/pack/selenium/tests/returns/I40185_VerifyReturnWithLinesSplitInTwoDifferentSB.java
---

- Issue History
Date Modified Username Field Change
2019-02-12 16:02 anderaranguren New Issue
2019-02-12 16:02 anderaranguren Assigned To => Retail
2019-02-12 16:02 anderaranguren Triggers an Emergency Pack => No
2019-02-12 16:03 anderaranguren File Added: woutDisc.png
2019-02-12 16:03 anderaranguren File Added: wDiscBO.png
2019-02-12 17:18 rqueralta Assigned To Retail => rqueralta
2019-02-12 17:19 rqueralta Status new => scheduled
2019-02-16 04:07 hgbot Checkin
2019-02-16 04:07 hgbot Note Added: 0109881
2019-02-16 04:07 hgbot Status scheduled => resolved
2019-02-16 04:07 hgbot Resolution open => fixed
2019-02-16 04:07 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.returns/rev/a680374f2bcfa70b79b02b2b6463e80fc692030e [^]
2019-02-25 16:01 marvintm Review Assigned To => marvintm
2019-02-25 16:01 marvintm Status resolved => closed
2019-02-25 16:01 marvintm Fixed in Version => RR19Q2
2019-03-13 15:27 hgbot Checkin
2019-03-13 15:27 hgbot Note Added: 0110412
2019-03-13 15:27 hgbot Checkin
2019-03-13 15:27 hgbot Note Added: 0110413
2019-03-14 19:32 hgbot Checkin
2019-03-14 19:32 hgbot Note Added: 0110448
2019-03-15 14:53 hgbot Checkin
2019-03-15 14:53 hgbot Note Added: 0110460
2019-03-15 14:53 hgbot Checkin
2019-03-15 14:53 hgbot Note Added: 0110461
2019-03-15 14:55 hgbot Checkin
2019-03-15 14:55 hgbot Note Added: 0110462
2019-03-18 13:17 hgbot Checkin
2019-03-18 13:17 hgbot Note Added: 0110476


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker