Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0040176
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajoralways2019-02-11 12:222019-02-15 09:27
Reportersamuel_nicuesaView Statuspublic 
Assigned Toranjith_qualiantech_com 
PriorityimmediateResolutionfixedFixed in VersionRR19Q2
StatusclosedFix in branchFixed in SCM revision
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Tomarvintm
Regression level
Regression date
Regression introduced in releaseRR18Q1
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0040176: Business date in local storage is null if terminal does't have payments for cashup

DescriptionIn 17Q3 if you login in one terminal which doesn't have payments for cash up these two fields have the same information
OB.MobileApp.model.attributes.terminal.poss_businessdate === OB.UTIL.localStorage.getItem('businessdate')


IN 18Q3 if you login in one terminal which doesn't have payment for cash up OB.UTIL.localStorage.getItem('businessdate') is null
Steps To Reproduce[POS]

-Login in one terminal which doesn't have payments for cash up
-Put a break point here : if (!OB.MobileApp.model.get('hasPaymentsForCashup')) {
-You will see that OB.UTIL.localStorage.getItem('businessdate') won't be filled.
TagsNo tags attached.
Attached Filespatch file icon issue 40176 source sessions.patch [^] (1,185 bytes) 2019-02-12 10:20 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]
caused by defect 0037299 closedasiermartirena Is possible to open the 'Change Business Date' popup when logging with a terminal for seller 

-  Notes
(0109685)
hgbot (developer)
2019-02-12 10:58

Repository: erp/pmods/org.openbravo.retail.sessions
Changeset: cc0ae33771b3eaa6e2f68efb6e28bc46f67129d4
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Tue Feb 12 15:28:07 2019 +0530
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.sessions/rev/cc0ae33771b3eaa6e2f68efb6e28bc46f67129d4 [^]

Related to issue 40176 : LocalStorage BusinessDate should be updated when terminal has business date

* If LocalStorage BusinessDate is empty then LocalStorage BusinessDate should be updated with terminal's business date

---
M web/org.openbravo.retail.sessions/js/components/loginhook.js
---

- Issue History
Date Modified Username Field Change
2019-02-11 12:22 samuel_nicuesa New Issue
2019-02-11 12:22 samuel_nicuesa Assigned To => Retail
2019-02-11 12:22 samuel_nicuesa Regression date => 2019-02-18
2019-02-11 12:22 samuel_nicuesa Regression introduced in release => RR18Q1
2019-02-11 12:22 samuel_nicuesa Triggers an Emergency Pack => No
2019-02-11 12:23 samuel_nicuesa Relationship added caused by 0037299
2019-02-11 12:36 samuel_nicuesa Description Updated View Revisions
2019-02-11 12:36 samuel_nicuesa Steps to Reproduce Updated View Revisions
2019-02-11 13:43 marvintm Category Sessions => Web POS
2019-02-11 20:48 rqueralta Assigned To Retail => rqueralta
2019-02-11 20:48 rqueralta Status new => scheduled
2019-02-12 07:09 ranjith_qualiantech_com Assigned To rqueralta => ranjith_qualiantech_com
2019-02-12 10:20 ranjith_qualiantech_com File Added: issue 40176 source sessions.patch
2019-02-12 10:58 hgbot Checkin
2019-02-12 10:58 hgbot Note Added: 0109685
2019-02-13 08:51 ranjith_qualiantech_com Status scheduled => resolved
2019-02-13 08:51 ranjith_qualiantech_com Resolution open => fixed
2019-02-14 17:35 ngarcia Regression date 2019-02-18 =>
2019-02-15 09:27 marvintm Review Assigned To => marvintm
2019-02-15 09:27 marvintm Status resolved => closed
2019-02-15 09:27 marvintm Fixed in Version => RR19Q2


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker