Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0040134
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Retail Modules] Gift cards and gift vouchersminoralways2019-01-15 15:462019-03-01 14:37
ReporterlorenzofidalgoView Statuspublic 
Assigned Toranjith_qualiantech_com 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revisionb509d6517520
ProjectionnoneETAnoneTarget VersionRR19Q1
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionmainSCM revision 
Review Assigned Tojorge-garcia
Regression levelPackaging and release
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0040134: Broken POS layout when many options are shown

DescriptionAfter clicking Total Amount button, if 4 buttons are shown at the right of the screen, the layout is broken. There is an overflow and the layout is also displaced
Steps To Reproduce0-Having credit properly configured for "VBS Customer" Business Partner, Gift Cards and Vouchers module installed and a GC created and sold, log in POS as vallblanca.
1-Add 1x "Avalanche transceiver".
2-In dropdown menu, click "Layaway this receipt". After that, click Total Amount button.
3-In Payment methods, click More and click Gift Card payment method. It must be selected.
4-Now add click button "5" and button "0". 50 must appear in the screen. Then, click Enter button. Gift Cards popup must appear.
5-Click magnifier button and select the previously created and sold Gift Card. Then click Apply and the 50€ payment must be placed.
6-Due to 4 buttons are shown, the layout is broken (check attached image).
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0039958 closedranjith_qualiantech_com Broken POS layout when many options are shown 

-  Notes
(0109949)
hgbot (developer)
2019-02-20 10:42

Repository: retail/backports/3.0RR19Q1/org.openbravo.retail.posterminal
Changeset: b509d65175204ce74dbcb390864b710505f6e1f3
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Wed Feb 20 15:11:58 2019 +0530
URL: http://code.openbravo.com/retail/backports/3.0RR19Q1/org.openbravo.retail.posterminal/rev/b509d65175204ce74dbcb390864b710505f6e1f3 [^]

Fixed issue 40134 : Added CSS to show Payment Tab Process Buttons with Vertical Scroll

---
M web/org.openbravo.retail.posterminal/js/pointofsale/view/payment.js
---
(0109950)
hgbot (developer)
2019-02-20 10:42

Repository: retail/backports/3.0RR19Q1/org.openbravo.mobile.core
Changeset: 1a9c584e7705e7139032451f2f86da6b669c3ebc
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Wed Feb 20 15:12:17 2019 +0530
URL: http://code.openbravo.com/retail/backports/3.0RR19Q1/org.openbravo.mobile.core/rev/1a9c584e7705e7139032451f2f86da6b669c3ebc [^]

Related to issue 40134 : Added CSS to show Payment Tab Process Buttons with Vertical Scroll

---
M web/org.openbravo.mobile.core/assets/css/ob-standard.css
---
(0110152)
jorge-garcia (developer)
2019-03-01 14:37

Code reviewed and tested

- Issue History
Date Modified Username Field Change
2019-02-05 09:01 marvintm Type defect => backport
2019-02-05 09:01 marvintm Target Version => RR19Q1
2019-02-20 10:42 hgbot Checkin
2019-02-20 10:42 hgbot Note Added: 0109949
2019-02-20 10:42 hgbot Status scheduled => resolved
2019-02-20 10:42 hgbot Resolution open => fixed
2019-02-20 10:42 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/ff8ccfc00b92c6a9d9d74d089b6bc9b3cb11a442 [^] => http://code.openbravo.com/retail/backports/3.0RR19Q1/org.openbravo.retail.posterminal/rev/b509d65175204ce74dbcb390864b710505f6e1f3 [^]
2019-02-20 10:42 hgbot Checkin
2019-02-20 10:42 hgbot Note Added: 0109950
2019-03-01 14:37 jorge-garcia Review Assigned To => jorge-garcia
2019-03-01 14:37 jorge-garcia Note Added: 0110152
2019-03-01 14:37 jorge-garcia Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker