Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0040056
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Retail Modules] Web POSminoralways2019-01-29 17:282019-03-01 14:44
ReporterlorenzofidalgoView Statuspublic 
Assigned Togorka_gil 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision831a24be86db
ProjectionnoneETAnoneTarget VersionRR19Q1
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionmainSCM revision 
Review Assigned Tojorge-garcia
Regression levelPackaging and release
Regression date
Regression introduced in releasemain
Regression introduced by commithttp://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/1392001fae5266678b988e6d34f0550a9da81209 [^]
Triggers an Emergency PackNo
Summary

0040056: Clicking "x" button in a receipt paying process throws a JS error

DescriptionClicking "x" button to remove a payment throws a JS error (check attached image).
It has been always reproducible in Windows 8 tablet and in the TILL. It has been reproduced in pi and RR19Q1.
It has been reproduced once in a non touchable device.
Steps To Reproduce0-Log POS as vallblanca.
1-Add 1x "Avalanche transceiver" to the receipt.
2-Click Total Amount button.
3-Click "tick" button and click "x". DEFECT: A javascript error is thrown.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0040054 closedgorka_gil Clicking "x" button in a receipt paying process throws a JS error 

-  Notes
(0109426)
hgbot (developer)
2019-02-01 12:03

Repository: retail/backports/3.0RR19Q1/org.openbravo.mobile.core
Changeset: 831a24be86db36663ff569967f88641c674ef29c
Author: Gorka Gil <gorka.gil <at> openbravo.com>
Date: Wed Jan 30 18:26:12 2019 +0100
URL: http://code.openbravo.com/retail/backports/3.0RR19Q1/org.openbravo.mobile.core/rev/831a24be86db36663ff569967f88641c674ef29c [^]

Fixes issue 40056: [terminal log] stop using the image file name for buttons without text

When a button don't have text, to get a name for use in the terminal log,
previously it tries to find if it has an image and use the image file name.

This is a bit fragile since could be a race condition in slow machines
that makes that when trying to get the html element it don't exist.

This method has a fallback way, that is extract the name from the id,
now this fallback method is the only one, that is more robust
and gives similar names.

---
M web/org.openbravo.mobile.core/source/utils/ob-terminal-log.js
---
(0110156)
jorge-garcia (developer)
2019-03-01 14:44

Code reviewed and tested

- Issue History
Date Modified Username Field Change
2019-01-29 18:55 gorka_gil Type defect => backport
2019-01-29 18:55 gorka_gil Target Version => RR19Q1
2019-02-01 12:03 hgbot Checkin
2019-02-01 12:03 hgbot Note Added: 0109426
2019-02-01 12:03 hgbot Status scheduled => resolved
2019-02-01 12:03 hgbot Resolution open => fixed
2019-02-01 12:03 hgbot Fixed in SCM revision => http://code.openbravo.com/retail/backports/3.0RR19Q1/org.openbravo.mobile.core/rev/831a24be86db36663ff569967f88641c674ef29c [^]
2019-03-01 14:44 jorge-garcia Review Assigned To => jorge-garcia
2019-03-01 14:44 jorge-garcia Note Added: 0110156
2019-03-01 14:44 jorge-garcia Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker