Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0040054
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSminoralways2019-01-29 17:282019-02-06 13:39
ReporterlorenzofidalgoView Statuspublic 
Assigned Togorka_gil 
PriorityimmediateResolutionfixedFixed in VersionRR19Q2
StatusclosedFix in branchFixed in SCM revision362aa306bbb8
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionmainSCM revision 
Review Assigned Tojorge-garcia
Regression levelPackaging and release
Regression date
Regression introduced in releasemain
Regression introduced by commithttp://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/1392001fae5266678b988e6d34f0550a9da81209 [^]
Triggers an Emergency PackNo
Summary

0040054: Clicking "x" button in a receipt paying process throws a JS error

DescriptionClicking "x" button to remove a payment throws a JS error (check attached image).
It has been always reproducible in Windows 8 tablet and in the TILL. It has been reproduced in pi and RR19Q1.
It has been reproduced once in a non touchable device.
Steps To Reproduce0-Log POS as vallblanca.
1-Add 1x "Avalanche transceiver" to the receipt.
2-Click Total Amount button.
3-Click "tick" button and click "x". DEFECT: A javascript error is thrown.
TagsNo tags attached.
Attached Filespng file icon JSError.PNG [^] (123,210 bytes) 2019-01-29 17:28


diff file icon 40054-mobilecore-18q3.diff [^] (1,796 bytes) 2019-02-01 12:10 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 0040056RR19Q1 closedgorka_gil Clicking "x" button in a receipt paying process throws a JS error 
caused by design defect 0039360 closedgorka_gil Improve log client with cashier actions and processes start/end info 

-  Notes
(0109425)
hgbot (developer)
2019-02-01 11:51

Repository: erp/pmods/org.openbravo.mobile.core
Changeset: 362aa306bbb8ffaf306de58d139d6072ec9d29f9
Author: Gorka Gil <gorka.gil <at> openbravo.com>
Date: Wed Jan 30 18:26:12 2019 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/362aa306bbb8ffaf306de58d139d6072ec9d29f9 [^]

Fixes issue 40054: [terminal log] stop using the image file name for buttons without text

When a button don't have text, to get a name for use in the terminal log,
previously it tries to find if it has an image and use the image file name.

This is a bit fragile since could be a race condition in slow machines
that makes that when trying to get the html element it don't exist.

This method has a fallback way, that is extract the name from the id,
now this fallback method is the only one, that is more robust
and gives similar names.

---
M web/org.openbravo.mobile.core/source/utils/ob-terminal-log.js
---
(0109631)
jorge-garcia (developer)
2019-02-06 13:39

Code reviewed and tested

- Issue History
Date Modified Username Field Change
2019-01-29 17:28 lorenzofidalgo New Issue
2019-01-29 17:28 lorenzofidalgo Assigned To => Retail
2019-01-29 17:28 lorenzofidalgo File Added: JSError.PNG
2019-01-29 17:28 lorenzofidalgo Regression level => Packaging and release
2019-01-29 17:28 lorenzofidalgo Regression introduced in release => main
2019-01-29 17:28 lorenzofidalgo Triggers an Emergency Pack => No
2019-01-29 17:34 gorka_gil Assigned To Retail => gorka_gil
2019-01-29 18:55 gorka_gil Regression introduced by commit => http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/1392001fae5266678b988e6d34f0550a9da81209 [^]
2019-01-29 18:55 gorka_gil Relationship added caused by 0039360
2019-01-29 18:55 gorka_gil Status new => scheduled
2019-02-01 11:51 hgbot Checkin
2019-02-01 11:51 hgbot Note Added: 0109425
2019-02-01 11:51 hgbot Status scheduled => resolved
2019-02-01 11:51 hgbot Resolution open => fixed
2019-02-01 11:51 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/362aa306bbb8ffaf306de58d139d6072ec9d29f9 [^]
2019-02-01 12:10 gorka_gil File Added: 40054-mobilecore-18q3.diff
2019-02-06 10:42 jorge-garcia Review Assigned To => jorge-garcia
2019-02-06 13:39 jorge-garcia Note Added: 0109631
2019-02-06 13:39 jorge-garcia Status resolved => closed
2019-02-06 13:39 jorge-garcia Fixed in Version => RR19Q2


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker