Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0040049
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 04. Warehouse managementmajoralways2019-01-29 11:572019-03-28 14:56
ReporterngarciaView Statuspublic 
Assigned ToAtulOpenbravo 
PriorityurgentResolutionfixedFixed in Version3.0PR19Q2
StatusclosedFix in branchFixed in SCM revision9103f1b1f506
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToSandrahuguet
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0040049: Create Shipments from Orders is consuming Document Sequence although the shipment is not created because there is not stock

DescriptionCreate Shipments from Orders is consuming Document Sequence although the shipment is not created because there is not stock
Steps To ReproduceAs group admin role:
   Check there is not any storage bin that allows negative stock (Inventory Status should not have Overissue option selected)

   Create a new product and add a sales price list to it
   Create a sales order, add previously created product and book it
   Create a Goods Shipment header and check the provided document number (X)
   Go to Create Shipments from Orders window, select previously created sales order and process it. Check the following error is shown:
      Error:
         Order No. <>: No shipment could be created.
         Order line: 10 Insufficient stock: for product <>.
   Create a Goods Shipment header and check the provided document number is X+2 instead of X+1
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0109320)
AtulOpenbravo (developer)
2019-01-30 10:59

- Login as F&B International Group Admin.
- Check there is no storage bin that allows negative stock (Inventory Status should not have Overissue option selected)
- Create a new product and add a sales price list to it
- Create a sales order, add previously created product and book it
- Create a Goods Shipment header and check the provided document number (X)
- Go to Create Shipments from Orders window, select previously created sales
  order and process it. Check the following error is shown:
  Error:
         Order No. <>: No shipment could be created.
         Order line: 10 Insufficient stock: for product <>.

- Create a Goods Shipment header and check the provided document number is X+1 which is correct.

- Reactivate Sales Order and add a product having stock to it along with earlier product.
- Complete the order.
- Go to Create Shipments from Orders window, select previously created sales
  order and process it. Check the following warning is shown:
 
  Warning
  Order No. <> Shipment No. <>: Order partially delivered.
  Order line: 10 Insufficient stock: for product <>.

- Create a Goods Shipment header and check the provided document number is X+2 which is correct as in previous step partial Goods Shipment was created with document no X+1.
(0109838)
hgbot (developer)
2019-02-14 15:51

Repository: erp/devel/pi
Changeset: 9103f1b1f506e9d3a396387f14b7cc5a9419a6f7
Author: Atul Gaware <atul.gaware <at> openbravo.com>
Date: Wed Jan 30 11:29:47 2019 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/9103f1b1f506e9d3a396387f14b7cc5a9419a6f7 [^]

Fixes Issue 0040049: Create Shipments from Orders is consuming
Document Sequence although the shipment is not created because
there is not stock

While creating shipment header, get document no but do not
increment the document sequence, before processing shipment
get document no and increment document sequence. So whenever
there is condition that shipment cannot be created, document
sequence is not incremented unless shipment is eligible for
processing.

---
M src-db/database/model/functions/M_INOUT_CREATE.xml
---
(0109839)
Sandrahuguet (developer)
2019-02-14 15:56

Code review + testing ok
(0110816)
hudsonbot (developer)
2019-03-28 14:56

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b2fbc1588df4 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2019-01-29 11:57 ngarcia New Issue
2019-01-29 11:57 ngarcia Assigned To => Triage Finance
2019-01-29 11:57 ngarcia Modules => Core
2019-01-29 11:57 ngarcia Triggers an Emergency Pack => No
2019-01-29 12:15 Sandrahuguet Assigned To Triage Finance => AtulOpenbravo
2019-01-29 18:49 AtulOpenbravo Status new => scheduled
2019-01-30 10:59 AtulOpenbravo Note Added: 0109320
2019-02-14 15:51 hgbot Checkin
2019-02-14 15:51 hgbot Note Added: 0109838
2019-02-14 15:51 hgbot Status scheduled => resolved
2019-02-14 15:51 hgbot Resolution open => fixed
2019-02-14 15:51 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/9103f1b1f506e9d3a396387f14b7cc5a9419a6f7 [^]
2019-02-14 15:56 Sandrahuguet Review Assigned To => Sandrahuguet
2019-02-14 15:56 Sandrahuguet Note Added: 0109839
2019-02-14 15:56 Sandrahuguet Status resolved => closed
2019-02-14 15:56 Sandrahuguet Fixed in Version => 3.0PR19Q2
2019-03-28 14:56 hudsonbot Checkin
2019-03-28 14:56 hudsonbot Note Added: 0110816


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker