Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0040036
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajoralways2019-01-25 12:412019-02-14 16:57
ReporterfranciscoView Statuspublic 
Assigned Toranjith_qualiantech_com 
PriorityhighResolutionfixedFixed in VersionRR19Q2
StatusclosedFix in branchFixed in SCM revisione1725e1909d2
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionRR18Q4.1SCM revision 
Review Assigned Tomarvintm
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0040036: POS: save button when creating a new customer get blocked

Descriptionwhen a new customer is created in POS and there is some error in the form like a mandatory field blank, and the button save is clicked multiple time fast (at least triple click), the button get gray and blocked.
Steps To Reproduce* Go to VBS Customer
* Click in *New Customer
* Click multiple times(fast like a triple click) in save button, having mandatory fields in blank
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0109588)
hgbot (developer)
2019-02-05 14:53

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: e1725e1909d206cd4167ee173d0ea3f602a61837
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Tue Feb 05 19:22:38 2019 +0530
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/e1725e1909d206cd4167ee173d0ea3f602a61837 [^]

Fixed issue 40036 : Button should be disabled after blocked in customer save

* In Customer Save button, blocked condition is added to avoid multiple clicks
  Button should not be disabled when it is blocked due to multiple clicks

---
M web/org.openbravo.retail.posterminal/js/pointofsale/view/subwindows/customers/editcreatecustomerform.js
---

- Issue History
Date Modified Username Field Change
2019-01-25 12:41 francisco New Issue
2019-01-25 12:41 francisco Assigned To => Retail
2019-01-25 12:41 francisco Triggers an Emergency Pack => No
2019-02-04 09:07 francisco Reproducibility have not tried => always
2019-02-05 12:28 ranjith_qualiantech_com Assigned To Retail => ranjith_qualiantech_com
2019-02-05 12:28 ranjith_qualiantech_com Status new => scheduled
2019-02-05 14:53 hgbot Checkin
2019-02-05 14:53 hgbot Note Added: 0109588
2019-02-05 14:53 hgbot Status scheduled => resolved
2019-02-05 14:53 hgbot Resolution open => fixed
2019-02-05 14:53 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/e1725e1909d206cd4167ee173d0ea3f602a61837 [^]
2019-02-06 17:07 jorge-garcia Review Assigned To => jorge-garcia
2019-02-06 17:14 jorge-garcia Review Assigned To jorge-garcia =>
2019-02-14 16:57 marvintm Review Assigned To => marvintm
2019-02-14 16:57 marvintm Status resolved => closed
2019-02-14 16:57 marvintm Fixed in Version => RR19Q2


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker