Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0040029
TypeCategorySeverityReproducibilityDate SubmittedLast Update
design defect[Openbravo ERP] A. Platformmajoralways2019-01-24 12:212019-05-31 12:45
Reporterjoniturralde93View Statuspublic 
Assigned Toplatform 
PriorityurgentResolutionopenFixed in Version
StatusacknowledgedFix in branchFixed in SCM revision
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0040029: Openbravo backoffice reports don't work for iPad/iPhone

DescriptionPrinter icon in order to download a report (example: Sales Order window) don't work.
It sometimes shows an error: 'Something went wrong while displaying this web page.'
Other times just nothing happens.

In other ways of downloading a file, there is no problem because the file is opened automatically (example: gmail or zendesk attached pdfs are opened).
Steps To Reproduce1. Log into live builds backoffice with an iPad or iPhone: https://livebuilds.openbravo.com/retail_pi_pgsql/ [^]
2. Go to sales order windows.
3. Click 'Print record' for an order.
4. Either nothing happens or an error page is shown.
TagsNo tags attached.
Attached Filespng file icon webInspectorIphone.png [^] (146,798 bytes) 2019-01-31 09:39

- Relationships Relation Graph ] Dependency Graph ]
related to design defect 0040038 acknowledgedplatform iOS issues in backoffice operations 

-  Notes
(0109255)
alostale (developer)
2019-01-25 13:20

Moved to design defect, iPad/iPhone are not supported for backoffice operations.
(0109346)
caristu (developer)
2019-01-31 09:38
edited on: 2019-01-31 09:39

Tested with both iPad/iPhone. It seems that the content-disposition of the HTTP response containing the report is ignored. It is correctly received (See attached image) but seems to be ignored.

After some research, it seems to that there is some kind of security mechanism that blocks the file download. See[1].

[1] https://apple.stackexchange.com/a/25690 [^]


- Issue History
Date Modified Username Field Change
2019-01-24 12:21 joniturralde93 New Issue
2019-01-24 12:21 joniturralde93 Assigned To => platform
2019-01-24 12:21 joniturralde93 Modules => Core
2019-01-24 12:21 joniturralde93 Triggers an Emergency Pack => No
2019-01-25 13:20 alostale Type defect => design defect
2019-01-25 13:20 alostale Note Added: 0109255
2019-01-25 13:21 alostale Relationship added related to 0040038
2019-01-31 09:38 caristu Note Added: 0109346
2019-01-31 09:38 caristu Note Edited: 0109346 View Revisions
2019-01-31 09:39 caristu Note Edited: 0109346 View Revisions
2019-01-31 09:39 caristu File Added: webInspectorIphone.png
2019-01-31 09:40 caristu Status new => acknowledged
2019-01-31 09:40 caristu Target Version pi =>
2019-05-31 12:45 ivancaceres Issue Monitored: ivancaceres


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker