Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0040019
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Cash upmajoralways2019-01-23 18:242019-01-30 14:34
ReportermalsasuaView Statuspublic 
Assigned Toranjith_qualiantech_com 
PriorityimmediateResolutionfixedFixed in VersionRR19Q2
StatusclosedFix in branchFixed in SCM revisionc5744e78fbac
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomigueldejuana
Regression levelProduction - Confirmed Stable
Regression date
Regression introduced in release
Regression introduced by commithttps://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/d0797b3798881a9b775cb323b3c79e49159eac58 [^]
Triggers an Emergency PackNo
Summary

0040019: Counted amount is wrong in the Cashup Report

DescriptionThe counted amount is wrong when the cashup report is printed in the backend.
Steps To ReproducePOS:
. new receipt:
 . product Avalanche Transceiver
   -> total amount 150.50 -> paid with Cash
. new receipt:
 . product Balaclava Cup
   -> total amount 169 -> paid with Card
. new receipt:
 . product Headlamp ultralight
   -> total amount 18.90 -> paid with USA Cash
. do cashup:
 . counted amounts:
   . cash-> 150
   . card -> 169
   . USA Cash -> 18.90
 ¬∑ amount to keep:
   ¬∑cash-> 200

BO:
. go to terminal-> cashup -> print cashup:
  counted amount:
   . cash -> 0 (WRONG)
   . card -> 0 (WRONG)
   . USA Cash -> 18.9 (RIGHT)
. go to terminal -> cashup -> Payment Method Status Cashup tab:
  counted amount:
   . cash -> 0 (WRONG)
   . card -> 0 (WRONG)
   . USA Cash -> 18.9 (RIGHT)

(see screenshots)

amountToKeep is 0 and it should be 200 in the backoffice
TagsNo tags attached.
Attached Filespng file icon POS_cashup.png [^] (59,778 bytes) 2019-01-23 18:24


png file icon bo_cashupReport.png [^] (20,422 bytes) 2019-01-23 18:25


png file icon bo_cashup.png [^] (135,983 bytes) 2019-01-23 18:25

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 0040059RR19Q1 closedranjith_qualiantech_com Counted amount is wrong in the Cashup Report 
depends on backport 0040060RR18Q4.2 closedranjith_qualiantech_com Counted amount is wrong in the Cashup Report 
depends on backport 0040061RR18Q3.5 closedranjith_qualiantech_com Counted amount is wrong in the Cashup Report 
caused by defect 0038193 closedSandrahuguet In updateOrCreateCashupInfo is updated all paymentmethods 

-  Notes
(0109290)
hgbot (developer)
2019-01-29 07:47

Repository: tools/automation/pi-mobile
Changeset: 356d3784ba8d22822166bef33afb6ca166a096e5
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Tue Jan 29 12:17:39 2019 +0530
URL: http://code.openbravo.com/tools/automation/pi-mobile/rev/356d3784ba8d22822166bef33afb6ca166a096e5 [^]

Verifies issue 40019 : Added Automated Test "I40019_VerifyCountedAmountAfterCashup"

---
A src-test/org/openbravo/test/mobile/retail/pack/selenium/tests/cashup/I40019_VerifyCountedAmountAfterCashup.java
---
(0109291)
hgbot (developer)
2019-01-29 07:48

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: c5744e78fbacd1937c39fce01e867a30cf4cd7f4
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Tue Jan 29 12:15:56 2019 +0530
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/c5744e78fbacd1937c39fce01e867a30cf4cd7f4 [^]

Fixed issue 40019 : PaymentMethodCashup should be updated when Cashup is Done

* PaymentMethodCashup should be created/updated for the following cases
  1) when cashup is closed
  2) when ticket is closed with respective payment

---
M src/org/openbravo/retail/posterminal/UpdateCashup.java
---
(0109332)
migueldejuana (developer)
2019-01-30 14:34

Tested and reviewed

- Issue History
Date Modified Username Field Change
2019-01-23 18:24 malsasua New Issue
2019-01-23 18:24 malsasua Assigned To => Retail
2019-01-23 18:24 malsasua File Added: POS_cashup.png
2019-01-23 18:24 malsasua Regression level => Production - Confirmed Stable
2019-01-23 18:24 malsasua Triggers an Emergency Pack => No
2019-01-23 18:25 malsasua File Added: bo_cashupReport.png
2019-01-23 18:25 malsasua File Added: bo_cashup.png
2019-01-24 14:33 ranjith_qualiantech_com Assigned To Retail => ranjith_qualiantech_com
2019-01-24 14:33 ranjith_qualiantech_com Status new => scheduled
2019-01-24 17:29 anderaranguren Steps to Reproduce Updated View Revisions
2019-01-24 17:37 Practics Issue Monitored: Practics
2019-01-29 07:47 hgbot Checkin
2019-01-29 07:47 hgbot Note Added: 0109290
2019-01-29 07:48 hgbot Checkin
2019-01-29 07:48 hgbot Note Added: 0109291
2019-01-29 07:48 hgbot Status scheduled => resolved
2019-01-29 07:48 hgbot Resolution open => fixed
2019-01-29 07:48 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/c5744e78fbacd1937c39fce01e867a30cf4cd7f4 [^]
2019-01-30 10:49 guillermogil Relationship added caused by 0038193
2019-01-30 10:49 guillermogil Regression introduced by commit => https://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/d0797b3798881a9b775cb323b3c79e49159eac58 [^]
2019-01-30 10:52 marvintm Status resolved => new
2019-01-30 10:52 marvintm Resolution fixed => open
2019-01-30 10:52 marvintm Status new => scheduled
2019-01-30 10:52 marvintm Status scheduled => resolved
2019-01-30 10:52 marvintm Fixed in Version => RR19Q2
2019-01-30 10:52 marvintm Resolution open => fixed
2019-01-30 14:34 migueldejuana Review Assigned To => migueldejuana
2019-01-30 14:34 migueldejuana Note Added: 0109332
2019-01-30 14:34 migueldejuana Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker