Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0040016
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] A. Platformminorhave not tried2019-01-23 12:362019-01-25 10:54
ReportercaristuView Statuspublic 
Assigned Tocaristu 
PriorityhighResolutionfixedFixed in Version3.0PR18Q4.2
StatusclosedFix in branchFixed in SCM revision4ab5cd94e65e
ProjectionnoneETAnoneTarget Version3.0PR18Q4.2
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0040016: Concurrency problems in MyOpenbravoActionHandler

DescriptionThe MyOpenbravoActionHandler execution can fail if it is accessed by several threads at the same time.

This is caused by [1]. As part of the changes done to decrease the time spent to load the widgets after login, the definition of the WidgetProviders is cached[2]. This kind of classes has a private field named widgetClass (a DAL object) which can cause exceptions when accessing to some of its properties in a concurrent way (See error.txt attached).

[1] https://code.openbravo.com/erp/devel/pi/rev/2a1a09ee6e6852cb977efa1a987e27d2811e9127 [^]
[2] https://code.openbravo.com/erp/devel/pi/rev/2a1a09ee6e6852cb977efa1a987e27d2811e9127#l1.178 [^]
Steps To Reproduce1) Start Tomcat
2) Run the attached MyOpenbravoActionHandlerConcurrencyTest.test that performs several requests to MyOpenbravoActionHandler in parallel
3) The test fails because not all the requests are executed successfully
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0040009 closedcaristu Concurrency problems in MyOpenbravoActionHandler 

-  Notes
(0109151)
hgbot (developer)
2019-01-24 11:12
edited on: 2019-01-24 11:13

Repository: erp/backports/3.0PR18Q4.2
Changeset: 699f8e73b89f7ef58661c5252f327f80ea091bb2
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Thu Jan 24 10:54:34 2019 +0100
URL: http://code.openbravo.com/erp/backports/3.0PR18Q4.2/rev/699f8e73b89f7ef58661c5252f327f80ea091bb2 [^] [^]

related to issue 40016: apply new Java formatting

---
M modules/org.openbravo.client.myob/src/org/openbravo/client/myob/WidgetProvider.java

(0109152)
caristu (developer)
2019-01-24 11:13

Repository: erp/backports/3.0PR18Q4.2
Changeset: 4ab5cd94e65e62072a0ce56008e6b97dab26adb4
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Thu Jan 24 11:10:47 2019 +0100
URL: http://code.openbravo.com/erp/backports/3.0PR18Q4.2/rev/4ab5cd94e65e62072a0ce56008e6b97dab26adb4 [^] [^]

fixes issue 40016: Concurrency problems in MyOpenbravoActionHandler

As part of the changes done to decrease the time spent to load the widgets after login, the WidgetProviders are cached[1]. This kind of classes had a private field named widgetClass (a DAL object) which could cause errors when accessing to some of its properties in a concurrent way.

To fix this issue we are now keeping in cache the properties of the WidgetClass instead of keeping the reference to the DAL object.

[1] https://code.openbravo.com/erp/devel/pi/rev/2a1a09ee6e6852cb977efa1a987e27d2811e9127#l1.178 [^] [^]

---
M modules/org.openbravo.client.myob/src/org/openbravo/client/myob/WidgetProvider.java
(0109248)
alostale (developer)
2019-01-25 10:54

reviewed + tested

- Issue History
Date Modified Username Field Change
2019-01-23 17:33 caristu Type defect => backport
2019-01-23 17:33 caristu Target Version => 3.0PR18Q4.2
2019-01-24 11:12 hgbot Checkin
2019-01-24 11:12 hgbot Note Added: 0109151
2019-01-24 11:12 hgbot Status scheduled => resolved
2019-01-24 11:12 hgbot Resolution open => fixed
2019-01-24 11:12 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR18Q4.2/rev/4ab5cd94e65e62072a0ce56008e6b97dab26adb4 [^]
2019-01-24 11:13 caristu Note Added: 0109152
2019-01-24 11:13 caristu Note Edited: 0109151 View Revisions
2019-01-25 08:15 caristu Review Assigned To => alostale
2019-01-25 10:54 alostale Note Added: 0109248
2019-01-25 10:54 alostale Status resolved => closed
2019-01-25 10:54 alostale Fixed in Version => 3.0PR18Q4.2


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker