Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0040015
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] A. Platformminorhave not tried2019-01-23 12:362019-01-25 10:53
ReportercaristuView Statuspublic 
Assigned Tocaristu 
PriorityhighResolutionfixedFixed in Version3.0PR19Q1
StatusclosedFix in branchFixed in SCM revision9cf8c26a4b17
ProjectionnoneETAnoneTarget Version3.0PR19Q1
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0040015: Concurrency problems in MyOpenbravoActionHandler

DescriptionThe MyOpenbravoActionHandler execution can fail if it is accessed by several threads at the same time.

This is caused by [1]. As part of the changes done to decrease the time spent to load the widgets after login, the definition of the WidgetProviders is cached[2]. This kind of classes has a private field named widgetClass (a DAL object) which can cause exceptions when accessing to some of its properties in a concurrent way (See error.txt attached).

[1] https://code.openbravo.com/erp/devel/pi/rev/2a1a09ee6e6852cb977efa1a987e27d2811e9127 [^]
[2] https://code.openbravo.com/erp/devel/pi/rev/2a1a09ee6e6852cb977efa1a987e27d2811e9127#l1.178 [^]
Steps To Reproduce1) Start Tomcat
2) Run the attached MyOpenbravoActionHandlerConcurrencyTest.test that performs several requests to MyOpenbravoActionHandler in parallel
3) The test fails because not all the requests are executed successfully
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0040009 closedcaristu Concurrency problems in MyOpenbravoActionHandler 

-  Notes
(0109148)
hgbot (developer)
2019-01-24 11:03

Repository: erp/backports/3.0PR19Q1
Changeset: 4928dadd5d57906a0fe03bc7221caf556f391cab
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Thu Jan 24 10:54:34 2019 +0100
URL: http://code.openbravo.com/erp/backports/3.0PR19Q1/rev/4928dadd5d57906a0fe03bc7221caf556f391cab [^]

related to issue 40015: apply new Java formatting

---
M modules/org.openbravo.client.myob/src/org/openbravo/client/myob/WidgetProvider.java
---
(0109149)
hgbot (developer)
2019-01-24 11:03

Repository: erp/backports/3.0PR19Q1
Changeset: 9cf8c26a4b1750ec5165a70f07671b4001a2d689
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Thu Jan 24 10:05:04 2019 +0100
URL: http://code.openbravo.com/erp/backports/3.0PR19Q1/rev/9cf8c26a4b1750ec5165a70f07671b4001a2d689 [^]

fixes issue 40015: Concurrency problems in MyOpenbravoActionHandler

  As part of the changes done to decrease the time spent to load the widgets after login, the WidgetProviders are cached[1]. This kind of classes had a private field named widgetClass (a DAL object) which could cause errors when accessing to some of its properties in a concurrent way.

  To fix this issue we are now keeping in cache the properties of the WidgetClass instead of keeping the reference to the DAL object.

[1] https://code.openbravo.com/erp/devel/pi/rev/2a1a09ee6e6852cb977efa1a987e27d2811e9127#l1.178 [^]

---
M modules/org.openbravo.client.myob/src/org/openbravo/client/myob/WidgetProvider.java
---
(0109247)
alostale (developer)
2019-01-25 10:53

reviewed + tested

- Issue History
Date Modified Username Field Change
2019-01-23 17:33 caristu Type defect => backport
2019-01-23 17:33 caristu Target Version => 3.0PR19Q1
2019-01-24 11:03 hgbot Checkin
2019-01-24 11:03 hgbot Note Added: 0109148
2019-01-24 11:03 hgbot Checkin
2019-01-24 11:03 hgbot Note Added: 0109149
2019-01-24 11:03 hgbot Status scheduled => resolved
2019-01-24 11:03 hgbot Resolution open => fixed
2019-01-24 11:03 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR19Q1/rev/9cf8c26a4b1750ec5165a70f07671b4001a2d689 [^]
2019-01-24 11:12 hgbot Checkin
2019-01-24 11:12 hgbot Note Added: 0109150
2019-01-24 11:12 caristu Note Deleted: 0109150
2019-01-25 08:15 caristu Review Assigned To => alostale
2019-01-25 10:53 alostale Note Added: 0109247
2019-01-25 10:53 alostale Status resolved => closed
2019-01-25 10:53 alostale Fixed in Version => 3.0PR19Q1


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker