Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0039988
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 04. Warehouse managementmajorhave not tried2019-01-21 16:492019-03-28 14:55
ReporterfranciscoView Statuspublic 
Assigned ToAtulOpenbravo 
PriorityhighResolutionfixedFixed in Version3.0PR19Q2
StatusclosedFix in branchFixed in SCM revision6d346acd0ba3
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToSandrahuguet
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0039988: Last inventory counting no updating

DescriptionWhen is created an inventory, and the product quantity remain the same (is not changed) the date at the bin content tab is not updating.
This can be confusing because you cannot see if this specific product was counted or not during the inventory.
Steps To Reproduce1. Go to physical inventory window and create a new inventory
2. Go to lines and create a new record
3. Without changing any "quantity count" click on Process inventory Count button
4. Go to warehouse and storage bins window and select the register from where the inventory was process
5. In Bin content tab you can see in "Last inventory count date" is not updated. Otherwise if you had changed "quantity count" it is mentioned in step 3, the "Last inventory count date" is updated
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0109243)
AtulOpenbravo (developer)
2019-01-25 07:29

- Go to physical inventory window and create a new inventory
- Go to lines and create a new record
- Without changing any "quantity count" click on Process inventory Count button
- Go to warehouse and storage bins window and select the register from where the inventory was process
- In Bin content tab you can see in "Last inventory count date" is updated.
(0109347)
hgbot (developer)
2019-01-31 10:05

Repository: erp/devel/pi
Changeset: 6d346acd0ba3fb403660a9efb0d84e500df0c655
Author: Atul Gaware <atul.gaware <at> openbravo.com>
Date: Tue Jan 29 23:14:28 2019 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/6d346acd0ba3fb403660a9efb0d84e500df0c655 [^]

Fixes Issue 0039988: Last inventory counting no updating

M_Transaction records are not created for inventory count line
having qtyCount equals to book quantity or order quantity equals
order quantity book. Hence update inventory is not called which
actual updates the date inventory in M_Storage_Detail.

Update Date Inventory method is introduced and now used to update
date in such cases which calls update inventory.

---
M src/org/openbravo/materialmgmt/InventoryCountProcess.java
---
(0109350)
Sandrahuguet (developer)
2019-01-31 10:12

Code review + testing OK
(0109351)
Sandrahuguet (developer)
2019-01-31 11:11

We are not going to provide script to fix data because there is a workaround.

With the fix applied, create a new Physical Inventory / Process Inventory Count and the Last Inventory Count Date is now updated.
(0110762)
hudsonbot (developer)
2019-03-28 14:55

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b2fbc1588df4 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2019-01-21 16:49 francisco New Issue
2019-01-21 16:49 francisco Assigned To => Triage Finance
2019-01-21 16:49 francisco Modules => Core
2019-01-21 16:49 francisco Triggers an Emergency Pack => No
2019-01-21 16:58 Practics Issue Monitored: Practics
2019-01-22 08:48 dmiguelez Assigned To Triage Finance => AtulOpenbravo
2019-01-25 07:29 AtulOpenbravo Status new => scheduled
2019-01-25 07:29 AtulOpenbravo Note Added: 0109243
2019-01-31 10:05 hgbot Checkin
2019-01-31 10:05 hgbot Note Added: 0109347
2019-01-31 10:05 hgbot Status scheduled => resolved
2019-01-31 10:05 hgbot Resolution open => fixed
2019-01-31 10:05 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/6d346acd0ba3fb403660a9efb0d84e500df0c655 [^]
2019-01-31 10:12 Sandrahuguet Review Assigned To => Sandrahuguet
2019-01-31 10:12 Sandrahuguet Note Added: 0109350
2019-01-31 10:12 Sandrahuguet Status resolved => closed
2019-01-31 10:12 Sandrahuguet Fixed in Version => 3.0PR19Q2
2019-01-31 11:11 Sandrahuguet Note Added: 0109351
2019-03-28 14:55 hudsonbot Checkin
2019-03-28 14:55 hudsonbot Note Added: 0110762


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker