Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0039923
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Retail Modules] Gift cards and gift vouchersminorhave not tried2017-05-09 11:332019-03-06 23:27
ReporterplujanView Statuspublic 
Assigned Torqueralta 
PrioritynormalResolutionfixedFixed in VersionRR19Q1
StatusclosedFix in branchFixed in SCM revision13922bc4832b
ProjectionnoneETAnoneTarget VersionRR19Q1
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionmainSCM revision 
Review Assigned Toguilleaer
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0039923: [RR17Q2] On session restart is possible to create a Gift Card with NULL identifier

DescriptionWhen purchasing a new Gift Card, there are some mandatory values to fill in the pop up that is shown.
However, if the session restarts before filling the fields, the pop up can be ignored and the Card can be created with the identifier as null.
Steps To Reproduce1. In an environment with Gift Cards configured, purchase a Card by adding it to a ticket.
2. A pop up window is shown, with several field to fill in. Leave all the fields blank. Note that it is not possible to continue with the ticket payment if ID is left blank (i.e. closing the window will remove the card from the ticket)
3. Restart the session (i.e. an automatic refresh is triggered or F5 key is pressed)
4. When the main screen is back, note that the Card is still in the ticket (as expected) but now you can pay the ticket. As a result, the ID is null and the Card cannot be used later (since it cannot be retrieved)
Proposed SolutionAn extra validation on the payment in case any mandatory field is missing.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0035957 closedrqueralta [RR17Q2] On session restart is possible to create a Gift Card with NULL identifier 

-  Notes
(0108913)
hgbot (developer)
2019-01-10 18:57

Repository: retail/backports/3.0RR19Q1/org.openbravo.retail.posterminal
Changeset: 06cd122bddfa7442c17522c219134e342d000c3b
Author: Rafael Queralta <rafaelcuba81 <at> gmail.com>
Date: Thu Dec 27 13:48:05 2018 -0500
URL: http://code.openbravo.com/retail/backports/3.0RR19Q1/org.openbravo.retail.posterminal/rev/06cd122bddfa7442c17522c219134e342d000c3b [^]

Fixed issue 39923: [RR17Q2] On session restart is possible to create a Gift Card
with NULL identifier

- Removed lines without mandatory filds filled

---
M web/org.openbravo.retail.posterminal/js/pointofsale/model/pointofsale-model.js
---
(0108914)
hgbot (developer)
2019-01-10 18:57

Repository: retail/backports/3.0RR19Q1/org.openbravo.retail.posterminal
Changeset: 13922bc4832b898bdd310075dcd788eae466638b
Author: Rafael Queralta <rafaelcuba81 <at> gmail.com>
Date: Fri Jan 04 07:53:35 2019 -0500
URL: http://code.openbravo.com/retail/backports/3.0RR19Q1/org.openbravo.retail.posterminal/rev/13922bc4832b898bdd310075dcd788eae466638b [^]

Fixed issue 39923: [RR17Q2] On session restart is possible to create a Gift Card
with NULL identifier

- Removed lines without mandatory filds filled

---
M web/org.openbravo.retail.posterminal/js/pointofsale/model/pointofsale-model.js
---
(0110272)
guilleaer (developer)
2019-03-06 23:27

To take advantage of this fix in 19Q1 apply changes from issue [1] which affects to gift card module

[1] https://issues.openbravo.com/view.php?id=35957 [^]

- Issue History
Date Modified Username Field Change
2019-01-10 18:52 gorka_gil Type defect => backport
2019-01-10 18:52 gorka_gil Target Version => RR19Q1
2019-01-10 18:57 hgbot Checkin
2019-01-10 18:57 hgbot Note Added: 0108913
2019-01-10 18:57 hgbot Status scheduled => resolved
2019-01-10 18:57 hgbot Resolution open => fixed
2019-01-10 18:57 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/48d02ee91c5bd3994c5a55af0ea7e9ff99efdc14 [^] => http://code.openbravo.com/retail/backports/3.0RR19Q1/org.openbravo.retail.posterminal/rev/06cd122bddfa7442c17522c219134e342d000c3b [^]
2019-01-10 18:57 hgbot Checkin
2019-01-10 18:57 hgbot Note Added: 0108914
2019-01-10 18:57 hgbot Fixed in SCM revision http://code.openbravo.com/retail/backports/3.0RR19Q1/org.openbravo.retail.posterminal/rev/06cd122bddfa7442c17522c219134e342d000c3b [^] => http://code.openbravo.com/retail/backports/3.0RR19Q1/org.openbravo.retail.posterminal/rev/13922bc4832b898bdd310075dcd788eae466638b [^]
2019-03-06 17:50 guilleaer Status resolved => new
2019-03-06 17:50 guilleaer Resolution fixed => open
2019-03-06 17:50 guilleaer Status new => scheduled
2019-03-06 23:24 guilleaer Status scheduled => resolved
2019-03-06 23:24 guilleaer Fixed in Version => RR19Q1
2019-03-06 23:24 guilleaer Resolution open => fixed
2019-03-06 23:27 guilleaer Note Added: 0110272
2019-03-06 23:27 guilleaer Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker