Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0039896
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 07. Sales managementminoralways2019-01-09 14:472019-03-28 14:55
ReporterlmassonView Statuspublic 
Assigned Tocaristu 
PrioritynormalResolutionfixedFixed in Version3.0PR19Q2
StatusclosedFix in branchFixed in SCM revision41b709331d14
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product Version3.0PR18Q4SCM revision 
Review Assigned Toalostale
Web browserGoogle Chrome
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2018-04-30
Regression introduced in release3.0PR18Q3
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/f2979bad688953ced9571ab74cf312c989a0f81b [^]
Triggers an Emergency PackNo
Summary

0039896: Purchase Order : Not possible to search product with Characteristic

DescriptionDuring the process of creation of a Purchase Order, when I try to make a search with the characteristic description using the button "Create line" any is propose.

See the video attached to this Mantis.
https://drive.google.com/file/d/1uNw9ix67xu3JWEG1-92GPI2atTEIUgod/view [^]
Steps To Reproduce* Open 'Product Characteristic' window and create a new record and also a characteristic value (lines tab)

* Then open 'Product' window and select a product Ex:"Cerveza Ale 0,5L". Switch to [Characteristics] tab and assign it a new characteristic.

* Run process "Update Characteristics" for that product and press OK.

* Go to Purchase Order windows and create a purchase order with the product where the characteristic was created.

* Click on creates lines button and try to filter by characteristic (Nothing appears)

*If you filter by product, the characteristic filter star working properly


TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00399533.0PR19Q1 closedcaristu Purchase Order : Not possible to search product with Characteristic 
depends on backport 00399543.0PR18Q4.2 closedcaristu Purchase Order : Not possible to search product with Characteristic 
depends on backport 00399553.0PR18Q3.5 closedcaristu Purchase Order : Not possible to search product with Characteristic 
caused by defect 0038422 closedjarmendariz Characteristic description selector included in a process definition not showing values when a filter is set 
has duplicate defect 0039944 closedTriage Finance Purchase Order : Not possible to filter product with Characteristic 

-  Notes
(0108929)
AtulOpenbravo (developer)
2019-01-11 17:17

- Login as F&B International Group Admin.
- Define a new Product Characteristics, set Variant flag = Yes.
- Define few values under it.
- Define a new Product with Generic flag = Yes.
- Add above created Product Characteristics for new product created.
- Using Create Variants, create products using generic product.
- Add purchase price for all the variants products.
- Create a Purchase Order header for any business partner.
- Using Create Line button open P&E window.
- Try to apply filters in Product Characteristics field.
- Realize that data is shown and after applying some filters data in P&E window is filtered properly.
(0108965)
hgbot (developer)
2019-01-15 16:28

Repository: erp/devel/pi
Changeset: 41b709331d1422f8db97e78557eb7b8dc2231d69
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Tue Jan 15 13:57:46 2019 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/41b709331d1422f8db97e78557eb7b8dc2231d69 [^]

fixes issue 39896: Not possible to filter by characteristic in Create Lines

  The changeset[1] was not taking into account the possibility of having a field with a name that already contains 'product'. This can happen when having a property field like: product.characteristicDescription.

  In that case an extra 'product' was being added to the propery path which resulted in a wrong HQL where clause definition for the characteristic filter.

  Now we do not append 'product' to the property path in case it already starts with it.

  [1] https://code.openbravo.com/erp/devel/pi/rev/f2979bad688953ced9571ab74cf312c989a0f81b [^]

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-characteristics.js
---
(0108969)
hgbot (developer)
2019-01-15 17:25

Repository: erp/devel/pi
Changeset: 0520ead34ebbf572353784125a40fa05f0ac5255
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Tue Jan 15 17:24:40 2019 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/0520ead34ebbf572353784125a40fa05f0ac5255 [^]

related to issue 39896: minor code cleanup

  Removed unused variables

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-characteristics.js
---
(0108971)
caristu (developer)
2019-01-16 10:17
edited on: 2019-01-16 10:43

TestLink:

https://testlink.openbravo.com/testlink/linkto.php?tprojectPrefix=Communit&item=testcase&id=Communit-11124 [^]

https://testlink.openbravo.com/testlink/linkto.php?tprojectPrefix=Communit&item=testcase&id=Communit-11125 [^]

(0109004)
alostale (developer)
2019-01-18 09:27

reviewed + tested
(0110728)
hudsonbot (developer)
2019-03-28 14:55

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b2fbc1588df4 [^]
Maturity status: Test
(0110729)
hudsonbot (developer)
2019-03-28 14:55

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b2fbc1588df4 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2019-01-09 14:47 lmasson New Issue
2019-01-09 14:47 lmasson Assigned To => Triage Finance
2019-01-09 14:47 lmasson Web browser => Google Chrome
2019-01-09 14:47 lmasson Modules => Core
2019-01-09 14:47 lmasson Triggers an Emergency Pack => No
2019-01-09 15:02 Sandrahuguet Assigned To Triage Finance => AtulOpenbravo
2019-01-10 15:29 Sandrahuguet Assigned To AtulOpenbravo => Triage Finance
2019-01-11 12:41 egoitz Web browser Google Chrome => Google Chrome
2019-01-11 13:06 Sandrahuguet Assigned To Triage Finance => AtulOpenbravo
2019-01-11 14:06 AtulOpenbravo Status new => scheduled
2019-01-11 17:17 AtulOpenbravo Note Added: 0108929
2019-01-15 12:33 dmiguelez Web browser Google Chrome => Google Chrome
2019-01-15 12:33 dmiguelez Regression level => Production - Confirmed Stable
2019-01-15 12:33 dmiguelez Regression date => 2018-04-30
2019-01-15 12:33 dmiguelez Regression introduced in release => 3.0PR18Q3
2019-01-15 12:33 dmiguelez Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/f2979bad688953ced9571ab74cf312c989a0f81b [^]
2019-01-15 12:33 dmiguelez Assigned To AtulOpenbravo => platform
2019-01-15 12:42 ngarcia Relationship added has duplicate 0039944
2019-01-15 13:04 Sandrahuguet Web browser Google Chrome => Google Chrome
2019-01-15 13:04 Sandrahuguet Description Updated View Revisions
2019-01-15 13:04 Sandrahuguet Steps to Reproduce Updated View Revisions
2019-01-15 13:41 caristu Assigned To platform => caristu
2019-01-15 13:42 caristu Relationship added caused by 0038422
2019-01-15 13:42 caristu Status scheduled => acknowledged
2019-01-15 13:42 caristu Status acknowledged => scheduled
2019-01-15 16:28 hgbot Checkin
2019-01-15 16:28 hgbot Note Added: 0108965
2019-01-15 16:28 hgbot Status scheduled => resolved
2019-01-15 16:28 hgbot Resolution open => fixed
2019-01-15 16:28 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/41b709331d1422f8db97e78557eb7b8dc2231d69 [^]
2019-01-15 16:29 caristu Review Assigned To => alostale
2019-01-15 16:29 caristu Web browser Google Chrome => Google Chrome
2019-01-15 16:31 caristu Web browser Google Chrome => Google Chrome
2019-01-15 16:31 caristu Target Version 3.0PR18Q4 =>
2019-01-15 16:35 caristu Web browser Google Chrome => Google Chrome
2019-01-15 16:35 caristu Severity major => minor
2019-01-15 17:25 hgbot Checkin
2019-01-15 17:25 hgbot Note Added: 0108969
2019-01-16 10:17 caristu Note Added: 0108971
2019-01-16 10:43 caristu Note Edited: 0108971 View Revisions
2019-01-18 09:27 alostale Note Added: 0109004
2019-01-18 09:27 alostale Status resolved => closed
2019-01-18 09:27 alostale Fixed in Version => 3.0PR19Q2
2019-03-28 14:55 hudsonbot Checkin
2019-03-28 14:55 hudsonbot Note Added: 0110728
2019-03-28 14:55 hudsonbot Checkin
2019-03-28 14:55 hudsonbot Note Added: 0110729


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker