Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0039872
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajoralways2019-01-03 12:562019-01-17 11:34
Reportergorka_gilView Statuspublic 
Assigned Toranjith_qualiantech_com 
PriorityurgentResolutionfixedFixed in VersionRR19Q2
StatusclosedFix in branchFixed in SCM revision7b1a591c616a
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tojorge-garcia
Regression levelPackaging and release
Regression date2018-12-18
Regression introduced in releasepi
Regression introduced by commithttps://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/7c3c0cb548f6 [^]
Triggers an Emergency PackNo
Summary

0039872: Javascript error is displayed when trying to close pending documents when opening store from a terminal - Cannot read 'models'

DescriptionThis commit (from issue 39816):
 https://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/7c3c0cb548f6 [^]

Makes that this issue happens again:
  https://issues.openbravo.com/view.php?id=39488 [^]

With a new error message:
  TypeError: Cannot read property 'models' of undefined at removeReceiptFromDatabase.


Details of error:
In function removeReceiptFromDatabase,
OB.MobileApp.model.orderList is undefined, previously it checks if undefined before use it, now try to get the models from it without check.

Steps To ReproduceRun test: I39488_VerifyNoErrorWhenClosingPendingDocs

or follow steps to reproduce of issue 39488
TagsNo tags attached.
Attached Filespng file icon 39872.png [^] (173,121 bytes) 2019-01-03 13:04

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0039488 closedrqueralta Javascript error is displayed when trying to close pending documents when opening store from a terminal. 
depends on backport 0039884RR19Q1 closedranjith_qualiantech_com Javascript error is displayed when trying to close pending documents when opening store from a terminal - Cannot read 'models' 
caused by defect 0039816 closedranjith_qualiantech_com Sales order are missing using press Generate invoice for order 

-  Notes
(0108813)
hgbot (developer)
2019-01-03 13:18

Repository: tools/automation/pi-mobile
Changeset: 2ec436d244d8a2520fa921e5f4b8256f75005d04
Author: Gorka Gil <gorka.gil <at> openbravo.com>
Date: Thu Jan 03 13:18:02 2019 +0100
URL: http://code.openbravo.com/tools/automation/pi-mobile/rev/2ec436d244d8a2520fa921e5f4b8256f75005d04 [^]

Related to issue 39872: disable test till issue is fixed

---
M src-test/org/openbravo/test/mobile/retail/extmodules/selenium/tests/sessions/openstoretill/I39488_VerifyNoErrorWhenClosingPendingDocs.java
---
(0108843)
hgbot (developer)
2019-01-07 16:11

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 7b1a591c616a4292262cc235a8306bb47c2aa73a
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Mon Jan 07 20:40:47 2019 +0530
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/7b1a591c616a4292262cc235a8306bb47c2aa73a [^]

Fixed issue 39872 : Receipt should be removed from database even if orderList is empty

* With Sessions module, Cashup window will be loaded before rendering the pointofsale window whem sessions closed in backoffice.
In that case, if receipt is saved in database and not completed, It will shown in cashup window to delete it.
OB.MobileApp.model.orderList will not be initiated while deleting the receipt.
So if orderList is present, receipt to be removed will be deleted from database and orderlist
else receipt will be removed from database only

---
M web/org.openbravo.retail.posterminal/js/model/order.js
---
(0108854)
ranjith_qualiantech_com (developer)
2019-01-08 13:51

Reopening to create backports
(0108973)
jorge-garcia (developer)
2019-01-16 10:44

Code reviewed and tested
(0108993)
hgbot (developer)
2019-01-17 11:34

Repository: tools/automation/pi-mobile
Changeset: 2eba00ac6d5c528eb878c7cfeb9722588d358fdf
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Thu Jan 17 16:04:21 2019 +0530
URL: http://code.openbravo.com/tools/automation/pi-mobile/rev/2eba00ac6d5c528eb878c7cfeb9722588d358fdf [^]

Related to issue 39872 : Modified Test 'I39488_VerifyNoErrorWhenClosingPendingDocs'

* Removed TestAnnotations waitFixOf

---
M src-test/org/openbravo/test/mobile/retail/extmodules/selenium/tests/sessions/openstoretill/I39488_VerifyNoErrorWhenClosingPendingDocs.java
---

- Issue History
Date Modified Username Field Change
2019-01-03 12:56 gorka_gil New Issue
2019-01-03 12:56 gorka_gil Assigned To => Retail
2019-01-03 12:56 gorka_gil Triggers an Emergency Pack => No
2019-01-03 12:57 gorka_gil Relationship added caused by 0039816
2019-01-03 12:58 gorka_gil Relationship added related to 0039488
2019-01-03 13:01 gorka_gil Regression level => Automated tests
2019-01-03 13:01 gorka_gil Regression date => 2018-12-18
2019-01-03 13:01 gorka_gil Regression introduced in release => pi
2019-01-03 13:01 gorka_gil Regression introduced by commit => https://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/7c3c0cb548f6 [^]
2019-01-03 13:04 gorka_gil File Added: 39872.png
2019-01-03 13:18 hgbot Checkin
2019-01-03 13:18 hgbot Note Added: 0108813
2019-01-03 14:35 ranjith_qualiantech_com Assigned To Retail => ranjith_qualiantech_com
2019-01-03 14:35 ranjith_qualiantech_com Status new => scheduled
2019-01-07 16:11 hgbot Checkin
2019-01-07 16:11 hgbot Note Added: 0108843
2019-01-07 16:11 hgbot Status scheduled => resolved
2019-01-07 16:11 hgbot Resolution open => fixed
2019-01-07 16:11 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/7b1a591c616a4292262cc235a8306bb47c2aa73a [^]
2019-01-08 13:51 ranjith_qualiantech_com Note Added: 0108854
2019-01-08 13:51 ranjith_qualiantech_com Status resolved => new
2019-01-08 13:51 ranjith_qualiantech_com Resolution fixed => open
2019-01-08 13:51 ranjith_qualiantech_com Status new => scheduled
2019-01-08 14:40 ranjith_qualiantech_com Status scheduled => resolved
2019-01-08 14:40 ranjith_qualiantech_com Resolution open => fixed
2019-01-09 13:42 gorka_gil Regression level Automated tests => Packaging and release
2019-01-15 17:11 jorge-garcia Review Assigned To => jorge-garcia
2019-01-16 10:44 jorge-garcia Note Added: 0108973
2019-01-16 10:44 jorge-garcia Status resolved => closed
2019-01-16 10:44 jorge-garcia Fixed in Version => RR19Q2
2019-01-17 11:34 hgbot Checkin
2019-01-17 11:34 hgbot Note Added: 0108993


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker