Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0039865
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] B. User interfaceminorhave not tried2019-01-02 13:142019-05-31 09:35
ReporterplujanView Statuspublic 
Assigned ToAugustoMauch 
PriorityurgentResolutionfixedFixed in Version3.0PR19Q3
StatusclosedFix in branchFixed in SCM revision67bed13f91ca
ProjectionnoneETAnoneTarget Version3.0PR19Q3
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionmainSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0039865: [19Q1] [KS] It is possible to create an empty record from an empty record

DescriptionWhile editing a record, pressing Tab in the last field or hitting Down key on any field should create a new blank record. However, performing the same action on a new blank record has no sense.
Steps To Reproduce1. As System Admin, open "Unit of measure" window
2. Filter the grid to get just one record
3. Using the pencil icon, edit the record
4. While editing a field, press Down key or use Tab key to move out of the record. As expected, a new record is shown.
5. Press Down or Tab key again, note another blank record is created. See attached screenshot.
TagsNo tags attached.
Attached Filespng file icon Tabbing_GridMode.png [^] (37,302 bytes) 2019-01-02 13:14


? file icon issue39865.export [^] (3,099 bytes) 2019-05-22 19:25

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0041016 closedcaristu creating new record in grid, empty record generated if clicking line while retrieving defaults 
related to defect 0041020 acknowledgedplatform inconsistent state creating new record in form while editing in grid an incomplete record 

-  Notes
(0111785)
egoitz (developer)
2019-05-20 10:46

Hi,

The issue is also reproducible using the toolbar button to add a new line ingrid view. To reproduce:

-Create a header
-Go to child tab
-Click onthe new line in grid tool bar button
-Without apply changes, click again on the same tool bar button.


Could Both arrow key and button should be disabled if mandatory fields are not filled?
(0112155)
hgbot (developer)
2019-05-27 09:31

Repository: erp/devel/pi
Changeset: 67bed13f91cad8d1bb1b32625cc566945b87ebf4
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Wed May 22 19:21:34 2019 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/67bed13f91cad8d1bb1b32625cc566945b87ebf4 [^]

Fixes issue 39865: Do not create line if mandatory fields of current are empty

In the view grid, if in a new line there are mandatory fields not filled in, it should not be
possible to create a new line.

To prevent that, the updateState function of the new line toolbar button has been updated, and
the doCellEditEnd function of ob-view-grid also takes it into account.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/toolbar/ob-toolbar.js
---
(0112176)
hudsonbot (developer)
2019-05-27 13:54

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/bdad8ace6f89 [^]
Maturity status: Test
(0112289)
alostale (developer)
2019-05-31 09:35

reviewed + tested

- Issue History
Date Modified Username Field Change
2019-01-02 13:14 plujan New Issue
2019-01-02 13:14 plujan Assigned To => platform
2019-01-02 13:14 plujan File Added: Tabbing_GridMode.png
2019-01-02 13:14 plujan Modules => Core
2019-01-02 13:14 plujan Triggers an Emergency Pack => No
2019-04-17 09:49 alostale Priority normal => urgent
2019-04-17 09:49 alostale Target Version => 3.0PR19Q3
2019-05-20 10:46 egoitz Note Added: 0111785
2019-05-20 11:58 AugustoMauch Assigned To platform => AugustoMauch
2019-05-22 19:25 AugustoMauch File Added: issue39865.export
2019-05-27 09:31 hgbot Checkin
2019-05-27 09:31 hgbot Note Added: 0112155
2019-05-27 09:31 hgbot Status new => resolved
2019-05-27 09:31 hgbot Resolution open => fixed
2019-05-27 09:31 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/67bed13f91cad8d1bb1b32625cc566945b87ebf4 [^]
2019-05-27 13:54 hudsonbot Checkin
2019-05-27 13:54 hudsonbot Note Added: 0112176
2019-05-27 22:26 egoitz Issue Monitored: egoitz
2019-05-31 09:35 alostale Review Assigned To => alostale
2019-05-31 09:35 alostale Note Added: 0112289
2019-05-31 09:35 alostale Status resolved => closed
2019-05-31 09:35 alostale Fixed in Version => 3.0PR19Q3
2019-06-04 09:48 egoitz Relationship added related to 0041016
2019-06-04 11:15 alostale Relationship added related to 0041020


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker