Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0039841
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Discounts and Promotionsmajoralways2018-12-20 10:562019-01-14 16:01
ReporteranderarangurenView Statuspublic 
Assigned Torqueralta 
PriorityurgentResolutionfixedFixed in Version
StatusresolvedFix in branchFixed in SCM revision8f47d0a2de50
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned To
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0039841: Cannot pay the ticket if an approval is configured for a Discretionary Discount

DescriptionIf an approval has been configured for a Discretionary Discount and the approval has been configured for a parent organization and set visibility to a parent organization it is not possible to pay.
Steps To Reproduce- Go to Discounts and Promotion window and add two records for North East Zone and Vall Blanca Store. Both Discretionary Fixed Percentage with Approval Required checked and included organization itself (As it is shown in the pic).
- Go to Preference window and add a record for Web POS Discretionary Discount Approval for North East Zone and visible at North East Zone value='Y' and visible at Openbravo user.
- Add another record for the same property set value to 'N' for Vall Blanca use.

- Go to Web POS and log in with vallblanca.
- Add a Product and add the created discount to the ticket.
- Click on the total amount and the approval popup will be shown.
- Login with openbravo (as it is shown as supervisor) and the payment window will not be shown
TagsNo tags attached.
Attached Filespng file icon Discount.png [^] (126,641 bytes) 2018-12-20 10:56


png file icon preference.png [^] (91,964 bytes) 2018-12-20 10:58

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0108839)
hgbot (developer)
2019-01-07 04:16

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 87c8706e97f3e73c7078285958104305dd9246e9
Author: Rafael Queralta <rafaelcuba81 <at> gmail.com>
Date: Fri Dec 28 14:35:11 2018 -0500
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/87c8706e97f3e73c7078285958104305dd9246e9 [^]

Fixed issue 39841: Cannot pay the ticket if an approval is configured for a
Discretionary Discount

- Remove orgList parameter because the transformed sql is having problems with it

---
M src/org/openbravo/retail/posterminal/utility/CheckApproval.java
---
(0108917)
marvintm (developer)
2019-01-11 08:40

We should always use parameters, it's not correct to concatenate a string to the query.

Instead of the current fix, most likely the problem with the original fix was that a comma-separated string was passed as parameter instead of a set or list. The Utility.getInStrSet should be removed, and instead the set or list should be passed as parameter to the query.
(0108930)
hgbot (developer)
2019-01-12 13:09

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 8f47d0a2de50484c6479747653c22a99f44bd9d4
Author: Rafael Queralta <rafaelcuba81 <at> gmail.com>
Date: Fri Jan 11 07:29:24 2019 -0500
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/8f47d0a2de50484c6479747653c22a99f44bd9d4 [^]

Fixed issue 39841: Cannot pay the ticket if an approval is configured for a
Discretionary Discount

- Change orgList string parameter by list parameter

---
M src/org/openbravo/retail/posterminal/utility/CheckApproval.java
---
(0108945)
hgbot (developer)
2019-01-14 16:00

Repository: tools/automation/pi-mobile
Changeset: b8fa1964c3b4e270065220f6ef29328bf21bc96f
Author: Alejandro <alekosmp86 <at> gmail.com>
Date: Thu Jan 10 13:00:34 2019 -0500
URL: http://code.openbravo.com/tools/automation/pi-mobile/rev/b8fa1964c3b4e270065220f6ef29328bf21bc96f [^]

Related to issue 39841: added automated test

---
A src-test/org/openbravo/test/mobile/retail/pack/selenium/tests/discountsandpromotions/I39841_VerifyTicketPaymentIfApprovalForDiscretionaryDiscount.java
---
(0108950)
hgbot (developer)
2019-01-14 16:01

Repository: erp/pmods/org.openbravo.retail.sampledata
Changeset: 8fee007580bc16f10b173ebe2e53ed08c53583ef
Author: Alejandro <alekosmp86 <at> gmail.com>
Date: Thu Jan 10 11:13:19 2019 -0500
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.sampledata/rev/8fee007580bc16f10b173ebe2e53ed08c53583ef [^]

Related to issue 39841: added sampledata for testing purposes

---
M referencedata/sampledata/The_White_Valley_Group/M_OFFER.xml
A referencedata/sampledata/The_White_Valley_Group/M_OFFER_ORGANIZATION.xml
---

- Issue History
Date Modified Username Field Change
2018-12-20 10:56 anderaranguren New Issue
2018-12-20 10:56 anderaranguren Assigned To => Retail
2018-12-20 10:56 anderaranguren File Added: Discount.png
2018-12-20 10:56 anderaranguren Triggers an Emergency Pack => No
2018-12-20 10:58 anderaranguren File Added: preference.png
2018-12-20 15:03 rqueralta Assigned To Retail => rqueralta
2018-12-24 18:36 rqueralta Status new => scheduled
2019-01-07 04:16 hgbot Checkin
2019-01-07 04:16 hgbot Note Added: 0108839
2019-01-07 04:16 hgbot Status scheduled => resolved
2019-01-07 04:16 hgbot Resolution open => fixed
2019-01-07 04:16 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/87c8706e97f3e73c7078285958104305dd9246e9 [^]
2019-01-11 08:40 marvintm Note Added: 0108917
2019-01-11 08:40 marvintm Status resolved => new
2019-01-11 08:40 marvintm Resolution fixed => open
2019-01-12 13:09 hgbot Checkin
2019-01-12 13:09 hgbot Note Added: 0108930
2019-01-12 13:09 hgbot Status new => resolved
2019-01-12 13:09 hgbot Resolution open => fixed
2019-01-12 13:09 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/87c8706e97f3e73c7078285958104305dd9246e9 [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/8f47d0a2de50484c6479747653c22a99f44bd9d4 [^]
2019-01-14 16:00 hgbot Checkin
2019-01-14 16:00 hgbot Note Added: 0108945
2019-01-14 16:01 hgbot Checkin
2019-01-14 16:01 hgbot Note Added: 0108950


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker