Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0039784
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajoralways2018-12-11 18:462019-05-27 17:12
ReporterguillermogilView Statuspublic 
Assigned Toranjith_qualiantech_com 
PriorityhighResolutionduplicateFixed in Version
StatusclosedFix in branchFixed in SCM revision
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomarvintm
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0039784: OBPOS_HardwareURL may be generated by org *

DescriptionOBPOS_HardwareURL may be generated by org * instead of inherit it from the header, it allows you to select every record on the table
Steps To ReproduceCreate a record on OBPOS_HardwareMNG with organization PS
Go to a POS Terminal Type of VBS and on Hardware URL you can select the previously created record.
This is generating Sync Issues with Store Server also.
Proposed SolutionAdd the filter on the combo or an Event Handler to check it.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
duplicate of design defect 0022314 newTriage Finance Openbravo ERP In some windows the Organization can be changed and this change is not propagated to all its child records 
related to defect 0036725 closedAugustoMauch Openbravo ERP Should not be possible to create new data when user is not able to edit existent data 

-  Notes
(0108678)
marvintm (developer)
2018-12-19 16:48

We have been unable to reproduce the issue.
(0111924)
ioritzCia (developer)
2019-05-20 13:57

This issue continues happening in BUT, you can contact us to reproduce it
(0111930)
marvintm (developer)
2019-05-20 15:45

This problem is part of a general design defect in the platform. It can happen in this window, also in other POS windows (like Channel Touchpoint and their children, or Channel Touchpoint Type), and in many backend windows, even some basic ones like Business Partner.

- Issue History
Date Modified Username Field Change
2018-12-11 18:46 guillermogil New Issue
2018-12-11 18:46 guillermogil Assigned To => Retail
2018-12-11 18:46 guillermogil Triggers an Emergency Pack => No
2018-12-11 18:53 guillermogil Summary OBPOS_HardwareURL has no filter by Organization on OBPOS_HardwareMNG combo => OBPOS_HardwareURL may be generated by org *
2018-12-11 18:53 guillermogil Description Updated View Revisions
2018-12-11 18:56 guillermogil Description Updated View Revisions
2018-12-13 07:04 guillermogil Resolution time => 1546210800
2018-12-17 17:08 ranjith_qualiantech_com Assigned To Retail => ranjith_qualiantech_com
2018-12-18 08:06 ranjith_qualiantech_com Status new => scheduled
2018-12-19 16:48 marvintm Review Assigned To => marvintm
2018-12-19 16:48 marvintm Note Added: 0108678
2018-12-19 16:48 marvintm Status scheduled => closed
2018-12-19 16:48 marvintm Resolution open => unable to reproduce
2019-05-20 13:57 ioritzCia Note Added: 0111924
2019-05-20 13:57 ioritzCia Status closed => new
2019-05-20 13:57 ioritzCia Resolution unable to reproduce => open
2019-05-20 15:45 marvintm Relationship added duplicate of 0022314
2019-05-20 15:45 marvintm Note Added: 0111930
2019-05-20 15:45 marvintm Status new => closed
2019-05-20 15:45 marvintm Resolution open => duplicate
2019-05-24 14:32 mtaal Assigned To ranjith_qualiantech_com => mtaal
2019-05-27 11:03 mtaal Assigned To mtaal => ranjith_qualiantech_com
2019-05-27 17:12 mtaal Relationship added related to 0036725


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker