Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0039772
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 00. Application dictionarymajoralways2018-12-10 13:072018-12-28 17:07
Reporterjoniturralde93View Statuspublic 
Assigned ToAtulOpenbravo 
PriorityurgentResolutionfixedFixed in Version3.0PR19Q1
StatusclosedFix in branchFixed in SCM revision80dfa107feb9
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned ToSandrahuguet
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0039772: Price includes Tax flag can lead to errors (verified return)

DescriptionIf you complete a ticket with Price includes Tax unchecked in Price List and you check it afterwards, then you try to verified return that ticket, the prices change.

This is related to a Gold Customer which, by mistake, unchecked this flag and some tickets were completed meanwhile. Now they can't return these, since the price is not the same after checking the flag again.
Steps To Reproduce1. Log into https://livebuilds.openbravo.com/retail_pi_pgsql/ [^]
2. Price List 'The White Valley Group Sale Price List', uncheck 'Price includes Tax'.
3. Go to POS Terminal, add some products and complete the ticket.
4. Check the flag again.
5.Refresh POS Terminal and 'Verified Returns': Open the previous ticket. The price changes.

In order to fix that ticket you have to uncheck the flag again and return the ticket, which can be problematic in a production environment.
Proposed SolutionPermanently disable flag after an order is done with that price list.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0108713)
AtulOpenbravo (developer)
2018-12-21 03:51

- Login as F&B International Group Admin
- Navigate to Price List window
- Select "Tarifa de ventas"
- Try to set Price Includes Tax flag = Yes, Save Record.
- Error message is shown as:
"You cannot change the Price Includes Tax flag because the pricelist has been linked to transactional documents. See Linked Items for details."

- Create a new Price List in "F&B EspaƱa, S.A" organization
- Set Price Includes Tax flag = No, Save Record.
- Try to set Price Includes Tax flag = Yes, Save Record.
- Price list is saved successfully.
- Use the above new price list in any of the following document.
  - Sales / Purchase Invoice Header
  - Sales / Purchase Order Header
  - Requistion / Requisition Line
- Save Record.
- Try to set Price Includes Tax flag = No, Save Record.
- Error message is shown as:
"You cannot change the Price Includes Tax flag because the pricelist has been linked to transactional documents. See Linked Items for details."
- Delete above documents created if any.
- Try to set Price Includes Tax flag = No, Save Record.
- Price list is saved successfully.
(0108778)
hgbot (developer)
2018-12-28 12:51

Repository: erp/devel/pi
Changeset: 80dfa107feb9b958592953e3ac58ea132704c3e8
Author: Atul Gaware <atul.gaware <at> openbravo.com>
Date: Thu Dec 20 22:19:18 2018 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/80dfa107feb9b958592953e3ac58ea132704c3e8 [^]

Fixes Issue 39772:Price includes Tax flag can lead to errors
(verified return)

Price Includes Tax flag in pricelist cannot be updated once
price list is being used in order or invoice in any status,
of any type.

---
M src-db/database/sourcedata/AD_MESSAGE.xml
A src-db/database/model/triggers/M_PRICELIST_TRG.xml
---
(0108779)
hgbot (developer)
2018-12-28 12:51

Repository: erp/devel/pi
Changeset: 713212c6b67f3ef544af9dcd4a37234479c9e04a
Author: Atul Gaware <atul.gaware <at> openbravo.com>
Date: Thu Dec 20 23:39:02 2018 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/713212c6b67f3ef544af9dcd4a37234479c9e04a [^]

Related to Issue 39772:Price Includes Tax flag should not be
changed once pricelist is already used in transactional documents.

** Add Requisition and Requisition Line check for price list
before updating price includes tax flag.

---
M src-db/database/model/triggers/M_PRICELIST_TRG.xml
---
(0108780)
Sandrahuguet (developer)
2018-12-28 12:52

Code review + testing OK
(0108785)
hudsonbot (developer)
2018-12-28 17:07

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/017b7152d4b2 [^]
Maturity status: Test
(0108786)
hudsonbot (developer)
2018-12-28 17:07

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/017b7152d4b2 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2018-12-10 13:07 joniturralde93 New Issue
2018-12-10 13:07 joniturralde93 Assigned To => Retail
2018-12-10 13:07 joniturralde93 Triggers an Emergency Pack => No
2018-12-10 13:30 jfrances Issue Monitored: jfrances
2018-12-18 15:10 rqueralta Assigned To Retail => rqueralta
2018-12-18 17:15 joniturralde93 Project Retail Modules => Openbravo ERP
2018-12-18 17:17 joniturralde93 Modules => Core
2018-12-18 17:17 joniturralde93 Assigned To rqueralta => Triage Finance
2018-12-18 17:17 joniturralde93 Category Web POS => 00. Application dictionary
2018-12-18 17:18 joniturralde93 Proposed Solution updated
2018-12-19 13:00 Sandrahuguet Assigned To Triage Finance => AtulOpenbravo
2018-12-20 10:30 AtulOpenbravo Status new => scheduled
2018-12-21 03:51 AtulOpenbravo Note Added: 0108713
2018-12-28 12:51 hgbot Checkin
2018-12-28 12:51 hgbot Note Added: 0108778
2018-12-28 12:51 hgbot Status scheduled => resolved
2018-12-28 12:51 hgbot Resolution open => fixed
2018-12-28 12:51 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/80dfa107feb9b958592953e3ac58ea132704c3e8 [^]
2018-12-28 12:51 hgbot Checkin
2018-12-28 12:51 hgbot Note Added: 0108779
2018-12-28 12:52 Sandrahuguet Review Assigned To => Sandrahuguet
2018-12-28 12:52 Sandrahuguet Note Added: 0108780
2018-12-28 12:52 Sandrahuguet Status resolved => closed
2018-12-28 12:52 Sandrahuguet Fixed in Version => 3.0PR19Q1
2018-12-28 17:07 hudsonbot Checkin
2018-12-28 17:07 hudsonbot Note Added: 0108785
2018-12-28 17:07 hudsonbot Checkin
2018-12-28 17:07 hudsonbot Note Added: 0108786


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker