Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0039730
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] StoreServermajorhave not tried2018-12-02 09:232018-12-05 11:52
ReportermtaalView Statuspublic 
Assigned Tomtaal 
PrioritynormalResolutionopenFixed in Version
StatusnewFix in branchFixed in SCM revision
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned To
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0039730: BP Location synced before BP

DescriptionSee attached screenshot and zip with more files, what happens:
- a bp exists and has a store 1 as a primary store, it is not yet linked to another store through server-by-bp
- a new bp location is created for the bp (is done in store 2)
- the bp is linked to store 2 (it is unknown why this happens, as when retesting this did not happen)
- the bp location and bp are synced to store 2 in the wrong order
Steps To ReproduceNot able to reproduce yet
Proposed SolutionEnsure correct sync order, the sync error was resolved after ignoring this specific insert and then later touching the record again.
TagsNo tags attached.
Attached Filespng file icon Screenshot from 2018-12-02 08-51-32.png [^] (124,985 bytes) 2018-12-02 09:24


png file icon Screenshot from 2018-12-02 08-52-23.png [^] (75,676 bytes) 2018-12-02 09:24


png file icon Screenshot from 2018-12-02 08-53-24.png [^] (89,632 bytes) 2018-12-02 09:24

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0108266)
mtaal (manager)
2018-12-05 09:14

Is solved in related issue
(0108277)
mtaal (manager)
2018-12-05 11:52

Re-open as bp location is synced before bp to the store, so not related to location it seems

- Issue History
Date Modified Username Field Change
2018-12-02 09:23 mtaal New Issue
2018-12-02 09:23 mtaal Assigned To => mtaal
2018-12-02 09:23 mtaal Triggers an Emergency Pack => No
2018-12-02 09:24 mtaal File Added: Screenshot from 2018-12-02 08-51-32.png
2018-12-02 09:24 mtaal File Added: Screenshot from 2018-12-02 08-52-23.png
2018-12-02 09:24 mtaal File Added: Screenshot from 2018-12-02 08-53-24.png
2018-12-05 09:14 mtaal Note Added: 0108266
2018-12-05 09:14 mtaal Status new => closed
2018-12-05 09:14 mtaal Resolution open => no change required
2018-12-05 11:52 mtaal Note Added: 0108277
2018-12-05 11:52 mtaal Status closed => new
2018-12-05 11:52 mtaal Resolution no change required => open


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker