Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0039696
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajorhave not tried2018-11-27 09:172018-12-05 11:04
ReporterasiermartirenaView Statuspublic 
Assigned Toasiermartirena 
PrioritynormalResolutionfixedFixed in VersionRR19Q1
StatusclosedFix in branchFixed in SCM revisiond0819be1ff75
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomarvintm
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0039696: API Changes in Java for Omnichannel

DescriptionNew API changes in Java.
Changes in OrderLoader.java. Existing methods moved to new classes and privatized other ones. Updated also protected methods to be accessible only in the same package.

The existing hooks are maintained exactly in the same way, so developers should not notice any changes, unless they are extending the OrderLoader itself, something which is not allowed since many releases ago.

Removed the implementation of the CancelLayawayPaymentsHook.
Steps To Reproduce.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0108123)
hgbot (developer)
2018-11-27 12:37

Repository: retail/api-checks-retail
Changeset: d0819be1ff75083dd1da895d70154870fc70c96c
Author: Asier Martirena <asier.martirena <at> openbravo.com>
Date: Tue Nov 27 12:32:22 2018 +0100
URL: http://code.openbravo.com/retail/api-checks-retail/rev/d0819be1ff75083dd1da895d70154870fc70c96c [^]

Fixed issue 39696: API Changes in Java for Omnichannel

---
M java/reference/java.japi.gz
---
(0108269)
marvintm (developer)
2018-12-05 11:04

http://wiki.openbravo.com/wiki/Retail:API_changes#RR19Q1 [^]

- Issue History
Date Modified Username Field Change
2018-11-27 09:17 asiermartirena New Issue
2018-11-27 09:17 asiermartirena Assigned To => Retail
2018-11-27 09:17 asiermartirena Triggers an Emergency Pack => No
2018-11-27 10:02 marvintm Summary API Chanes in Java for Omnichannel => API Changes in Java for Omnichannel
2018-11-27 10:02 marvintm Description Updated View Revisions
2018-11-27 10:02 marvintm Steps to Reproduce Updated View Revisions
2018-11-27 12:37 hgbot Checkin
2018-11-27 12:37 hgbot Note Added: 0108123
2018-11-27 12:37 hgbot Status new => resolved
2018-11-27 12:37 hgbot Resolution open => fixed
2018-11-27 12:37 hgbot Fixed in SCM revision => http://code.openbravo.com/retail/api-checks-retail/rev/d0819be1ff75083dd1da895d70154870fc70c96c [^]
2018-11-28 13:47 marvintm Assigned To Retail => asiermartirena
2018-12-05 11:04 marvintm Review Assigned To => marvintm
2018-12-05 11:04 marvintm Note Added: 0108269
2018-12-05 11:04 marvintm Status resolved => closed
2018-12-05 11:04 marvintm Fixed in Version => RR19Q1


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker