Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0039674
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajoralways2018-11-22 11:182019-01-28 18:33
ReporterumartirenaView Statuspublic 
Assigned Torqueralta 
PriorityhighResolutionfixedFixed in VersionRR19Q1
StatusclosedFix in branchFixed in SCM revisionf7c03d326732
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomarvintm
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0039674: One use coupons, if are tried to be used offline, they are not added to the ticket, and no message is returned giving any warn

DescriptionOne use coupons, if are tried to be used offline, they are not added to the ticket, and no message is returned giving any warn.

It should be added or an error message should appear explaining to the user the cause.
Steps To ReproduceLogin into https://livebuilds.openbravo.com/retail_modules_pgsql_pi [^] [^] as "The White Valley Group" client.
Go to Discounts & Promotions window.
Search "Coupon 10" discount.
Add a new record in Coupon tab:
 * Coupon Code: COUPON20
 * Expire after 1 use: Selected.

Login into Web POS: https://livebuilds.openbravo.com/retail_modules_pgsql_pi/web/org.openbravo.retail.posterminal/?terminal=VBS1001 [^] [^]

Search Wilderness wash 100 ml product.
Change price to 150.
Go offline
Open Coupon Code menu entry.
Search by COUPON20 coupon.
The coupon is not added and no message is returned explaining what has happened.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0108138)
hgbot (developer)
2018-11-27 23:01

Repository: erp/pmods/org.openbravo.retail.discounts.coupons
Changeset: f7c03d32673282c26f72e1b98f9de140e1234574
Author: Rafael Queralta <rafaelcuba81 <at> gmail.com>
Date: Tue Nov 27 16:52:13 2018 -0500
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.discounts.coupons/rev/f7c03d32673282c26f72e1b98f9de140e1234574 [^]

Fixed issue 39674: One use coupons, if are tried to be used offline, they are
not added to the ticket, and no message is returned giving any warn

- If POS aplication is offline a message is shown

---
M web/org.openbravo.retail.discounts.coupons/js/couponcode-popup.js
---
(0108196)
hgbot (developer)
2018-11-30 17:00

Repository: tools/automation/pi-mobile
Changeset: 0d184942e94668e67b4ccd6242e43dfa19432ea4
Author: Alejandro <alekosmp86 <at> gmail.com>
Date: Wed Nov 28 16:07:56 2018 -0500
URL: http://code.openbravo.com/tools/automation/pi-mobile/rev/0d184942e94668e67b4ccd6242e43dfa19432ea4 [^]

Related to issue 39674: added automated test

---
M src-test/org/openbravo/test/mobile/core/utils/AllowedErrorsHelper.java
A src-test/org/openbravo/test/mobile/retail/extmodules/selenium/tests/discounts_coupons/I39674_VerifyMessageWhenUsingCouponInOfflineMode.java
---
(0108263)
umartirena (developer)
2018-12-05 09:05

The message returned it is not clear for me. It should inform the user that the operation is not permitted while being offline.
(0108283)
hgbot (developer)
2018-12-05 14:59

Repository: erp/pmods/org.openbravo.retail.discounts.coupons
Changeset: 148ef853cb3c7a0ed0a50fdee8143cacb105363a
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Wed Dec 05 14:59:29 2018 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.discounts.coupons/rev/148ef853cb3c7a0ed0a50fdee8143cacb105363a [^]

Related to issue 39674. Clarified error message

---
M src-db/database/sourcedata/AD_MESSAGE.xml
---
(0109286)
hgbot (developer)
2019-01-28 18:33

Repository: tools/automation/pi-mobile
Changeset: 4e2cf8bbd619e9a1d51d91db2353b8968e02e125
Author: Alejandro <alekosmp86 <at> gmail.com>
Date: Wed Jan 23 11:11:49 2019 -0500
URL: http://code.openbravo.com/tools/automation/pi-mobile/rev/4e2cf8bbd619e9a1d51d91db2353b8968e02e125 [^]

Related to issue 39674: test has been refactored due to it no longer creates its
own sampledata

---
M src-test/org/openbravo/test/mobile/retail/extmodules/selenium/tests/discounts_coupons/I39674_VerifyMessageWhenUsingCouponInOfflineMode.java
---

- Issue History
Date Modified Username Field Change
2018-11-22 11:18 umartirena New Issue
2018-11-22 11:18 umartirena Assigned To => Retail
2018-11-22 11:18 umartirena Triggers an Emergency Pack => No
2018-11-23 05:08 rqueralta Assigned To Retail => rqueralta
2018-11-23 05:08 rqueralta Status new => scheduled
2018-11-27 23:01 hgbot Checkin
2018-11-27 23:01 hgbot Note Added: 0108138
2018-11-27 23:01 hgbot Status scheduled => resolved
2018-11-27 23:01 hgbot Resolution open => fixed
2018-11-27 23:01 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.discounts.coupons/rev/f7c03d32673282c26f72e1b98f9de140e1234574 [^]
2018-11-30 17:00 hgbot Checkin
2018-11-30 17:00 hgbot Note Added: 0108196
2018-12-04 15:17 marvintm Review Assigned To => marvintm
2018-12-04 15:17 marvintm Status resolved => closed
2018-12-04 15:17 marvintm Fixed in Version => RR19Q1
2018-12-05 09:05 umartirena Note Added: 0108263
2018-12-05 14:59 hgbot Checkin
2018-12-05 14:59 hgbot Note Added: 0108283
2019-01-28 18:33 hgbot Checkin
2019-01-28 18:33 hgbot Note Added: 0109286


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker