Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0039634
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajoralways2018-11-15 13:322018-12-13 18:39
ReporterucarrionView Statuspublic 
Assigned Toranjith_qualiantech_com 
PrioritynormalResolutionfixedFixed in VersionRR19Q1
StatusclosedFix in branchFixed in SCM revisionf175e481b1ef
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomarvintm
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0039634: Scaning GUN no able to scan C&R documents

DescriptionScaning GUN no able to scan C&R documents

"The scanning gun is not reading the correct characters when scanning C&R document (see below, for example: 214.105/0000417-1).

What is scanning currently: 214.105-0000417ç'1
What it should to scan: 214.105/0000417\-1


---UCA 1511: The main problem is now around setting the scanning gun. Manually (using the keyboard) there´s no problem to simulate the scan (thanks to issue https://issues.openbravo.com/view.php?id=39593 [^]). But in spite of applying that fix in production, in the stores the problem will persist when using the scanning gun (but it will work when simulating the scanning manually on the keypad)"

The doc.no for C&R documents has to be changed. The '-' character has to be '.' onwards just for a correct scanning in BUT, french keyboard. (due to lots of problems generated by the '\' for the scanning).
Steps To Reproduce+Create a C&R document
+Scan it with the gun
Proposed SolutionA new field should be created at organization window, in the "Web POS formats". This field should have default value "-". Its value should be loaded in the WebPOS, and used as separator for the Cancel and Replace tickets.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
has duplicate defect 0039593 closedjorge-garcia '\' character does not work in Webpos 

-  Notes
(0108314)
hgbot (developer)
2018-12-06 14:08

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: aafd48c78bac4a75ac9a9bc71847a0ea71e154d2
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Thu Dec 06 18:38:04 2018 +0530
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/aafd48c78bac4a75ac9a9bc71847a0ea71e154d2 [^]

Fixed issue 39634 : Added New Field in Org for Cancel and Replace Document No Separator

---
M src-db/database/model/modifiedTables/AD_ORG.xml
M src-db/database/sourcedata/AD_COLUMN.xml
M src-db/database/sourcedata/AD_ELEMENT.xml
M src-db/database/sourcedata/AD_FIELD.xml
M src/org/openbravo/retail/posterminal/term/TerminalProperties.java
M web/org.openbravo.retail.posterminal/js/model/order.js
---
(0108315)
hgbot (developer)
2018-12-06 14:08

Repository: erp/pmods/org.openbravo.retail.sampledata
Changeset: 11e1aadb7928555613b7ce9fec4feb770c4d9738
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Thu Dec 06 18:38:31 2018 +0530
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.sampledata/rev/11e1aadb7928555613b7ce9fec4feb770c4d9738 [^]

Related to issue 39634 : Added sample data for Cancel and Replace Document No Separator in Org table

---
M referencedata/sampledata/The_White_Valley_Group/AD_ORG.xml
---
(0108327)
marvintm (developer)
2018-12-07 12:20

Fix is not fully correct. The existing code searches for the separator character, so that if subsequent cancel and replace actions are executed, the document number first is 1, then 2, ...
VBS1/0000092
VBS1/0000092-1
VBS1/0000092-2
...

However, if we change the character to ".", then this part doesn't work:
VBS1/0000092
VBS1/0000092.1
VBS1/0000092.1.1
VBS1/0000092.1.1.1
...

The reason is that these two statements still have previous default value hardcoded:

splittedDocNo = me.get('documentNo').substring(terminalDocNoPrefix.length, me.get('documentNo').length).split('-');

newDocNo = me.get('documentNo').substring(0, me.get('documentNo').lastIndexOf('-')) + OB.MobileApp.model.get('terminal').cancelAndReplaceSeparator + nextNumber;

The '-' needs to be replaced by the cancelAndReplaceSeparator character.
(0108352)
hgbot (developer)
2018-12-10 07:30

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: f175e481b1efe27fe636cc3112ee4b6e43461015
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Mon Dec 10 11:59:54 2018 +0530
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/f175e481b1efe27fe636cc3112ee4b6e43461015 [^]

Fixed issue 39634 : Separator must be used for generating Cancel And Replace Document No

* While generating Cancel And Replace Document No, Separator must be used to split order no

---
M web/org.openbravo.retail.posterminal/js/model/order.js
---

- Issue History
Date Modified Username Field Change
2018-11-15 13:32 ucarrion New Issue
2018-11-15 13:32 ucarrion Assigned To => Retail
2018-11-15 13:32 ucarrion Triggers an Emergency Pack => No
2018-11-17 00:36 marvintm Relationship added has duplicate 0039593
2018-11-20 18:02 rqueralta Assigned To Retail => rqueralta
2018-11-28 16:08 ucarrion Description Updated View Revisions
2018-11-28 16:08 ucarrion Proposed Solution updated
2018-11-28 16:18 marvintm Proposed Solution updated
2018-12-05 10:02 ranjith_qualiantech_com Assigned To rqueralta => ranjith_qualiantech_com
2018-12-05 10:02 ranjith_qualiantech_com Status new => scheduled
2018-12-06 14:08 hgbot Checkin
2018-12-06 14:08 hgbot Note Added: 0108314
2018-12-06 14:08 hgbot Status scheduled => resolved
2018-12-06 14:08 hgbot Resolution open => fixed
2018-12-06 14:08 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/aafd48c78bac4a75ac9a9bc71847a0ea71e154d2 [^]
2018-12-06 14:08 hgbot Checkin
2018-12-06 14:08 hgbot Note Added: 0108315
2018-12-07 12:20 marvintm Note Added: 0108327
2018-12-07 12:20 marvintm Status resolved => new
2018-12-07 12:20 marvintm Resolution fixed => open
2018-12-07 14:16 ranjith_qualiantech_com Status new => scheduled
2018-12-10 07:30 hgbot Checkin
2018-12-10 07:30 hgbot Note Added: 0108352
2018-12-10 07:30 hgbot Status scheduled => resolved
2018-12-10 07:30 hgbot Resolution open => fixed
2018-12-10 07:30 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/aafd48c78bac4a75ac9a9bc71847a0ea71e154d2 [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/f175e481b1efe27fe636cc3112ee4b6e43461015 [^]
2018-12-13 18:39 marvintm Review Assigned To => marvintm
2018-12-13 18:39 marvintm Status resolved => closed
2018-12-13 18:39 marvintm Fixed in Version => RR19Q1


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker